# Elasticsearch fails to start after install with custom paths, possible BUG

**URL:** <https://discuss.elastic.co/t/elasticsearch-fails-to-start-after-install-with-custom-paths-possible-bug/384091>\
**Category:** Elastic Search\
**Created:** [December 15, 2025, 8:41pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-after-install-with-custom-paths-possible-bug/384091 "2025-12-15T20:41:00Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![commandline](https://avatars.discourse-cdn.com/v4/letter/c/8baadc/32.png) [@commandline](https://discuss.elastic.co/u/commandline)\
**Post date:** [December 15, 2025, 8:41pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-after-install-with-custom-paths-possible-bug/384091/1 "2025-12-15T20:41:00Z")

</div>

when installing elasticsearch with custom paths set in /etc/elasticsearch/elasticsearch.yml and no other change this throws a very uninformative and annoying error.

```auto
systemd-entrypoint\[13576\]: ERROR: Unable to create logs dir \[/srv/elastic/log\], with exit code 78

```

the binary /usr/share/elasticsearch/bin/systemd-entrypoint can be manually invoked to no avail

changes made were to set in elasticsearch.yml

```auto
 path:
      data: /srv/elastic/esdata
      logs: /srv/elastic/eslogs
      repo: /srv/elastic/esrepo

```

eventually the ‘Unable to create’ issue is a read issue of sorts

try either of

```auto
chmod 750 /src/elastic

```

```auto
chmod 755 /src/elastic

```

when this error should continue to occur

assure the ownership is set

```auto
chmod -R elasticsearch:elasticsearch /srv/elastic

```

though i’m not yet confident that’s a sane ownership permission to set  
my guess is

```auto
chmod -R root:elasticsearch /srv/elastic

```

could work too

crazy part is this issue was not resolved until the permission is manually set  
reinstalled multiple times, also when remove all possible folders

eventually the process to stuck on a node.lock file, which was fixed after

```auto
rm /srv/elastic/data/node.lock

```

```auto
systemctl restart elasticsearch

```

---

<div class="post-metadata">

**Author:** ![RainTown](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/raintown/32/140206_2.png) [@RainTown](https://discuss.elastic.co/u/RainTown)\
**Post date:** [December 15, 2025, 8:49pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-after-install-with-custom-paths-possible-bug/384091/2 "2025-12-15T20:49:19Z")

</div>

> [@commandline](#):
>
> ```auto
> chmod 750 /src/elastic
> 
> ```
> 
> ```auto
> chmod 755 /src/elastic
> 
> ```

I don't know if those are typos, but `/src/...` != `/srv/...`

Outside that, I do not really understand what's the possible bug you are reporting? if you set custom paths, you need to set ownership/perms correctly? What am I missing/misunderstanding?
