# Elasticsearch fails to start on ubuntu 20.04

**URL:** <https://discuss.elastic.co/t/elasticsearch-fails-to-start-on-ubuntu-20-04/262684>\
**Category:** Elasticsearch\
**Created:** [January 29, 2021, 8:21pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-on-ubuntu-20-04/262684 "2021-01-29T20:21:47Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![josephthejoe](https://avatars.discourse-cdn.com/v4/letter/j/e495f1/32.png) [@josephthejoe](https://discuss.elastic.co/u/josephthejoe)\
**Post date:** [January 29, 2021, 8:21pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-on-ubuntu-20-04/262684/1 "2021-01-29T20:21:47Z")

</div>

There seems to be a lot of these types of posts ive gone through a ton of them and havent been able to find one spitting out similar errors to what I have. No logs just the output from systemctl status.

```auto
lab@siem:~$ systemctl status elasticsearch.service
● elasticsearch.service - Elasticsearch
     Loaded: loaded (/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Fri 2021-01-29 20:13:56 UTC; 8s ago
       Docs: https://www.elastic.co
    Process: 2734 ExecStart=/usr/share/elasticsearch/bin/systemd-entrypoint -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
   Main PID: 2734 (code=exited, status=1/FAILURE)

Jan 29 20:13:56 siem systemd-entrypoint[2788]: at java.base/sun.nio.fs.UnixFileSystemProvider.createDirectory(UnixFileSystemProvider.java:388)
Jan 29 20:13:56 siem systemd-entrypoint[2788]: at java.base/java.nio.file.Files.createDirectory(Files.java:694)
Jan 29 20:13:56 siem systemd-entrypoint[2788]: at java.base/java.nio.file.TempFileHelper.create(TempFileHelper.java:135)
Jan 29 20:13:56 siem systemd-entrypoint[2788]: at java.base/java.nio.file.TempFileHelper.createTempDirectory(TempFileHelper.java:172)
Jan 29 20:13:56 siem systemd-entrypoint[2788]: at java.base/java.nio.file.Files.createTempDirectory(Files.java:1011)
Jan 29 20:13:56 siem systemd-entrypoint[2788]: at org.elasticsearch.tools.launchers.Launchers.createTempDirectory(Launchers.java:66)
Jan 29 20:13:56 siem systemd-entrypoint[2788]: at org.elasticsearch.tools.launchers.TempDirectory.main(TempDirectory.java:54)
Jan 29 20:13:56 siem systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
Jan 29 20:13:56 siem systemd[1]: elasticsearch.service: Failed with result 'exit-code'.
Jan 29 20:13:56 siem systemd[1]: Failed to start Elasticsearch.

```

Has anyone seen a similar problem? This was working before but after a reboot it stopped working. Logs are saved to a NFS share which I thought was the problem at first but its connected and working now.

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [January 30, 2021, 5:15pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-on-ubuntu-20-04/262684/2 "2021-01-30T17:15:19Z")

</div>

There should be a lot more information in de Elasticsearch logs. Checkout /var/log/elasticsearch  
From the snippet it shows there seems to be a problem with permission on a toplevel directory. ES wants to create a sub dir and is not allowed to..

---

<div class="post-metadata">

**Author:** ![josephthejoe](https://avatars.discourse-cdn.com/v4/letter/j/e495f1/32.png) [@josephthejoe](https://discuss.elastic.co/u/josephthejoe)\
**Post date:** [January 30, 2021, 5:34pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-on-ubuntu-20-04/262684/3 "2021-01-30T17:34:01Z")

</div>

Unfortunately there is nothing in the log file

```auto
lab@siem:~$ sudo tail -100 /var/log/elasticsearch/elasticsearch.log
lab@siem:~$

```

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [January 30, 2021, 5:35pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-on-ubuntu-20-04/262684/4 "2021-01-30T17:35:39Z")

</div>

Try starting ES in the forground, that might tell you whats wrong..

---

<div class="post-metadata">

**Author:** ![josephthejoe](https://avatars.discourse-cdn.com/v4/letter/j/e495f1/32.png) [@josephthejoe](https://discuss.elastic.co/u/josephthejoe)\
**Post date:** [January 30, 2021, 5:37pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-on-ubuntu-20-04/262684/5 "2021-01-30T17:37:18Z")

</div>

Im not sure I know what you mean by in the forground?

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [January 30, 2021, 5:38pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-on-ubuntu-20-04/262684/6 "2021-01-30T17:38:42Z")

</div>

Check this [run ES](https://www.elastic.co/guide/en/elasticsearch/reference/current/starting-elasticsearch.html)

---

<div class="post-metadata">

**Author:** ![HKN\_MZ](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hkn_mz/32/75678_2.png) [@HKN\_MZ](https://discuss.elastic.co/u/HKN_MZ)\
**Post date:** [January 30, 2021, 6:28pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-on-ubuntu-20-04/262684/7 "2021-01-30T18:28:58Z")

</div>

**systemctl status elasticsearch.service** hasnt said exactly error reason

Can you use this code ?  
**Journalctl -xe**

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 27, 2021, 6:29pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-on-ubuntu-20-04/262684/8 "2021-02-27T18:29:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
