# Elasticsearch Fails to Start Up within Kubernetes

**URL:** <https://discuss.elastic.co/t/elasticsearch-fails-to-start-up-within-kubernetes/318462>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Created:** [November 8, 2022, 6:12pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-up-within-kubernetes/318462 "2022-11-08T18:12:36Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![argsv](https://avatars.discourse-cdn.com/v4/letter/a/b77776/32.png) [@argsv](https://discuss.elastic.co/u/argsv)\
**Post date:** [November 8, 2022, 6:12pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-up-within-kubernetes/318462/1 "2022-11-08T18:12:37Z")

</div>

I am using elasticsearch 7.17.2 within Kubernetes. I am using the elastic operator. I am getting the following error

```auto
Exception in thread "main" java.nio.file.AccessDeniedException: /usr/share/elasticsearch/plugins/lost+found
    at java.base/sun.nio.fs.UnixException.translateToIOException(UnixException.java:90)
    at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:106)
    at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)
    at java.base/sun.nio.fs.UnixFileSystemProvider.newDirectoryStream(UnixFileSystemProvider.java:440)
    at java.base/java.nio.file.Files.newDirectoryStream(Files.java:482)
    at java.base/java.nio.file.Files.list(Files.java:3792)
    at org.elasticsearch.tools.launchers.BootstrapJvmOptions.getPluginInfo(BootstrapJvmOptions.java:49)
    at org.elasticsearch.tools.launchers.BootstrapJvmOptions.bootstrapJvmOptions(BootstrapJvmOptions.java:34)
    at org.elasticsearch.tools.launchers.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:137)
    at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:86

```

Any thoughts on why Elasticsearhc (java) is trying to read the lost+found directory?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 6, 2022, 6:13pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-up-within-kubernetes/318462/2 "2022-12-06T18:13:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
