# ElasticSearch Fails to Start with -server Option

**URL:** <https://discuss.elastic.co/t/elasticsearch-fails-to-start-with-server-option/127508>\
**Category:** Elasticsearch\
**Created:** [April 10, 2018, 2:50pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-with-server-option/127508 "2018-04-10T14:50:31Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![wwalker](https://avatars.discourse-cdn.com/v4/letter/w/43a26b/32.png) [@wwalker](https://discuss.elastic.co/u/wwalker)\
**Post date:** [April 10, 2018, 2:50pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-with-server-option/127508/1 "2018-04-10T14:50:31Z")

</div>

Elasticsearch 6.2.2 Windows installation installed as a service refuses to start with the -server option configured. Java 8u152 is installed and JAVA\_HOME variable is set. This has been running fine for months and has suddenly started. If I remove the option the service stops and consumes large amounts of RAM, though that may not be related.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 10, 2018, 8:27pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-with-server-option/127508/2 "2018-04-10T20:27:30Z")

</div>

Please post logs of what you are running and the output.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 8, 2018, 8:27pm UTC](https://discuss.elastic.co/t/elasticsearch-fails-to-start-with-server-option/127508/3 "2018-05-08T20:27:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
