# Elasticsearch for Apache Hadoop doesn't work

**URL:** <https://discuss.elastic.co/t/elasticsearch-for-apache-hadoop-doesnt-work/163971>\
**Category:** Elasticsearch\
**Tags:** es-hadoop\
**Created:** [January 12, 2019, 3:18am UTC](https://discuss.elastic.co/t/elasticsearch-for-apache-hadoop-doesnt-work/163971 "2019-01-12T03:18:14Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![spagano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spagano/32/40136_2.png) [@spagano](https://discuss.elastic.co/u/spagano)\
**Post date:** [January 22, 2019, 8:58pm UTC](https://discuss.elastic.co/t/elasticsearch-for-apache-hadoop-doesnt-work/163971/3 "2019-01-22T20:58:54Z")

</div>

hi, i don't know but in new versions is necessary to do reference to commons-httpclient-3.0.1.jar

on the hive session:

**_add jar /your\_hdphome/hadoop/lib/commons-httpclient-3.0.1.jar;_**  
**_create external table etc etc_**

try doing this roadmap:

> [@Error: Unsupported/Unknown Elasticsearch version 6.X.X](https://discuss.elastic.co/t/error-unsupported-unknown-elasticsearch-version-6-x-x/164846/2):
>
> The problem was solved. The roadmap was the following: Use hive, no beeline. Just copy elasticsearch-hadoop-6.4.3.jar to all data nodes and masters on /{HDP\_HOME}/hadoop/lib/ (hortonworks to me) Create index and type on elasticsearch curl -X POST 'localhost:9200/bookindex/books' -H 'Content-Type: application/json' -d' { "bookId" : "A00-3", "author" : "Sankaran", "publisher" : "Mcgrahill", "name" : "how to get a job" } ' On hive always to do: hive\> add jar /usr/hdp/2.6.4.0-…

---

_[View the full topic](https://discuss.elastic.co/t/elasticsearch-for-apache-hadoop-doesnt-work/163971)._
