# Elasticsearch-hadoop-2.4.2 and Elasticsearch version 5.0.0 support

**URL:** https://discuss.elastic.co/t/elasticsearch-hadoop-2-4-2-and-elasticsearch-version-5-0-0-support/67348
**Category:** Elasticsearch
**Tags:** es-hadoop
**Created:** [November 28, 2016, 1:07pm UTC](https://discuss.elastic.co/t/elasticsearch-hadoop-2-4-2-and-elasticsearch-version-5-0-0-support/67348 "2016-11-28T13:07:00Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![deepankar32](https://avatars.discourse-cdn.com/v4/letter/d/f6c823/32.png) [@deepankar32](https://discuss.elastic.co/u/deepankar32)
#### Post date: [November 28, 2016, 1:07pm UTC](https://discuss.elastic.co/t/elasticsearch-hadoop-2-4-2-and-elasticsearch-version-5-0-0-support/67348/1 "2016-11-28T13:07:00Z")

</div>

Hi,

Please let meknow the compatible ES Hadoop version for elasticsearch version 5.0

Caused by: org.elasticsearch.hadoop.EsHadoopIllegalArgumentException: Unsupported/Unknown Elasticsearch version 5.0.0  
at org.elasticsearch.hadoop.rest.InitializationUtils.discoverEsVersion(InitializationUtils.java:191)  
... 16 more  
2016-11-28 07:55:01,467 [main] WARN org.apache.pig.backend.hadoop.executionengine.mapReduceLayer.MapReduceLauncher - Ooops! Some job has failed! Specify -stop\_on\_failure if you want Pig to stop immediately on failure.  
2016-11-28 07:55:01,468 [main] INFO org.apache.pig.backend.hadoop.executionengine.mapReduceLayer.MapReduceLauncher - job job\_local\_0001 has failed! Stop running all dependent jobs

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [November 28, 2016, 1:45pm UTC](https://discuss.elastic.co/t/elasticsearch-hadoop-2-4-2-and-elasticsearch-version-5-0-0-support/67348/2 "2016-11-28T13:45:59Z")

</div>

According to the [support matrix](https://www.elastic.co/support/matrix#show_compatibility) you will need to upgrade to version 5.0 of the ES-Hadoop connector.

---

<div class="post-metadata">

### Author: ![deepankar32](https://avatars.discourse-cdn.com/v4/letter/d/f6c823/32.png) [@deepankar32](https://discuss.elastic.co/u/deepankar32)
#### Post date: [November 28, 2016, 1:47pm UTC](https://discuss.elastic.co/t/elasticsearch-hadoop-2-4-2-and-elasticsearch-version-5-0-0-support/67348/3 "2016-11-28T13:47:07Z")

</div>

Thanks..Its working with 5.0

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 26, 2016, 1:47pm UTC](https://discuss.elastic.co/t/elasticsearch-hadoop-2-4-2-and-elasticsearch-version-5-0-0-support/67348/4 "2016-12-26T13:47:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
