# ElasticSearch Hadoop Repository issue

**URL:** <https://discuss.elastic.co/t/elasticsearch-hadoop-repository-issue/98505>\
**Category:** Elasticsearch\
**Tags:** es-hadoop\
**Created:** [August 28, 2017, 4:06am UTC](https://discuss.elastic.co/t/elasticsearch-hadoop-repository-issue/98505 "2017-08-28T04:06:46Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![karthiga\_sivaraman](https://avatars.discourse-cdn.com/v4/letter/k/45deac/32.png) [@karthiga\_sivaraman](https://discuss.elastic.co/u/karthiga_sivaraman)\
**Post date:** [August 28, 2017, 4:06am UTC](https://discuss.elastic.co/t/elasticsearch-hadoop-repository-issue/98505/1 "2017-08-28T04:06:46Z")

</div>

In out production environment we are having Cloudera distributed Hadoop version 2.6.0-cdh5.11.0 and our Elastic search version is 2.4.1.  
If I install repository-hdfs plugin , I'm getting hadoop-2.7.1 And it ends in hadoop version conflicts.  
So I replaced all the jars in hadoop-libs to the relevant Hadoop version in my production environment (i.e 2.6.0-cdh5.11.0) .  
Now while starting Elastic search its showing error like ,  
Error -1 ;  
Unable to load native-hadoop library for your platform... using builtin-java classes where applicable  
[2017-08-28 09:28:43,201][WARN][repositories] [Plasma] failed to create repository [hdfs][hadoop]  
org.elasticsearch.common.inject.CreationException: Guice creation errors:

1. Error injecting constructor, ElasticsearchGenerationException[Cannot create Hdfs file-system for uri [hdfs://52.220.175.57:8020/]]; nested: HadoopIllegalArgumentException[The short-circuit local reads feature is enabled but dfs.domain.socket.path is not set.];  
at org.elasticsearch.repositories.hdfs.HdfsRepository.(Unknown Source)  
while locating org.elasticsearch.repositories.hdfs.HdfsRepository  
while locating org.elasticsearch.repositories.Repository

Kindly help me out...

---

<div class="post-metadata">

**Author:** ![james.baiera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/james.baiera/32/10209_2.png) [@james.baiera](https://discuss.elastic.co/u/james.baiera)\
**Post date:** [September 12, 2017, 3:01pm UTC](https://discuss.elastic.co/t/elasticsearch-hadoop-repository-issue/98505/2 "2017-09-12T15:01:15Z")

</div>

The error message contains some information that would be a good starting point. It seems that the client has short-circuit local reads enabled in the settings, but the setting `dfs.domain.socket.path` is not set, thus throwing an error. Are you setting short-circuit local reads to enabled in the repository settings? How are you loading your configurations?

---

<div class="post-metadata">

**Author:** ![karthiga\_sivaraman](https://avatars.discourse-cdn.com/v4/letter/k/45deac/32.png) [@karthiga\_sivaraman](https://discuss.elastic.co/u/karthiga_sivaraman)\
**Post date:** [September 22, 2017, 4:44am UTC](https://discuss.elastic.co/t/elasticsearch-hadoop-repository-issue/98505/3 "2017-09-22T04:44:46Z")

</div>

Ya we have enabled the property "dfs.domain.socket.path " and assigned a path as well. Eventhough its showing eerror.

---

<div class="post-metadata">

**Author:** ![james.baiera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/james.baiera/32/10209_2.png) [@james.baiera](https://discuss.elastic.co/u/james.baiera)\
**Post date:** [October 4, 2017, 3:40am UTC](https://discuss.elastic.co/t/elasticsearch-hadoop-repository-issue/98505/4 "2017-10-04T03:40:15Z")

</div>

Could you include your HDFS repository settings here? Is this property required for you? Are you hosting HDFS nodes and ES nodes on the same hardware?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 1, 2017, 3:40am UTC](https://discuss.elastic.co/t/elasticsearch-hadoop-repository-issue/98505/5 "2017-11-01T03:40:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
