# Elasticsearch heapdump using jmap

**URL:** <https://discuss.elastic.co/t/elasticsearch-heapdump-using-jmap/18606>\
**Category:** Elasticsearch\
**Created:** [July 11, 2014, 4:16pm UTC](https://discuss.elastic.co/t/elasticsearch-heapdump-using-jmap/18606 "2014-07-11T16:16:36Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![nc1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nc1/32/70487_2.png) [@nc1](https://discuss.elastic.co/u/nc1)\
**Post date:** [July 11, 2014, 4:16pm UTC](https://discuss.elastic.co/t/elasticsearch-heapdump-using-jmap/18606/1 "2014-07-11T16:16:36Z")

</div>

Over last few days noticed more GC in my es cluster and was trying to take  
a look at heap .. I'm runnning Es over wrapper, running on EC2 , with  
Amazon linux AMI

Always get this message with jmap -J-d64 -histo

"Unable to open socket file: target process not responding or HotSpot VM  
not loaded."

Tried , with -F option - that works, but wasnt able to provide all objects

- since it fails with bad Address error ( i think using -F , thats always a  
high possibility )

If anyone successfully took a heap dump - help will be appreciated !

TIA  
Nirmal

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/5cf70106-d308-4b4c-bbb1-722dcb934c52%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/5cf70106-d308-4b4c-bbb1-722dcb934c52%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Szasz\_Tamas](https://avatars.discourse-cdn.com/v4/letter/s/848f3c/32.png) [@Szasz\_Tamas](https://discuss.elastic.co/u/Szasz_Tamas)\
**Post date:** [September 18, 2014, 1:23pm UTC](https://discuss.elastic.co/t/elasticsearch-heapdump-using-jmap/18606/2 "2014-09-18T13:23:27Z")

</div>

It clearly says, you have to use -F

On Friday, July 11, 2014 6:16:36 PM UTC+2, NC wrote:

> Over last few days noticed more GC in my es cluster and was trying to take  
> a look at heap .. I'm runnning Es over wrapper, running on EC2 , with  
> Amazon linux AMI
> 
> Always get this message with jmap -J-d64 -histo
> 
> "Unable to open socket file: target process not responding or HotSpot VM  
> not loaded."
> 
> Tried , with -F option - that works, but wasnt able to provide all objects
> 
> - since it fails with bad Address error ( i think using -F , thats always a  
> high possibility )
> 
> If anyone successfully took a heap dump - help will be appreciated !
> 
> TIA  
> Nirmal

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/7a74d52e-285b-4d87-9bea-d80041118dd3%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/7a74d52e-285b-4d87-9bea-d80041118dd3%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:01am UTC](https://discuss.elastic.co/t/elasticsearch-heapdump-using-jmap/18606/3 "2017-07-06T01:01:15Z")

</div>


