# Elasticsearch hive "cannot handle type" exception

**URL:** <https://discuss.elastic.co/t/elasticsearch-hive-cannot-handle-type-exception/15702>\
**Category:** Elasticsearch\
**Created:** [February 10, 2014, 5:32pm UTC](https://discuss.elastic.co/t/elasticsearch-hive-cannot-handle-type-exception/15702 "2014-02-10T17:32:06Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sameer\_Abhyankar](https://avatars.discourse-cdn.com/v4/letter/s/b3f665/32.png) [@Sameer\_Abhyankar](https://discuss.elastic.co/u/Sameer_Abhyankar)\
**Post date:** [February 10, 2014, 5:32pm UTC](https://discuss.elastic.co/t/elasticsearch-hive-cannot-handle-type-exception/15702/1 "2014-02-10T17:32:06Z")

</div>

Hello,

I am new to the Elasticsearch Hadoop integration and was attempting to use  
an external table to index certain fields. The table creation is  
successful. However, when i try to do a insert i get the following error  
message:

Caused by: org.apache.hadoop.hive.ql.metadata.HiveException: Hive Runtime  
Error while processing row {"session":12345,"invnum":"ABCXYZ"}  
at  
org.apache.hadoop.hive.ql.exec.MapOperator.process(MapOperator.java:544)  
at  
org.apache.hadoop.hive.ql.exec.mr.ExecMapper.map(ExecMapper.java:157)  
... 8 more  
Caused by: org.elasticsearch.hadoop.serialization.SerializationException:  
Cannot handle type [class org.elasticsearch.hadoop.hive.HiveType], instance  
[org.elasticsearch.hadoop.hive.HiveType@4fa36719] using writer  
[org.elasticsearch.hadoop.hive.HiveValueWriter@70c5c327]  
at  
org.elasticsearch.hadoop.serialization.ContentBuilder.value(ContentBuilder.java:252)  
at org.elasticsearch.hadoop.hive.ESSerDe.serialize(ESSerDe.java:100)  
at  
org.apache.hadoop.hive.ql.exec.FileSinkOperator.processOp(FileSinkOperator.java:618)  
at  
org.apache.hadoop.hive.ql.exec.Operator.process(Operator.java:504)  
at  
org.apache.hadoop.hive.ql.exec.Operator.forward(Operator.java:842)  
at  
org.apache.hadoop.hive.ql.exec.SelectOperator.processOp(SelectOperator.java:88)  
at  
org.apache.hadoop.hive.ql.exec.Operator.process(Operator.java:504)  
at  
org.apache.hadoop.hive.ql.exec.Operator.forward(Operator.java:842)  
at  
org.apache.hadoop.hive.ql.exec.TableScanOperator.processOp(TableScanOperator.java:91)  
at  
org.apache.hadoop.hive.ql.exec.Operator.process(Operator.java:504)  
at  
org.apache.hadoop.hive.ql.exec.Operator.forward(Operator.java:842)  
at  
org.apache.hadoop.hive.ql.exec.MapOperator.process(MapOperator.java:534)  
... 9 more

FAILED: Execution Error, return code 2 from  
org.apache.hadoop.hive.ql.exec.mr.MapRedTask  
14/02/10 12:18:19 ERROR ql.Driver: FAILED: Execution Error, return code 2  
from org.apache.hadoop.hive.ql.exec.mr.MapRedTask

Any ideas as to what might be causing this error?

I am using M1 yarn jar files and ES 0.90.10

Thanks!  
Sameer

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/384392ad-7b1e-40b0-8b91-5bff0faed4f1%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/384392ad-7b1e-40b0-8b91-5bff0faed4f1%40googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:51am UTC](https://discuss.elastic.co/t/elasticsearch-hive-cannot-handle-type-exception/15702/2 "2017-07-06T01:51:24Z")

</div>


