# Elasticsearch https error

**URL:** <https://discuss.elastic.co/t/elasticsearch-https-error/201723>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [October 1, 2019, 5:00am UTC](https://discuss.elastic.co/t/elasticsearch-https-error/201723 "2019-10-01T05:00:39Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Vikas\_Yadav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vikas_yadav/32/54987_2.png) [@Vikas\_Yadav](https://discuss.elastic.co/u/Vikas_Yadav)\
**Post date:** [October 1, 2019, 5:00am UTC](https://discuss.elastic.co/t/elasticsearch-https-error/201723/1 "2019-10-01T05:00:39Z")

</div>

this error occured while configuring elasticsearch for https  
Caused by: java.security.AccessControlException: access denied ("java.io.FilePermission" "/usr/share/elasticsearch/config/certs/elastic-certificates.p12" "read")  
at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472) ~[?:?]  
at java.security.AccessController.checkPermission(AccessController.java:1044) ~[?:?]

---

<div class="post-metadata">

**Author:** ![Vikas\_Yadav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vikas_yadav/32/54987_2.png) [@Vikas\_Yadav](https://discuss.elastic.co/u/Vikas_Yadav)\
**Post date:** [October 1, 2019, 5:13am UTC](https://discuss.elastic.co/t/elasticsearch-https-error/201723/2 "2019-10-01T05:13:00Z")

</div>

also tried changing the location of file to /etc/elasticsearch/config/elastic-certificates.p12  
same error access denied

---

<div class="post-metadata">

**Author:** ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)\
**Post date:** [October 1, 2019, 6:39am UTC](https://discuss.elastic.co/t/elasticsearch-https-error/201723/3 "2019-10-01T06:39:40Z")

</div>

The user as which elasticsearch runs doesn't have access to read the file, as clearly stated by the exception. What are the file permissions and the owner of this file ? Check with

```auto
ls -la /etc/elasticsearch/config/elastic-certificates.p12

```

> [@Vikas\_Yadav](#):
>
> also tried changing the location of file to

The location of this file should be _very specific_ and it can only be within a the configuration directory of elasticsearch. If you installed Elasticsearch with the deb or rpm package this is`/etc/elasticsearch`

---

<div class="post-metadata">

**Author:** ![Vikas\_Yadav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vikas_yadav/32/54987_2.png) [@Vikas\_Yadav](https://discuss.elastic.co/u/Vikas_Yadav)\
**Post date:** [October 1, 2019, 10:59am UTC](https://discuss.elastic.co/t/elasticsearch-https-error/201723/4 "2019-10-01T10:59:04Z")

</div>

thanks got it resolved

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 29, 2019, 11:04am UTC](https://discuss.elastic.co/t/elasticsearch-https-error/201723/5 "2019-10-29T11:04:25Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
