# Elasticsearch index issues

**URL:** https://discuss.elastic.co/t/elasticsearch-index-issues/73871
**Category:** Elasticsearch
**Created:** [February 3, 2017, 2:57pm UTC](https://discuss.elastic.co/t/elasticsearch-index-issues/73871 "2017-02-03T14:57:50Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![aFowlerAtWork](https://avatars.discourse-cdn.com/v4/letter/a/7ba0ec/32.png) [@aFowlerAtWork](https://discuss.elastic.co/u/aFowlerAtWork)
#### Post date: [February 3, 2017, 2:57pm UTC](https://discuss.elastic.co/t/elasticsearch-index-issues/73871/1 "2017-02-03T14:57:50Z")

</div>

i have an Ubuntu 16.04 VM running ELK stack.

installed an older versions of elastic, kibana, lostash and wrote an index to pull data from a MySQL database. it worked.

updated kibana and elastic to 5.1.2 and logstash to 5. something

added xpack to kibana and elastic

disabled security (this is only a proof of concept)

updated the xpack license

now the graph plugin doesnt work; its not present in Kibana UI.  
logstash logs show no errors and that data is being pulled from the database.

i have the free BASIC license: no sure if this is a problem:  
ubuntu@ubuntu-VirtualBox:~$ curl -XGET localhost:9200/.monitoring-es-2-2017.01.17?pretty  
{  
"error" : {  
"root\_cause" : [  
{  
"type" : "index\_not\_found\_exception",  
"reason" : "no such index",  
"resource.type" : "index\_or\_alias",  
"[resource.id](http://resource.id)" : ".monitoring-es-2-2017.01.17",  
"index\_uuid" : "_na_",  
"index" : ".monitoring-es-2-2017.01.17"  
}  
],  
"type" : "index\_not\_found\_exception",  
"reason" : "no such index",  
"resource.type" : "index\_or\_alias",  
"[resource.id](http://resource.id)" : ".monitoring-es-2-2017.01.17",  
"index\_uuid" : "_na_",  
"index" : ".monitoring-es-2-2017.01.17"  
},  
"status" : 404  
}

from the elasticsearch log:  
[2017-02-03T09:56:20,470][ERROR][o.e.x.m.AgentService] [v2HOWFX] exception when exporting documents  
org.elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulks  
at org.elasticsearch.xpack.monitoring.exporter.ExportBulk$Compound.doFlush(ExportBulk.java:148) ~[x-pack-5.1.2.jar:5.1.2]  
at org.elasticsearch.xpack.monitoring.exporter.ExportBulk.close(ExportBulk.java:77) ~[x-pack-5.1.2.jar:5.1.2]  
at org.elasticsearch.xpack.monitoring.exporter.Exporters.export(Exporters.java:183) ~[x-pack-5.1.2.jar:5.1.2]  
at org.elasticsearch.xpack.monitoring.AgentService$ExportingWorker.run(AgentService.java:208) [x-pack-5.1.2.jar:5.1.2]  
at java.lang.Thread.run(Thread.java:745) [?:1.8.0\_121]  
Caused by: org.elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulk [default\_local]  
at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.doFlush(LocalBulk.java:114) ~[?:?]  
at org.elasticsearch.xpack.monitoring.exporter.ExportBulk.flush(ExportBulk.java:62) ~[?:?]  
at org.elasticsearch.xpack.monitoring.exporter.ExportBulk$Compound.doFlush(ExportBulk.java:145) ~[?:?]  
... 4 more  
Caused by: org.elasticsearch.xpack.monitoring.exporter.ExportException: bulk [default\_local] reports failures when exporting documents  
at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.throwExportException(LocalBulk.java:121) ~[?:?]  
at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.doFlush(LocalBulk.java:111) ~[?:?]  
at org.elasticsearch.xpack.monitoring.exporter.ExportBulk.flush(ExportBulk.java:62) ~[?:?]  
at org.elasticsearch.xpack.monitoring.exporter.ExportBulk$Compound.doFlush(ExportBulk.java:145) ~[?:?]  
... 4 more

---

<div class="post-metadata">

### Author: ![aFowlerAtWork](https://avatars.discourse-cdn.com/v4/letter/a/7ba0ec/32.png) [@aFowlerAtWork](https://discuss.elastic.co/u/aFowlerAtWork)
#### Post date: [February 3, 2017, 3:24pm UTC](https://discuss.elastic.co/t/elasticsearch-index-issues/73871/2 "2017-02-03T15:24:22Z")

</div>

logstash-plain.log:  
[2017-02-03T10:23:00,159][INFO][logstash.inputs.jdbc] (0.111000s) SELECT \* from testtable  
[2017-02-03T10:23:03,526][INFO][logstash.outputs.elasticsearch] Elasticsearch pool URLs updated {:changes=\>{:removed=\>["[http://localhost:9200](http://localhost:9200)"], :added=\>[]}}  
[2017-02-03T10:23:08,544][WARN][logstash.outputs.elasticsearch] UNEXPECTED POOL ERROR {:e=\>#\<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections\>}  
[2017-02-03T10:23:08,545][WARN][logstash.outputs.elasticsearch] Elasticsearch output attempted to sniff for new connections but cannot. No living connections are detected. Pool contains the following current URLs {:url\_info=\>{}}

---

<div class="post-metadata">

### Author: ![aFowlerAtWork](https://avatars.discourse-cdn.com/v4/letter/a/7ba0ec/32.png) [@aFowlerAtWork](https://discuss.elastic.co/u/aFowlerAtWork)
#### Post date: [February 3, 2017, 4:09pm UTC](https://discuss.elastic.co/t/elasticsearch-index-issues/73871/3 "2017-02-03T16:09:32Z")

</div>

and heres my configuration:

input {  
jdbc {  
jdbc\_driver\_library =\> "/usr/share/java/mysql-connector-java-5.1.38.jar"  
jdbc\_driver\_class =\> "com.mysql.jdbc.Driver"  
jdbc\_connection\_string =\> "jdbc:mysql://localhost:3306/testdb"  
jdbc\_validate\_connection =\> true  
jdbc\_user =\>   
jdbc\_password =\>   
schedule =\> "\* \* \* \* \*"  
statement =\> "SELECT \* from testtable"  
}  
}  
output {  
elasticsearch{  
index =\> "test-migrate"  
document\_type =\> "table"  
document\_id =\> "PersonID"  
hosts =\> "localhost:9200"  
sniffing =\> false  
}  
stdout{  
codec =\> json\_lines  
}

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [February 5, 2017, 9:28am UTC](https://discuss.elastic.co/t/elasticsearch-index-issues/73871/4 "2017-02-05T09:28:12Z")

</div>

> [@aFowlerAtWork](#):
>
> now the graph plugin doesnt work; its not present in Kibana UI.logstash logs show no errors and that data is being pulled from the database.
> 
> i have the free BASIC license: no sure if this is a problem:

Basic licenses do not have access to Graph.

---

<div class="post-metadata">

### Author: ![aFowlerAtWork](https://avatars.discourse-cdn.com/v4/letter/a/7ba0ec/32.png) [@aFowlerAtWork](https://discuss.elastic.co/u/aFowlerAtWork)
#### Post date: [February 6, 2017, 2:25pm UTC](https://discuss.elastic.co/t/elasticsearch-index-issues/73871/5 "2017-02-06T14:25:41Z")

</div>

i eventually figured out the BASIC license restriction.

what about the "type" : "index\_not\_found\_exception"?

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [February 7, 2017, 6:30am UTC](https://discuss.elastic.co/t/elasticsearch-index-issues/73871/6 "2017-02-07T06:30:33Z")

</div>

Doe the index exist?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 7, 2017, 6:30am UTC](https://discuss.elastic.co/t/elasticsearch-index-issues/73871/7 "2017-03-07T06:30:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
