# Elasticsearch IndexShardMissingException

**URL:** <https://discuss.elastic.co/t/elasticsearch-indexshardmissingexception/9334>\
**Category:** Elasticsearch\
**Created:** [October 12, 2012, 10:50am UTC](https://discuss.elastic.co/t/elasticsearch-indexshardmissingexception/9334 "2012-10-12T10:50:07Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![l00l](https://avatars.discourse-cdn.com/v4/letter/l/a183cd/32.png) [@l00l](https://discuss.elastic.co/u/l00l)\
**Post date:** [October 12, 2012, 10:50am UTC](https://discuss.elastic.co/t/elasticsearch-indexshardmissingexception/9334/1 "2012-10-12T10:50:07Z")

</div>

I receive this error whenever I start my node.  
  
What's going wrong?

[2012-10-12 10:00:38,196][DEBUG][action.admin.indices.status] [Gorgilla] [monitoring][1], node[dbnnA1NOQ1ubysyADvazFg], [P], s[INITIALIZING]: Failed to execute [org.elasticsearch.action.admin.indices.status.IndicesStatusRequest@968f9]  
org.elasticsearch.index. **IndexShardMissingException** : [monitoring][1] missing  
at org.elasticsearch.index.service.InternalIndexService.shardSafe(InternalIndexService.java:175)  
at org.elasticsearch.action.admin.indices.status.TransportIndicesStatusAction.shardOperation(TransportIndicesStatusAction.java:153)  
at org.elasticsearch.action.admin.indices.status.TransportIndicesStatusAction.shardOperation(TransportIndicesStatusAction.java:59)  
at org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$AsyncBroadcastAction.performOperation(TransportBroadcastOperationAction.java:234)  
at org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$AsyncBroadcastAction.performOperation(TransportBroadcastOperationAction.java:211)  
at org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$AsyncBroadcastAction$1.run(TransportBroadcastOperationAction.java:187)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)  
at java.lang.Thread.run(Thread.java:636)

  
  
my ES version -\> 0.19.0  
  

settings:  
  
ES\_HOME/bin/service/elasticsearch.conf file:  
  
&nbsp;set.default.ES\_HEAP\_SIZE=1024  
  
&nbsp;set.default.ES\_MIN\_MEM=1048576  
  
&nbsp;set.default.ES\_MAX\_MEM=1048576  
  
  
  
elasticsearch.yml  
  
&nbsp;index.cache.field.type: soft  
  
&nbsp;index.cache.field.max\_size: 1000  
  
&nbsp;bootstrap.mlockall: true  
  
  
  
index settings:  
  
"number\_of\_shards":5  
  
"number\_of\_replicas":1  
  
  
  
  
  
  
  
Another problem that I am facing is, in the ES\_HOME/bin/service/elasticsearch.conf file when I change set.default.ES\_HEAP\_SIZE=(from "1024" to some large value, say "1048576"), the "rcelasticsearch start" commands fails  
to start my es server. Message that gets printed:  
  
  
$ rcelasticsearch start  
  
  
  
  
Starting ElasticSearch...  
  
Waiting for ElasticSearch.............................  
  
WARNING: ElasticSearch may have failed to start.  
  
  
  
But "elasticsearch/bin/elasticsearch -f" command works fine.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:09am UTC](https://discuss.elastic.co/t/elasticsearch-indexshardmissingexception/9334/2 "2017-07-06T03:09:04Z")

</div>


