# Elasticsearch Ingest Support For GeoIP2 ISP

**URL:** <https://discuss.elastic.co/t/elasticsearch-ingest-support-for-geoip2-isp/163794>\
**Category:** Elasticsearch\
**Created:** [January 10, 2019, 5:55pm UTC](https://discuss.elastic.co/t/elasticsearch-ingest-support-for-geoip2-isp/163794 "2019-01-10T17:55:21Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Evesy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/evesy/32/29520_2.png) [@Evesy](https://discuss.elastic.co/u/Evesy)\
**Post date:** [January 10, 2019, 5:55pm UTC](https://discuss.elastic.co/t/elasticsearch-ingest-support-for-geoip2-isp/163794/1 "2019-01-10T17:55:21Z")

</div>

Hi,

Does the Elasticsearch ingest plugin support the MaxMind GeoIP2 ISP database? I saw that is was added to Logstash a while back ([https://github.com/logstash-plugins/logstash-filter-geoip/pull/111](https://github.com/logstash-plugins/logstash-filter-geoip/pull/111)) however when trying to specify it in an ingest pipeline:

```auto
        "field": "nginx.access.remote_ip",
        "database_file": "GeoIP2-ISP.mmdb",
        "target_field": "geoip",
        "ignore_missing": true

```

I receive the below:

```auto
Failed to connect: Connection marked as failed because the onConnect callback failed: Error loading pipeline for fileset ingress-nginx/access: couldn't load pipeline: couldn't load json. Error: 400 Bad Request: {"error":{"root_cause":[{"type":"parse_exception","reason":"[database_file] Unsupported database type [GeoIP2-ISP]","header":{"processor_type":"geoip","property_name":"database_file"}}],"type":"parse_exception","reason":"[database_file] Unsupported database type [GeoIP2-ISP]","header":{"processor_type":"geoip","property_name":"database_file"}},"status":400}. Response body: {"error":{"root_cause":[{"type":"parse_exception","reason":"[database_file] Unsupported database type [GeoIP2-ISP]","header":{"processor_type":"geoip","property_name":"database_file"}}],"type":"parse_exception","reason":"[database_file] Unsupported database type [GeoIP2-ISP]","header":{"processor_type":"geoip","property_name":"database_file"}},"status":400}

```

Thanks,  
Mike

---

<div class="post-metadata">

**Author:** ![toppyc](https://avatars.discourse-cdn.com/v4/letter/t/2bfe46/32.png) [@toppyc](https://discuss.elastic.co/u/toppyc)\
**Post date:** [January 11, 2019, 2:08am UTC](https://discuss.elastic.co/t/elasticsearch-ingest-support-for-geoip2-isp/163794/2 "2019-01-11T02:08:58Z")

</div>

It looks like it does not support the GeoIP2-ISP.mmdb. Did you try to open the ASN file GeoIP2-ASN.mmdb instead?

We are currently using geolocation database from other service provider [IP2Location Logstash](https://github.com/ip2location/logstash-filter-ip2location) with ISP information ready.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 8, 2019, 2:09am UTC](https://discuss.elastic.co/t/elasticsearch-ingest-support-for-geoip2-isp/163794/3 "2019-02-08T02:09:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
