# Elasticsearch is giving error as "failed to start shard"

**URL:** <https://discuss.elastic.co/t/elasticsearch-is-giving-error-as-failed-to-start-shard/16086>\
**Category:** Elasticsearch\
**Created:** [March 1, 2014, 9:28am UTC](https://discuss.elastic.co/t/elasticsearch-is-giving-error-as-failed-to-start-shard/16086 "2014-03-01T09:28:35Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![bagui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bagui/32/960_2.png) [@bagui](https://discuss.elastic.co/u/bagui)\
**Post date:** [March 1, 2014, 9:28am UTC](https://discuss.elastic.co/t/elasticsearch-is-giving-error-as-failed-to-start-shard/16086/1 "2014-03-01T09:28:35Z")

</div>

Hi ,

I'm trying to move elastic search on a new system, but while trying to  
start the service its giving below exception. Althrough the process is  
running. There was old elasticsearch 0.90 copied which is not running now  
as I checked. Please suggest.

[2014-02-28 16:40:13,588][WARN][transport.netty] [DJ] Message  
not fully read (response) for [4] handler  
future(org.elasticsearch.indices.recovery.RecoveryTarget$4@1b4268b), error  
[true], resetting  
[2014-02-28 16:40:13,589][WARN][transport.netty] [DJ] Message  
not fully read (response) for [3] handler  
future(org.elasticsearch.indices.recovery.RecoveryTarget$4@151d6cb), error  
[true], resetting  
[2014-02-28 16:40:13,590][WARN][indices.cluster] [DJ]  
[logstash-2014.02.27][1] failed to start shard  
org.elasticsearch.indices.recovery.RecoveryFailedException:  
[logstash-2014.02.27][1]: Recovery failed from  
[Brutacus][L0THepPDR6Cmx7O2jqVLdg][[cloudclient1.aricent.com](http://cloudclient1.aricent.com)][inet[/10.203.251.143:9300]]  
into  
[DJ][LajLfvlYSAGZdsyFnorwEA][[cloudclient.aricent.com](http://cloudclient.aricent.com)][inet[/10.203.251.142:9300]]  
at  
org.elasticsearch.indices.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:303)  
at  
org.elasticsearch.indices.recovery.RecoveryTarget.access$300(RecoveryTarget.java:65)  
at  
org.elasticsearch.indices.recovery.RecoveryTarget$2.run(RecoveryTarget.java:171)

Thanks,  
Subahdip

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/1ee34fd2-27f2-45bb-82d0-f11cdf07aaf2%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/1ee34fd2-27f2-45bb-82d0-f11cdf07aaf2%40googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![bagui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bagui/32/960_2.png) [@bagui](https://discuss.elastic.co/u/bagui)\
**Post date:** [March 2, 2014, 8:02am UTC](https://discuss.elastic.co/t/elasticsearch-is-giving-error-as-failed-to-start-shard/16086/2 "2014-03-02T08:02:12Z")

</div>

Hi,

Please help to fix the issue.

On Saturday, March 1, 2014 2:58:35 PM UTC+5:30, Subhadip Bagui wrote:

> Hi ,
> 
> I'm trying to move Elasticsearch on a new system, but while trying to  
> start the service its giving below exception. Althrough the process is  
> running. There was old elasticsearch 0.90 copied which is not running now  
> as I checked. Please suggest.
> 
> [2014-02-28 16:40:13,588][WARN][transport.netty] [DJ] Message  
> not fully read (response) for [4] handler  
> future(org.elasticsearch.indices.recovery.RecoveryTarget$4@1b4268b), error  
> [true], resetting  
> [2014-02-28 16:40:13,589][WARN][transport.netty] [DJ] Message  
> not fully read (response) for [3] handler  
> future(org.elasticsearch.indices.recovery.RecoveryTarget$4@151d6cb), error  
> [true], resetting  
> [2014-02-28 16:40:13,590][WARN][indices.cluster] [DJ]  
> [logstash-2014.02.27][1] failed to start shard  
> org.elasticsearch.indices.recovery.RecoveryFailedException:  
> [logstash-2014.02.27][1]: Recovery failed from  
> [Brutacus][L0THepPDR6Cmx7O2jqVLdg][[cloudclient1.aricent.com](http://cloudclient1.aricent.com)][inet[/  
> 10.203.251.143:9300]] into [DJ][LajLfvlYSAGZdsyFnorwEA][  
> [cloudclient.aricent.com](http://cloudclient.aricent.com)][inet[/10.203.251.142:9300]]  
> at  
> org.elasticsearch.indices.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:303)  
> at  
> org.elasticsearch.indices.recovery.RecoveryTarget.access$300(RecoveryTarget.java:65)  
> at  
> org.elasticsearch.indices.recovery.RecoveryTarget$2.run(RecoveryTarget.java:171)
> 
> Thanks,  
> Subahdip

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/e3936205-8ba2-4bd9-a76c-c5f18142e1c6%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/e3936205-8ba2-4bd9-a76c-c5f18142e1c6%40googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![bagui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bagui/32/960_2.png) [@bagui](https://discuss.elastic.co/u/bagui)\
**Post date:** [March 3, 2014, 6:49am UTC](https://discuss.elastic.co/t/elasticsearch-is-giving-error-as-failed-to-start-shard/16086/3 "2014-03-03T06:49:00Z")

</div>

Hi,

Please suggest how to resolve the issue.

Thanks,  
Subhadip

---

<div class="post-metadata">

**Author:** ![bagui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bagui/32/960_2.png) [@bagui](https://discuss.elastic.co/u/bagui)\
**Post date:** [March 3, 2014, 7:10am UTC](https://discuss.elastic.co/t/elasticsearch-is-giving-error-as-failed-to-start-shard/16086/4 "2014-03-03T07:10:38Z")

</div>

Hi,

Please suggest how to resolve the issue.

Thanks,  
Subhadip

On Saturday, March 1, 2014 2:58:35 PM UTC+5:30, Subhadip Bagui wrote:

> Hi ,
> 
> I'm trying to move Elasticsearch on a new system, but while trying to  
> start the service its giving below exception. Althrough the process is  
> running. There was old elasticsearch 0.90 copied which is not running now  
> as I checked. Please suggest.
> 
> [2014-02-28 16:40:13,588][WARN][transport.netty] [DJ] Message  
> not fully read (response) for [4] handler  
> future(org.elasticsearch.indices.recovery.RecoveryTarget$4@1b4268b), error  
> [true], resetting  
> [2014-02-28 16:40:13,589][WARN][transport.netty] [DJ] Message  
> not fully read (response) for [3] handler  
> future(org.elasticsearch.indices.recovery.RecoveryTarget$4@151d6cb), error  
> [true], resetting  
> [2014-02-28 16:40:13,590][WARN][indices.cluster] [DJ]  
> [logstash-2014.02.27][1] failed to start shard  
> org.elasticsearch.indices.recovery.RecoveryFailedException:  
> [logstash-2014.02.27][1]: Recovery failed from  
> [Brutacus][L0THepPDR6Cmx7O2jqVLdg][[cloudclient1.aricent.com](http://cloudclient1.aricent.com)][inet[/  
> 10.203.251.143:9300]] into [DJ][LajLfvlYSAGZdsyFnorwEA][  
> [cloudclient.aricent.com](http://cloudclient.aricent.com)][inet[/10.203.251.142:9300]]  
> at  
> org.elasticsearch.indices.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:303)  
> at  
> org.elasticsearch.indices.recovery.RecoveryTarget.access$300(RecoveryTarget.java:65)  
> at  
> org.elasticsearch.indices.recovery.RecoveryTarget$2.run(RecoveryTarget.java:171)
> 
> Thanks,  
> Subahdip

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/7a6843bd-1aa0-4a9b-8a48-c4b5a6a65907%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/7a6843bd-1aa0-4a9b-8a48-c4b5a6a65907%40googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![bagui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bagui/32/960_2.png) [@bagui](https://discuss.elastic.co/u/bagui)\
**Post date:** [March 3, 2014, 10:30am UTC](https://discuss.elastic.co/t/elasticsearch-is-giving-error-as-failed-to-start-shard/16086/5 "2014-03-03T10:30:56Z")

</div>

Hi,

When I deleted all in index using rest then elasticsearch is getting up  
fine. Any help to identify the issue.

Thanks

On Saturday, March 1, 2014 2:58:35 PM UTC+5:30, Subhadip Bagui wrote:

> Hi ,
> 
> I'm trying to move Elasticsearch on a new system, but while trying to  
> start the service its giving below exception. Althrough the process is  
> running. There was old elasticsearch 0.90 copied which is not running now  
> as I checked. Please suggest.
> 
> [2014-02-28 16:40:13,588][WARN][transport.netty] [DJ] Message  
> not fully read (response) for [4] handler  
> future(org.elasticsearch.indices.recovery.RecoveryTarget$4@1b4268b), error  
> [true], resetting  
> [2014-02-28 16:40:13,589][WARN][transport.netty] [DJ] Message  
> not fully read (response) for [3] handler  
> future(org.elasticsearch.indices.recovery.RecoveryTarget$4@151d6cb), error  
> [true], resetting  
> [2014-02-28 16:40:13,590][WARN][indices.cluster] [DJ]  
> [logstash-2014.02.27][1] failed to start shard  
> org.elasticsearch.indices.recovery.RecoveryFailedException:  
> [logstash-2014.02.27][1]: Recovery failed from  
> [Brutacus][L0THepPDR6Cmx7O2jqVLdg][[cloudclient1.aricent.com](http://cloudclient1.aricent.com)][inet[/  
> 10.203.251.143:9300]] into [DJ][LajLfvlYSAGZdsyFnorwEA][  
> [cloudclient.aricent.com](http://cloudclient.aricent.com)][inet[/10.203.251.142:9300]]  
> at  
> org.elasticsearch.indices.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:303)  
> at  
> org.elasticsearch.indices.recovery.RecoveryTarget.access$300(RecoveryTarget.java:65)  
> at  
> org.elasticsearch.indices.recovery.RecoveryTarget$2.run(RecoveryTarget.java:171)
> 
> Thanks,  
> Subahdip

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/9ef1288f-c9bc-4671-8de4-71938e7429f4%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/9ef1288f-c9bc-4671-8de4-71938e7429f4%40googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![bagui](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bagui/32/960_2.png) [@bagui](https://discuss.elastic.co/u/bagui)\
**Post date:** [March 3, 2014, 11:55am UTC](https://discuss.elastic.co/t/elasticsearch-is-giving-error-as-failed-to-start-shard/16086/6 "2014-03-03T11:55:50Z")

</div>

Hi,

I'm using Elasticsearch 1.0 and logstash 1.3.3 with redis\_version:2.4.10  
When ever I'm trying to start logstash indexer it's giving me below error  
..."failed to start shard" I deleted all the indices from Elasticsearch  
before start.

[2014-03-03 17:04:33,178][WARN][transport.netty] [Mantra]  
Message not fully read (response) for [2114] handler  
future(org.elasticsearch.indices.recovery.RecoveryTarget$4@14487c8), error  
[true], resetting

[2014-03-03 17:04:33,183][WARN][indices.cluster] [Mantra]  
[logstash-2014.03.03][3] failed to start shard

org.elasticsearch.indices.recovery.RecoveryFailedException:  
[logstash-2014.03.03][3]: Recovery failed from  
[Brutacus][L0THepPDR6Cmx7O2jqVLdg][[cloudclient1.aricent.com](http://cloudclient1.aricent.com)][inet[/10.203.251.143:9300]]  
into  
[Mantra][cKMntkkDT5Ws8g8\_yeoTUg][[cloudclient.aricent.com](http://cloudclient.aricent.com)][inet[/10.203.251.142:9300]]

```
    at 

```

org.elasticsearch.indices.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:303)

```
    at 

```

org.elasticsearch.indices.recovery.RecoveryTarget.access$300(RecoveryTarget.java:65)

```
    at 

```

org.elasticsearch.indices.recovery.RecoveryTarget$2.run(RecoveryTarget.java:171)

```
    at 

```

java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)

```
    at 

```

java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)

```
    at java.lang.Thread.run(Thread.java:662)

```

* * *

Please help to resolve the issue.

Thanks,  
Subhadip

On Saturday, March 1, 2014 2:58:35 PM UTC+5:30, Subhadip Bagui wrote:

> Hi ,
> 
> I'm trying to move Elasticsearch on a new system, but while trying to  
> start the service its giving below exception. Althrough the process is  
> running. There was old elasticsearch 0.90 copied which is not running now  
> as I checked. Please suggest.
> 
> [2014-02-28 16:40:13,588][WARN][transport.netty] [DJ] Message  
> not fully read (response) for [4] handler  
> future(org.elasticsearch.indices.recovery.RecoveryTarget$4@1b4268b), error  
> [true], resetting  
> [2014-02-28 16:40:13,589][WARN][transport.netty] [DJ] Message  
> not fully read (response) for [3] handler  
> future(org.elasticsearch.indices.recovery.RecoveryTarget$4@151d6cb), error  
> [true], resetting  
> [2014-02-28 16:40:13,590][WARN][indices.cluster] [DJ]  
> [logstash-2014.02.27][1] failed to start shard  
> org.elasticsearch.indices.recovery.RecoveryFailedException:  
> [logstash-2014.02.27][1]: Recovery failed from  
> [Brutacus][L0THepPDR6Cmx7O2jqVLdg][[cloudclient1.aricent.com](http://cloudclient1.aricent.com)][inet[/  
> 10.203.251.143:9300]] into [DJ][LajLfvlYSAGZdsyFnorwEA][  
> [cloudclient.aricent.com](http://cloudclient.aricent.com)][inet[/10.203.251.142:9300]]  
> at  
> org.elasticsearch.indices.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:303)  
> at  
> org.elasticsearch.indices.recovery.RecoveryTarget.access$300(RecoveryTarget.java:65)  
> at  
> org.elasticsearch.indices.recovery.RecoveryTarget$2.run(RecoveryTarget.java:171)
> 
> Thanks,  
> Subahdip

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/d66ab1d6-8cb2-4019-9cc3-2054328d8864%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/d66ab1d6-8cb2-4019-9cc3-2054328d8864%40googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:46am UTC](https://discuss.elastic.co/t/elasticsearch-is-giving-error-as-failed-to-start-shard/16086/7 "2017-07-06T01:46:14Z")

</div>


