# Elasticsearch is not getting started and throwing same ‘operation not permitted’ error

**URL:** https://discuss.elastic.co/t/elasticsearch-is-not-getting-started-and-throwing-same-operation-not-permitted-error/367202
**Category:** Elasticsearch
**Tags:** docker
**Created:** [September 26, 2024, 5:16pm UTC](https://discuss.elastic.co/t/elasticsearch-is-not-getting-started-and-throwing-same-operation-not-permitted-error/367202 "2024-09-26T17:16:50Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![bshiwanand](https://avatars.discourse-cdn.com/v4/letter/b/dc4da7/32.png) [@bshiwanand](https://discuss.elastic.co/u/bshiwanand)
#### Post date: [September 26, 2024, 5:16pm UTC](https://discuss.elastic.co/t/elasticsearch-is-not-getting-started-and-throwing-same-operation-not-permitted-error/367202/1 "2024-09-26T17:16:50Z")

</div>

![thumbnail_image002](https://us1.discourse-cdn.com/elastic/original/3X/1/6/165000095c1b74ce6acfe43d5469f683bb4cc97d.png)

We are deploying the Elasticsearch on containerized env. with multi cluster facing the below issue.

“/home/jboss/gpp/profiles/GPPE\_EG\_EUS\_HV06/config/esserver11/elasticsearch.keystore.tmp” operation not permitted

Please check the screenshot attached here.

Any resolution you think here like I need to update the permissions - in this way?

sudo chmod g+w /etc/elasticsearch

```auto
sudo bash -c 'printf "topsecret" | /usr/share/elasticsearch/bin/elasticsearch-keystore add "bootstrap.password"'

```

Reference

> <https://stackoverflow.com/questions/56969454/unable-to-create-temporary-keystore-error-while-launching-elasticsearch-bat-from>

---

<div class="post-metadata">

### Author: ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)
#### Post date: [September 27, 2024, 1:02am UTC](https://discuss.elastic.co/t/elasticsearch-is-not-getting-started-and-throwing-same-operation-not-permitted-error/367202/2 "2024-09-27T01:02:25Z")

</div>

The most likely explanation is that this is due to two reasons:

1. You are bind mounting files directly into the container (rather than directories)
2. Your keystore format is out of date.

Because of (2) Elasticsearch tries to rewrite the keystore into a new format, but because of (1) it cannot because it doesn't have a writeable directory.

You should be able to fix this be either

1. bind mounting a writeable config/ directory into the container
2. Upgrading your keystore format from outside the container (using [`elasticsearch-keystore upgrade`](https://www.elastic.co/guide/en/elasticsearch/reference/current/elasticsearch-keystore.html))

---

<div class="post-metadata">

### Author: ![bshiwanand](https://avatars.discourse-cdn.com/v4/letter/b/dc4da7/32.png) [@bshiwanand](https://discuss.elastic.co/u/bshiwanand)
#### Post date: [September 27, 2024, 4:50am UTC](https://discuss.elastic.co/t/elasticsearch-is-not-getting-started-and-throwing-same-operation-not-permitted-error/367202/3 "2024-09-27T04:50:06Z")

</div>

> [@TimV](#):
>
> rading your keystore format from outside

Hi @TimV

The issue with directory permission Elasticsearch started working fine.

Thanks for your time and Efforts TimV
