# Elasticsearch is not working after x-pack installation

**URL:** https://discuss.elastic.co/t/elasticsearch-is-not-working-after-x-pack-installation/104217
**Category:** Elasticsearch
**Created:** [October 17, 2017, 9:33am UTC](https://discuss.elastic.co/t/elasticsearch-is-not-working-after-x-pack-installation/104217 "2017-10-17T09:33:25Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![sarit](https://avatars.discourse-cdn.com/v4/letter/s/eada6e/32.png) [@sarit](https://discuss.elastic.co/u/sarit)
#### Post date: [October 17, 2017, 9:33am UTC](https://discuss.elastic.co/t/elasticsearch-is-not-working-after-x-pack-installation/104217/1 "2017-10-17T09:33:25Z")

</div>

Hello,  
I'm trying to add monitoring to logstash  
I have elasticsearch,logstash and kibana installed on one server (version 5.5).  
I installed x-pack on logstash and since then i cannot start elasticsearch.  
After that I installed x-pack also on elasticsearch (should I ? ) and i got error :  
[ERROR][o.e.x.m.e.l.LocalExporter] failed to set monitoring pipeline [xpack\_monitoring\_6]  
org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException: failed to process cluster event (put-pipeline-xpack\_monitoring\_6) within 30s

should x-pack be installed on elasticsearch and kibana as well if i want to monitor only logstash ?  
If yes, what am i missing ?  
If no, why elasticseach not start after the installation ?  
i got error :  
Unable to connect to Elasticsearch at [http://localhost:9200](http://localhost:9200).

thanks for you help

---

<div class="post-metadata">

### Author: ![sarit](https://avatars.discourse-cdn.com/v4/letter/s/eada6e/32.png) [@sarit](https://discuss.elastic.co/u/sarit)
#### Post date: [October 17, 2017, 11:36am UTC](https://discuss.elastic.co/t/elasticsearch-is-not-working-after-x-pack-installation/104217/2 "2017-10-17T11:36:05Z")

</div>

update :  
i removed the xpack installation from elasticsearch and it is working now  
but i don't have xpack configuration in logstash.yml after the installation.  
why is that ?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 14, 2017, 11:36am UTC](https://discuss.elastic.co/t/elasticsearch-is-not-working-after-x-pack-installation/104217/3 "2017-11-14T11:36:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
