# Elasticsearch is throwing bootstrap error and it's unable to load system call filters when i'm trying to run on linux

**URL:** https://discuss.elastic.co/t/elasticsearch-is-throwing-bootstrap-error-and-its-unable-to-load-system-call-filters-when-im-trying-to-run-on-linux/88517
**Category:** Elasticsearch
**Created:** [June 7, 2017, 7:19am UTC](https://discuss.elastic.co/t/elasticsearch-is-throwing-bootstrap-error-and-its-unable-to-load-system-call-filters-when-im-trying-to-run-on-linux/88517 "2017-06-07T07:19:11Z")
**Posts on this page:** 1
**Showing post:** 7

<div class="post-metadata">

### Author: ![yash\_mangla](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yash_mangla/32/25889_2.png) [@yash\_mangla](https://discuss.elastic.co/u/yash_mangla)
#### Post date: [June 7, 2017, 1:03pm UTC](https://discuss.elastic.co/t/elasticsearch-is-throwing-bootstrap-error-and-its-unable-to-load-system-call-filters-when-im-trying-to-run-on-linux/88517/7 "2017-06-07T13:03:02Z")

</div>

In 2.4 there is still warning regarding bootstrap validation but not mandatory step to run elasticsearch.  
i don't know on what scenario i have required bootstrap validation.

but in my current situation i just using elasticsearch as a database for insertion and deletion that's it rest network & preprocessing part is take care by logstash & filebeat.

Can You Suggest anything on this topic also

[how to set ./pattern directory path in logstash after extracting tar file on linux ?](https://discuss.elastic.co/t/what-would-be-the-filetype-for-our-custom-patterns-in-pattern-directory/88029)

---

_[View the full topic](https://discuss.elastic.co/t/elasticsearch-is-throwing-bootstrap-error-and-its-unable-to-load-system-call-filters-when-im-trying-to-run-on-linux/88517)._
