# Elasticsearch Kibana Azure Template fails for new resource group

**URL:** <https://discuss.elastic.co/t/elasticsearch-kibana-azure-template-fails-for-new-resource-group/62198>\
**Category:** Elasticsearch\
**Created:** [October 4, 2016, 5:29pm UTC](https://discuss.elastic.co/t/elasticsearch-kibana-azure-template-fails-for-new-resource-group/62198 "2016-10-04T17:29:24Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![MatthewHartz](https://avatars.discourse-cdn.com/v4/letter/m/e47774/32.png) [@MatthewHartz](https://discuss.elastic.co/u/MatthewHartz)\
**Post date:** [October 4, 2016, 5:29pm UTC](https://discuss.elastic.co/t/elasticsearch-kibana-azure-template-fails-for-new-resource-group/62198/1 "2016-10-04T17:29:24Z")

</div>

I've had no issues before deploying the template for Elasticsearch Kibana (last time I tried was about a few months ago). Now when i tried to create a new environment with it, I get this error when on the load balancer step.

{  
"status": "Failed",  
"error": {  
"code": "ResourceDeploymentFailure",  
"message": "The resource operation completed with terminal provisioning state 'Failed'.",  
"details": [  
{  
"code": "DeploymentFailed",  
"message": "At least one resource deployment operation failed. Please list deployment operations for details. Please see [https://aka.ms/arm-debug](https://aka.ms/arm-debug) for usage details.",  
"details": [  
{  
"code": "BadRequest",  
"message": "{\r\n "error": {\r\n "code": "PrivateIPAddressIsAllocated",\r\n "message": "IP configuration /subscriptions/XXX/resourceGroups/XXX/providers/Microsoft.Network/loadBalancers/es-internal-lb/frontendIPConfigurations/LBFE is using the private IP address 10.0.0.4 which is already allocated to resource /subscriptions/XXX/resourceGroups/XXX/providers/Microsoft.Network/networkInterfaces/|providers|Microsoft.Compute|virtualMachineScaleSets|node|virtualMachines|0|networkInterfaces|NIC-qmtintplus-0.",\r\n "details": []\r\n }\r\n}"  
}  
]  
}  
]  
}  
}

---

<div class="post-metadata">

**Author:** ![forloop](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/forloop/32/9021_2.png) [@forloop](https://discuss.elastic.co/u/forloop)\
**Post date:** [October 10, 2016, 9:05pm UTC](https://discuss.elastic.co/t/elasticsearch-kibana-azure-template-fails-for-new-resource-group/62198/2 "2016-10-10T21:05:52Z")

</div>

Hey @MatthewHartz,

The issue is that the deployment template needs a known static IP address in the virtual network to which the cluster is attached, to be allocated to the internal load balancer (an internal load balancer is _always_ deployed as part of the template).

It sounds like the last time you deployed the template, this parameter was not required; this parameter, [**vNetLoadBalancerIp**](https://github.com/elastic/azure-marketplace#parameters), was introduced when the [ability to attach the deployed cluster to an existing virtual network or create a new virtual network was added in 1.3.0](https://github.com/elastic/azure-marketplace/releases/tag/1.3.0). The default value is `10.0.0.4`, but that IP address is already allocated to another virtual machine in your subscription so you should set it to another value, along with **vNetNewAddressPrefix** and **vNetNewSubnetAddressPrefix**.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:13pm UTC](https://discuss.elastic.co/t/elasticsearch-kibana-azure-template-fails-for-new-resource-group/62198/3 "2017-07-05T22:13:30Z")

</div>


