# Elasticsearch metrics collection error

**URL:** <https://discuss.elastic.co/t/elasticsearch-metrics-collection-error/94365>\
**Category:** Elasticsearch\
**Created:** [July 24, 2017, 4:25pm UTC](https://discuss.elastic.co/t/elasticsearch-metrics-collection-error/94365 "2017-07-24T16:25:57Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![hemasalma](https://avatars.discourse-cdn.com/v4/letter/h/ea5d25/32.png) [@hemasalma](https://discuss.elastic.co/u/hemasalma)\
**Post date:** [July 24, 2017, 4:25pm UTC](https://discuss.elastic.co/t/elasticsearch-metrics-collection-error/94365/1 "2017-07-24T16:25:58Z")

</div>

Hello,

we have installed ELK-5.4.0 and try to monitor it using telegraf-agent and when we are monitoring we are getting the following the error.

**E! Elasticsearch indexing failure, id: 2, error: failed to parse [elasticsearch\_indices.segments\_max\_unsafe\_auto\_id\_timestamp], caused by: Numeric value (-9223372036854776000) out of range of long (-9223372036854775808 - 9223372036854775807)**  
\*\* at [Source: org.elasticsearch.common.bytes.BytesReference$MarkSupportingStreamInputWrapper@6609b880; line: 1, column: 2014], i\_o\_exception\*\*

can i get the solution for the error and know from where we get the field name..?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 26, 2017, 8:21pm UTC](https://discuss.elastic.co/t/elasticsearch-metrics-collection-error/94365/2 "2017-07-26T20:21:49Z")

</div>

Is there more to the log?

> [@hemasalma](#):
>
> we have installed ELK-5.4.0

From 5.0 we've started calling it the Elastic Stack, otherwise Beats gets left out 😉

---

<div class="post-metadata">

**Author:** ![hemasalma](https://avatars.discourse-cdn.com/v4/letter/h/ea5d25/32.png) [@hemasalma](https://discuss.elastic.co/u/hemasalma)\
**Post date:** [August 2, 2017, 7:15am UTC](https://discuss.elastic.co/t/elasticsearch-metrics-collection-error/94365/3 "2017-08-02T07:15:04Z")

</div>

Aug 02 12:44:41 elasticsearch\_masternode telegraf[15349]: 2017-08-02T07:14:41Z E! Elasticsearch indexing failure, id: 36, error: failed to parse [elasticsearch\_indices.segments\_max\_unsafe\_auto\_id\_timestamp], caused by: Numeric value (-9223372036854776000) out of range of long (-9223372036854775808 - 9223372036854775807)  
Aug 02 12:44:41 elasticsearch\_masternode telegraf[15349]: at [Source: org.elasticsearch.common.bytes.BytesReference$MarkSupportingStreamInputWrapper@6352444e; line: 1, column: 2014], i\_o\_exception  
Aug 02 12:44:41 elasticsearch\_masternode telegraf[15349]: 2017-08-02T07:14:41Z E! Elasticsearch indexing failure, id: 37, error: failed to parse [elasticsearch\_indices.segments\_max\_unsafe\_auto\_id\_timestamp], caused by: Numeric value (-9223372036854776000) out of range of long (-9223372036854775808 - 9223372036854775807)  
Aug 02 12:44:41 elasticsearch\_masternode telegraf[15349]: at [Source: org.elasticsearch.common.bytes.BytesReference$MarkSupportingStreamInputWrapper@2892d936; line: 1, column: 2014], i\_o\_exception  
Aug 02 12:44:41 elasticsearch\_masternode telegraf[15349]: 2017-08-02T07:14:41Z E! Elasticsearch indexing failure, id: 38, error: failed to parse [elasticsearch\_indices.segments\_max\_unsafe\_auto\_id\_timestamp], caused by: Numeric value (-9223372036854776000) out of range of long (-9223372036854775808 - 9223372036854775807)  
Aug 02 12:44:41 elasticsearch\_masternode telegraf[15349]: at [Source: org.elasticsearch.common.bytes.BytesReference$MarkSupportingStreamInputWrapper@5a501115; line: 1, column: 2014], i\_o\_exception  
Aug 02 12:44:41 elasticsearch\_masternode telegraf[15349]: 2017-08-02T07:14:41Z E! Elasticsearch indexing failure, id: 39, error: failed to parse [elasticsearch\_indices.segments\_max\_unsafe\_auto\_id\_timestamp], caused by: Numeric value (-9223372036854776000) out of range of long (-9223372036854775808 - 9223372036854775807)  
Aug 02 12:44:41 elasticsearch\_masternode telegraf[15349]: at [Source: org.elasticsearch.common.bytes.BytesReference$MarkSupportingStreamInputWrapper@424e4041; line: 1, column: 2014], i\_o\_exception  
Aug 02 12:44:41 elasticsearch\_masternode telegraf[15349]: 2017-08-02T07:14:41Z E! Error writing to output [elasticsearch]: W! Elasticsearch failed to index 40 metrics

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 2, 2017, 9:41am UTC](https://discuss.elastic.co/t/elasticsearch-metrics-collection-error/94365/4 "2017-08-02T09:41:04Z")

</div>

Thanks. What's telegraf?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 30, 2017, 9:41am UTC](https://discuss.elastic.co/t/elasticsearch-metrics-collection-error/94365/5 "2017-08-30T09:41:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
