# Elasticsearch not showing on browser or via php

**URL:** <https://discuss.elastic.co/t/elasticsearch-not-showing-on-browser-or-via-php/37577>\
**Category:** Elasticsearch\
**Created:** [December 18, 2015, 1:38pm UTC](https://discuss.elastic.co/t/elasticsearch-not-showing-on-browser-or-via-php/37577 "2015-12-18T13:38:07Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![tushar\_chevulkar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tushar_chevulkar/32/46270_2.png) [@tushar\_chevulkar](https://discuss.elastic.co/u/tushar_chevulkar)\
**Post date:** [December 18, 2015, 1:38pm UTC](https://discuss.elastic.co/t/elasticsearch-not-showing-on-browser-or-via-php/37577/1 "2015-12-18T13:38:07Z")

</div>

I have a centos server wher I have installed Elasticsearch. the installation is done correctly with no changes in elasticsearch.yml i have installed it via RPM and its running perfectly as a service , but he problem is I am not been able to view anything on [https://xxxx.com:9200](https://xxxx.com:9200). It says unable to connect. also I am using PHP to acces it via code but PHP code is also not been able to detect Elasticsearch

```
     <?php
require 'vendor/autoload.php';

$client = ClientBuilder::create()->build();

```

this code also shows a blank result with no error. I have absolutely no idea what is wrong can any one help.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 18, 2015, 2:07pm UTC](https://discuss.elastic.co/t/elasticsearch-not-showing-on-browser-or-via-php/37577/2 "2015-12-18T14:07:10Z")

</div>

If you are using elasticsearch 2.0 and \>, you need to define network.host setting.

---

<div class="post-metadata">

**Author:** ![tushar\_chevulkar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tushar_chevulkar/32/46270_2.png) [@tushar\_chevulkar](https://discuss.elastic.co/u/tushar_chevulkar)\
**Post date:** [December 18, 2015, 2:32pm UTC](https://discuss.elastic.co/t/elasticsearch-not-showing-on-browser-or-via-php/37577/3 "2015-12-18T14:32:28Z")

</div>

I am using the latest, I changes network.host to my ip xx.xx.xx.xx but still I am not able to view anything on the browser by typing x.xx.xx.xx:9200 not i am able to connect via php. I get the following error in php

```
Catchable fatal error: Argument 1 passed to 
Elasticsearch\Client::__construct() must be an instance of 
Elasticsearch\Transport, array given, called in 
/var/www/html/ElasticClass/Elastic.php on line 8 and defined in /var/www/html/Master/ElasticClass/vendor/elasticsearch/elasticsearch/src/Elasticsearch/Client.php on line 70
```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 18, 2015, 3:44pm UTC](https://discuss.elastic.co/t/elasticsearch-not-showing-on-browser-or-via-php/37577/4 "2015-12-18T15:44:21Z")

</div>

Did you restart the node? Can you show the node logs?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:29pm UTC](https://discuss.elastic.co/t/elasticsearch-not-showing-on-browser-or-via-php/37577/5 "2017-07-05T23:29:57Z")

</div>


