# Elasticsearch not starting as a service in RHEL 8

**URL:** <https://discuss.elastic.co/t/elasticsearch-not-starting-as-a-service-in-rhel-8/227758>\
**Category:** Elasticsearch\
**Created:** [April 13, 2020, 10:53am UTC](https://discuss.elastic.co/t/elasticsearch-not-starting-as-a-service-in-rhel-8/227758 "2020-04-13T10:53:08Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![gefela](https://avatars.discourse-cdn.com/v4/letter/g/90ced4/32.png) [@gefela](https://discuss.elastic.co/u/gefela)\
**Post date:** [April 13, 2020, 10:53am UTC](https://discuss.elastic.co/t/elasticsearch-not-starting-as-a-service-in-rhel-8/227758/1 "2020-04-13T10:53:08Z")

</div>

Hi  
When I try to start elasticsearch using the following command, I get the following error message

[root@gefela ansible\_junos]# systemctl restart logstash elasticsearch kibana  
Job for elasticsearch.service failed because the control process exited with error code.  
See "systemctl status elasticsearch.service" and "journalctl -xe" for details  
Job for elasticsearch.service failed because the control process exited with error code.  
See "systemctl status elasticsearch.service" and "journalctl -xe" for details.  
[root@gefela ansible\_junos]# systemctl status elasticsearch.serviccce  
Unit elasticsearch.serviccce.service could not be found.  
[root@gefela ansible\_junos]# systemctl status elasticsearch.service  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Mon 2020-04-13 09:46:26 BST; 58s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 39975 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 39975 (code=exited, status=1/FAILURE)

Apr 13 09:46:25 gefela elasticsearch[39975]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161)  
Apr 13 09:46:25 gefela elasticsearch[39975]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)  
Apr 13 09:46:25 gefela elasticsearch[39975]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:125)  
Apr 13 09:46:25 gefela elasticsearch[39975]: at org.elasticsearch.cli.Command.main(Command.java:90)

Apr 13 09:46:25 gefela elasticsearch[39975]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126)  
Apr 13 09:46:25 gefela elasticsearch[39975]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)  
Apr 13 09:46:25 gefela elasticsearch[39975]: For complete error details, refer to the log at /var/log/elasticsearch/gefela.log  
Apr 13 09:46:26 gefela systemd[1]: elasticsearch.service: Main process exited, code=exited,

status=1/FAILURE  
Apr 13 09:46:26 gefela systemd[1]: elasticsearch.service: Failed with result 'exit-code'.  
Apr 13 09:46:26 gefela systemd[1]: Failed to start Elasticsearch.  
[root@gefela ansible\_junos]#

---

<div class="post-metadata">

**Author:** ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)\
**Post date:** [April 13, 2020, 2:22pm UTC](https://discuss.elastic.co/t/elasticsearch-not-starting-as-a-service-in-rhel-8/227758/2 "2020-04-13T14:22:58Z")

</div>

This

> [@gefela](#):
>
> For complete error details, refer to the log at /var/log/elasticsearch/gefela.log

Check the elasticsearch log for errors.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 11, 2020, 2:23pm UTC](https://discuss.elastic.co/t/elasticsearch-not-starting-as-a-service-in-rhel-8/227758/3 "2020-05-11T14:23:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
