# Elasticsearch not starting when i deleted few indices

**URL:** <https://discuss.elastic.co/t/elasticsearch-not-starting-when-i-deleted-few-indices/210110>\
**Category:** Elasticsearch\
**Created:** [December 2, 2019, 5:51am UTC](https://discuss.elastic.co/t/elasticsearch-not-starting-when-i-deleted-few-indices/210110 "2019-12-02T05:51:18Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![pankaj90](https://avatars.discourse-cdn.com/v4/letter/p/b2d939/32.png) [@pankaj90](https://discuss.elastic.co/u/pankaj90)\
**Post date:** [December 2, 2019, 5:51am UTC](https://discuss.elastic.co/t/elasticsearch-not-starting-when-i-deleted-few-indices/210110/1 "2019-12-02T05:51:18Z")

</div>

I accidentally deleted few indices from elastic-search data but not it's not starting the service. i'm getting error while starting the service which was " attempt to resurrect connection to dead ES instances" when i check logstash logs. i don't have any backup.

the elasticsearch logs are below. could you please help me because it's a production server.

```
   <Caused by: java.io.IOException: failed to find metadata for existing index apm-7.3.2-span-000009 [location: ZnuY-sJ8TDCvkE085oOn_g, generation: 26]
    at org.elasticsearch.gateway.MetaStateService.loadFullState(MetaStateService.java:99) ~[elasticsearch-7.3.2.jar:7.3.2]
    at org.elasticsearch.gateway.GatewayMetaState.upgradeMetaData(GatewayMetaState.java:141) ~[elasticsearch-7.3.2.jar:7.3.2]
    at org.elasticsearch.gateway.GatewayMetaState.<init>(GatewayMetaState.java:95) ~[elasticsearch-7.3.2.jar:7.3.2]
    at org.elasticsearch.node.Node.<init>(Node.java:492) ~[elasticsearch-7.3.2.jar:7.3.2]
    ... 11 more

```

[2019-12-02T11:07:14,444][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [channelplay-backup] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: ElasticsearchException[failed to bind service]; nested: IOException[failed to find metadata for existing index apm-7.3.2-span-000009 [location: ZnuY-sJ8TDCvkE085oOn\_g, generation: 26]];  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-7.3.2.jar:7.3.2]  
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.3.2.jar:7.3.2]  
Caused by: org.elasticsearch.ElasticsearchException: failed to bind service  
at org.elasticsearch.node.Node.(Node.java:617) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.node.Node.(Node.java:258) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:221) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:221) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.3.2.jar:7.3.2]  
... 6 more  
Caused by: java.io.IOException: failed to find metadata for existing index apm-7.3.2-span-000009 [location: ZnuY-sJ8TDCvkE085oOn\_g, generation: 26]  
at org.elasticsearch.gateway.MetaStateService.loadFullState(MetaStateService.java:99) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.gateway.GatewayMetaState.upgradeMetaData(GatewayMetaState.java:141) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.gateway.GatewayMetaState.(GatewayMetaState.java:95) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.node.Node.(Node.java:492) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.node.Node.(Node.java:258) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:221) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:221) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) ~[elasticsearch-7.3.2.jar:7.3.2]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.3.2.jar:7.3.2]  
... 6 more  
/\>

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 30, 2019, 5:58am UTC](https://discuss.elastic.co/t/elasticsearch-not-starting-when-i-deleted-few-indices/210110/2 "2019-12-30T05:58:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
