# ElasticSearch not starting

**URL:** <https://discuss.elastic.co/t/elasticsearch-not-starting/7212>\
**Category:** Elasticsearch\
**Created:** [April 3, 2012, 3:52pm UTC](https://discuss.elastic.co/t/elasticsearch-not-starting/7212 "2012-04-03T15:52:55Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![octomeow](https://avatars.discourse-cdn.com/v4/letter/o/dbc845/32.png) [@octomeow](https://discuss.elastic.co/u/octomeow)\
**Post date:** [April 3, 2012, 3:52pm UTC](https://discuss.elastic.co/t/elasticsearch-not-starting/7212/1 "2012-04-03T15:52:55Z")

</div>

I am trying to wipe everything in my elasticsearch install and start over (testbed, nothing big or valuable)  
However, when I deleted the data path folder and reinstall elasticsearch, I get the following over nad over and over again. How do I do a complete uninstall and reinstall?

[2012-04-03 15:49:24,333][WARN][cluster.action.shard] [Stark, Arno] sending failed shard for [graylog2][2], node[qfN0meUWQGeYs0o16AV96A], relocating [qJGJk9Q9She5hOmeGiR9Wg], [R], s[INITIALIZING], reason [Failed to start shard, message [RecoveryFailedException[Index Shard [graylog2][2]: Recovery failed from [Carter Ghazikhanian][JU0y7TYTR0ynbx6-UxU49g][inet[/xxx.xx.xx.xx:9301]] into [Stark, Arno][qfN0meUWQGeYs0o16AV96A][inet[/xx.xx.xx.xx:9302]]]; nested: RemoteTransportException[[Carter Ghazikhanian][inet[/xx.xx.xx.xxx:9301]][index/shard/recovery/startRecovery]]; nested: RecoveryEngineException[[graylog2][2] Phase[1] Execution failed]; nested: RecoverFilesRecoveryException[[graylog2][2] Failed to transfer [1] files with total size of [58b]]; nested: FileNotFoundException[/home/logstash/data/elasticsearchtest/nodes/1/indices/graylog2/2/index/segments\_1 (No such file or directory)]; ]]  
[2012-04-03 15:49:24,339][WARN][cluster.action.shard] [Stark, Arno] sending failed shard for [graylog2][1], node[qfN0meUWQGeYs0o16AV96A], relocating [JU0y7TYTR0ynbx6-UxU49g], [R], s[INITIALIZING], reason [Failed to start shard, message [RecoveryFailedException[Index Shard [graylog2][1]: Recovery failed from [Ringer][qJGJk9Q9She5hOmeGiR9Wg][inet[/xx.xx.xxx.xx:9300]] into [Stark, Arno][qfN0meUWQGeYs0o16AV96A][inet[/xx.xx.xx.xx:9302]]]; nested: RemoteTransportException[[Ringer][inet[/xx.xx.xx.xx:9300]][index/shard/recovery/startRecovery]]; nested: RecoveryEngineException[[graylog2][1] Phase[1] Execution failed]; nested: RecoverFilesRecoveryException[[graylog2][1] Failed to transfer [1] files with total size of [58b]]; nested: FileNotFoundException[/home/logstash/data/elasticsearchtest/nodes/0/indices/graylog2/1/index/segments\_1 (No such file or directory)]; ]]  
[2012-04-03 15:49:24,365][WARN][indices.cluster] [Stark, Arno] [graylog2][0] failed to start shard  
org.elasticsearch.indices.recovery.RecoveryFailedException: Index Shard [graylog2][0]: Recovery failed from [Ringer][qJGJk9Q9She5hOmeGiR9Wg][inet[/xxx.xxx.xxx.xxx:9300]] into [Stark, Arno][qfN0meUWQGeYs0o16AV96A][inet[/xxx.xxx.xxx.xxx:9302]]  
at org.elasticsearch.indices.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:258)  
at org.elasticsearch.indices.recovery.RecoveryTarget.access$100(RecoveryTarget.java:63)  
at org.elasticsearch.indices.recovery.RecoveryTarget$2.run(RecoveryTarget.java:154)  
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)  
at java.lang.Thread.run(Thread.java:662)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 3:33am UTC](https://discuss.elastic.co/t/elasticsearch-not-starting/7212/2 "2017-07-06T03:33:49Z")

</div>


