# Elasticsearch not working

**URL:** <https://discuss.elastic.co/t/elasticsearch-not-working/274944>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-monitoring\
**Created:** [June 4, 2021, 5:49am UTC](https://discuss.elastic.co/t/elasticsearch-not-working/274944 "2021-06-04T05:49:14Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Drupad\_Soni](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/drupad_soni/32/89388_2.png) [@Drupad\_Soni](https://discuss.elastic.co/u/Drupad_Soni)\
**Post date:** [June 4, 2021, 5:49am UTC](https://discuss.elastic.co/t/elasticsearch-not-working/274944/1 "2021-06-04T05:49:14Z")

</div>

Hi People,

My elasticsearch fails to start please guide me thru this. Sharing error as below

● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: enabled)  
Active: failed (Result: signal) since Fri 2021-06-04 05:39:42 UTC; 15s ago  
Docs: [https://www.elastic.co](https://www.elastic.co)  
Process: 60510 ExecStart=/usr/share/elasticsearch/bin/systemd-entrypoint -p ${PID\_DIR}/elasticsearch.pid --quiet (cod\>  
Main PID: 60510 (code=killed, signal=KILL)

Jun 04 05:39:38 testmispelk systemd[1]: Starting Elasticsearch...  
Jun 04 05:39:40 testmispelk systemd-entrypoint[60510]: [0.003s][warning][logging] Output options for existing outputs are\>  
Jun 04 05:39:42 testmispelk systemd[1]: elasticsearch.service: Main process exited, code=killed, status=9/KILL  
Jun 04 05:39:42 testmispelk systemd[1]: elasticsearch.service: Failed with result 'signal'.  
Jun 04 05:39:42 testmispelk systemd[1]: Failed to start Elasticsearch.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [June 4, 2021, 5:50am UTC](https://discuss.elastic.co/t/elasticsearch-not-working/274944/2 "2021-06-04T05:50:19Z")

</div>

Please share the Elasticsearch logs which will provide more details.

---

<div class="post-metadata">

**Author:** ![Drupad\_Soni](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/drupad_soni/32/89388_2.png) [@Drupad\_Soni](https://discuss.elastic.co/u/Drupad_Soni)\
**Post date:** [June 21, 2021, 10:46am UTC](https://discuss.elastic.co/t/elasticsearch-not-working/274944/3 "2021-06-21T10:46:48Z")

</div>

## root@testmispelk:/# service elasticsearch start Job for elasticsearch.service failed because a fatal signal was delivered to the control process. See "systemctl status elasticsearch.service" and "journalctl -xe" for details. root@testmispelk:/# journalctl -xe Jun 21 10:30:29 testmispelk kernel: [3044] 33 3044 620645 554190 4780032 0 0 php Jun 21 10:30:29 testmispelk kernel: [3404] 0 3404 2837 605 61440 0 0 systemctl Jun 21 10:30:29 testmispelk kernel: [3411] 0 3411 5600 882 86016 0 0 systemd-tty-a\> Jun 21 10:30:29 testmispelk kernel: [3412] 129 3412 2407571 1494776 12185600 0 0 java Jun 21 10:30:29 testmispelk kernel: oom-kill:constraint=CONSTRAINT\_NONE,nodemask=(null),cpuset=/,mems\_allowed=0,global\_oo\> Jun 21 10:30:29 testmispelk kernel: Out of memory: Killed process 3412 (java) total-vm:9630284kB, anon-rss:5977164kB, fil\> Jun 21 10:30:29 testmispelk kernel: oom\_reaper: reaped process 3412 (java), now anon-rss:0kB, file-rss:0kB, shmem-rss:0kB Jun 21 10:30:29 testmispelk systemd[1]: elasticsearch.service: Main process exited, code=killed, status=9/KILL -- Subject: Unit process exited -- Defined-By: systemd -- Support: [http://www.ubuntu.com/support](http://www.ubuntu.com/support)

## -- An ExecStart= process belonging to unit elasticsearch.service has exited.

## -- The process' exit code is 'killed' and its exit status is 9. Jun 21 10:30:29 testmispelk systemd[1]: elasticsearch.service: Failed with result 'signal'. -- Subject: Unit failed -- Defined-By: systemd -- Support: [http://www.ubuntu.com/support](http://www.ubuntu.com/support)

## -- The unit elasticsearch.service has entered the 'failed' state with result 'signal'. Jun 21 10:30:29 testmispelk systemd[1]: Failed to start Elasticsearch. -- Subject: A start job for unit elasticsearch.service has failed -- Defined-By: systemd -- Support: [http://www.ubuntu.com/support](http://www.ubuntu.com/support)

## -- A start job for unit elasticsearch.service has finished with a failure.

-- The job identifier is 3122 and the job result is failed.  
Jun 21 10:30:33 testmispelk sshd[3592]: Invalid user admin1 from 218.111.84.99 port 5931  
Jun 21 10:30:34 testmispelk sshd[3592]: pam\_unix(sshd:auth): check pass; user unknown  
Jun 21 10:30:34 testmispelk sshd[3592]: pam\_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser=\>

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 19, 2021, 10:47am UTC](https://discuss.elastic.co/t/elasticsearch-not-working/274944/4 "2021-07-19T10:47:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
