# Связь с Elasticsearch кластером oбрывается когда пытаюсь открыть дешбоард в кибане

**URL:** <https://discuss.elastic.co/t/elasticsearch-o/24890>\
**Category:** Вопросы на русском языке\
**Created:** [July 4, 2015, 7:36am UTC](https://discuss.elastic.co/t/elasticsearch-o/24890 "2015-07-04T07:36:28Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Drewshg312](https://avatars.discourse-cdn.com/v4/letter/d/4af34b/32.png) [@Drewshg312](https://discuss.elastic.co/u/Drewshg312)\
**Post date:** [July 4, 2015, 7:36am UTC](https://discuss.elastic.co/t/elasticsearch-o/24890/1 "2015-07-04T07:36:28Z")

</div>

Здравствуйте! Такая ситуация: OS X 10.10.4, Elasticsearch 1.6.0, Logstash 1.5.2, Kibana 4.1.0 - все из Homebrew. Использую для анализа результатов из Suricata IDPS.  
Демоны работают нормально, кластер вроде здоров:

```
$ curl -XGET http://127.0.0.1:9200/_cluster/health?pretty
{
  "cluster_name" : "elasticsearch_brew",
  "status" : "green",
  "timed_out" : false,
  "number_of_nodes" : 1,
  "number_of_data_nodes" : 1,
  "active_primary_shards" : 146,
  "active_shards" : 146,
  "relocating_shards" : 0,
  "initializing_shards" : 0,
  "unassigned_shards" : 0,
  "number_of_pending_tasks" : 0,
  "number_of_in_flight_fetch" : 0
}

```

но как только я захожу в Kibana Dashboards - она пытается загрузить их и тут связь с кластером обрывается - Логстэш тут же перестает парсить данные, а Кибана выдает:

```
Error: Bad Gateway
at respond (https://www.server.kibana//index.js?_b=:85279:15)
at checkRespForFailure (https://www.server.kibana//index.js?_b=:85247:7)
at https://www.server.kibana//index.js?_b=:83885:7
at wrappedErrback (https://www.server.kibana//index.js?_b=:20902:78)
at wrappedErrback (https://www.server.kibana//index.js?_b=:20902:78)
at wrappedErrback (https://www.server.kibana//index.js?_b=:20902:78)
at https://www.server.kibana//index.js?_b=:21035:76
at Scope.$eval (https://www.server.kibana//index.js?_b=:22022:28)
at Scope.$digest (https://www.server.kibana//index.js?_b=:21834:31)
at Scope.$apply (https://www.server.kibana//index.js?_b=:22126:24)

```

Плагины Bigdesk и head при попытке обновить страницу долго думают показывая `cluster health status: RED`

**Kibana\_error.log:**

```
[Sat Jul 04 00:09:35.411074 2015] [proxy:error] [pid 39308] [client 127.0.0.1:55168] AH00898: Error reading from remote server returned by /elasticsearch/_msearch, referer: https://www.server.kibana//

```

**/usr/local/var/log/elasticsearch/elasticsearch\_brew.log:**

```
[2015-07-04 00:26:12,517][DEBUG][action.search.type] [Carnage] [logstash-2015.06.24][3], node[ys_yldD3RISn21emE5KSaA], [P], s[STARTED]: Failed to execute [org.elasticsearch.action.search.SearchRequest@6d667b4] lastShard [true]
    org.elasticsearch.ElasticsearchException: java.lang.OutOfMemoryError: Java heap space
        at org.elasticsearch.index.fielddata.plain.AbstractIndexFieldData.load(AbstractIndexFieldData.java:80)
        at org.elasticsearch.search.aggregations.support.ValuesSource$MetaData.load(ValuesSource.java:88)
        at org.elasticsearch.search.aggregations.support.AggregationContext.bytesField(AggregationContext.java:180)
        at org.elasticsearch.search.aggregations.support.AggregationContext.valuesSource(AggregationContext.java:143)
        at org.elasticsearch.search.aggregations.support.ValuesSourceAggregatorFactory.create(ValuesSourceAggregatorFactory.java:53)
        at org.elasticsearch.search.aggregations.AggregatorFactories.createAndRegisterContextAware(AggregatorFactories.java:53)
        at org.elasticsearch.search.aggregations.AggregatorFactories.createSubAggregators(AggregatorFactories.java:71)
        at org.elasticsearch.search.aggregations.Aggregator.<init>(Aggregator.java:191)
        at org.elasticsearch.search.aggregations.bucket.BucketsAggregator.<init>(BucketsAggregator.java:39)
        at org.elasticsearch.search.aggregations.bucket.geogrid.GeoHashGridAggregator.<init>(GeoHashGridAggregator.java:53)
        at org.elasticsearch.search.aggregations.bucket.geogrid.GeoHashGridParser$GeoGridFactory.create(GeoHashGridParser.java:132)
        at org.elasticsearch.search.aggregations.bucket.geogrid.GeoHashGridParser$GeoGridFactory.create(GeoHashGridParser.java:105)
        at org.elasticsearch.search.aggregations.support.ValuesSourceAggregatorFactory.create(ValuesSourceAggregatorFactory.java:54)
        at org.elasticsearch.search.aggregations.AggregatorFactories.createAndRegisterContextAware(AggregatorFactories.java:53)
        at org.elasticsearch.search.aggregations.AggregatorFactories.createTopLevelAggregators(AggregatorFactories.java:157)
        at org.elasticsearch.search.aggregations.AggregationPhase.preProcess(AggregationPhase.java:79)
        at org.elasticsearch.search.query.QueryPhase.execute(QueryPhase.java:100)
        at org.elasticsearch.search.SearchService.loadOrExecuteQueryPhase(SearchService.java:289)
        at org.elasticsearch.search.SearchService.executeQueryPhase(SearchService.java:300)
        at org.elasticsearch.search.action.SearchServiceTransportAction$5.call(SearchServiceTransportAction.java:231)
        at org.elasticsearch.search.action.SearchServiceTransportAction$5.call(SearchServiceTransportAction.java:228)
        at org.elasticsearch.search.action.SearchServiceTransportAction$23.run(SearchServiceTransportAction.java:559)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
    Caused by: org.elasticsearch.common.util.concurrent.ExecutionError: java.lang.OutOfMemoryError: Java heap space
        at org.elasticsearch.common.cache.LocalCache$Segment.get(LocalCache.java:2201)
        at org.elasticsearch.common.cache.LocalCache.get(LocalCache.java:3937)
        at org.elasticsearch.common.cache.LocalCache$LocalManualCache.get(LocalCache.java:4739)
        at org.elasticsearch.indices.fielddata.cache.IndicesFieldDataCache$IndexFieldCache.load(IndicesFieldDataCache.java:167)
        at org.elasticsearch.index.fielddata.plain.AbstractIndexFieldData.load(AbstractIndexFieldData.java:74)
        ... 24 more
    Caused by: java.lang.OutOfMemoryError: Java heap space

```

Ребята, подскажите пожалуйста в чем проблема и как ее можно решить? Спасибо за любую помощь!

---

<div class="post-metadata">

**Author:** ![Igor\_Motov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/igor_motov/32/45193_2.png) [@Igor\_Motov](https://discuss.elastic.co/u/Igor_Motov)\
**Post date:** [July 4, 2015, 1:03pm UTC](https://discuss.elastic.co/t/elasticsearch-o/24890/2 "2015-07-04T13:03:14Z")

</div>

Проблема в этом:

> [@Drewshg312](#):
>
> Caused by: java.lang.OutOfMemoryError: Java heap space

Серверу elasticsearch не хватает памяти, что бы обработать все данные, которые необходимы для показа страницы. По умолчанию, elasticsearch использует [только 1G памяти](https://github.com/elastic/elasticsearch/blob/master/core/src/packaging/common/packaging.properties#L15) и этого часто бывает не достаточно. Изменить количество доступной серверу памяти можно с помощью [переменной окружения ES\_HEAP\_SIZE](https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-configuration.html#_environment_variables).

---

<div class="post-metadata">

**Author:** ![Drewshg312](https://avatars.discourse-cdn.com/v4/letter/d/4af34b/32.png) [@Drewshg312](https://discuss.elastic.co/u/Drewshg312)\
**Post date:** [July 4, 2015, 6:26pm UTC](https://discuss.elastic.co/t/elasticsearch-o/24890/3 "2015-07-04T18:26:41Z")

</div>

@Igor_Motov, Спасибо большое за ответ. Скажите пожалуйста, а где ее можно(и лучше) указать?  
И как понять сколько памяти оптимально выделить серверу... и в каком формате записывать переменную? Вобщем если можно - пример

---

<div class="post-metadata">

**Author:** ![Igor\_Motov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/igor_motov/32/45193_2.png) [@Igor\_Motov](https://discuss.elastic.co/u/Igor_Motov)\
**Post date:** [July 4, 2015, 6:41pm UTC](https://discuss.elastic.co/t/elasticsearch-o/24890/4 "2015-07-04T18:41:05Z")

</div>

Это зависит от того, как Вы сервер запускаете.

---

<div class="post-metadata">

**Author:** ![Drewshg312](https://avatars.discourse-cdn.com/v4/letter/d/4af34b/32.png) [@Drewshg312](https://discuss.elastic.co/u/Drewshg312)\
**Post date:** [July 4, 2015, 7:49pm UTC](https://discuss.elastic.co/t/elasticsearch-o/24890/5 "2015-07-04T19:49:47Z")

</div>

Все нашел! Спасибо... Задал значение в ЛанчАгенте… Может кому-то поможет:  
в **~/Library/LaunchAgents/homebrew.mxcl.elasticsearch.plist** добавил:

```
<key>EnvironmentVariables</key>
<dict>
  <key>ES_HEAP_SIZE</key>
  <string>5g</string>
</dict>
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:51pm UTC](https://discuss.elastic.co/t/elasticsearch-o/24890/6 "2017-07-06T13:51:49Z")

</div>


