# ElasticSearch on AWS EC2

**URL:** <https://discuss.elastic.co/t/elasticsearch-on-aws-ec2/307565>\
**Category:** Elasticsearch\
**Created:** [June 18, 2022, 1:50pm UTC](https://discuss.elastic.co/t/elasticsearch-on-aws-ec2/307565 "2022-06-18T13:50:25Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![chandramouli\_ravi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chandramouli_ravi/32/107222_2.png) [@chandramouli\_ravi](https://discuss.elastic.co/u/chandramouli_ravi)\
**Post date:** [June 18, 2022, 1:50pm UTC](https://discuss.elastic.co/t/elasticsearch-on-aws-ec2/307565/1 "2022-06-18T13:50:25Z")

</div>

Hi,

My project is having Elasticsearch running on few EC2 Machines.  
I want to do 2 things

1. Check ES Query's executed in last 5 minutes or 1 hour
2. Have a tool where i can run SQL on top of Elasticsearch.  
If user is from SQL background, this will help use data in Elasticsearch without learning ES Query syntax.

Could you please help.

Thanks,  
Chandra

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [June 18, 2022, 2:27pm UTC](https://discuss.elastic.co/t/elasticsearch-on-aws-ec2/307565/2 "2022-06-18T14:27:51Z")

</div>

1. You need to monitor that by yourself. Or use audit log (but I think it's available only with a trial or commercial license)
2. There's a SQL endpoint in Elasticsearch. See [SQL | Elasticsearch Guide [8.2] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/xpack-sql.html)

---

<div class="post-metadata">

**Author:** ![chandramouli\_ravi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chandramouli_ravi/32/107222_2.png) [@chandramouli\_ravi](https://discuss.elastic.co/u/chandramouli_ravi)\
**Post date:** [June 18, 2022, 7:58pm UTC](https://discuss.elastic.co/t/elasticsearch-on-aws-ec2/307565/3 "2022-06-18T19:58:45Z")

</div>

Thanks... I tried and able connect using "Elasticsearch-sql-cli.bat [http://username:password@hostname:8080](http://username:password@hostname:8080)" (Actual credentials are not shown here)

Once i am sql prompt, i ran command "show tables", "select \* from tablename"  
i am unable to get the data back. I am getting this error.. Could you please help.  
I tried to check in blogs but i didn't get the actual root cause and fix i need to do.  
Is it because i may not have POST access? This is the 1st time i am trying post in project account.  
I can run get from Postman and Curl.  
sql\> show tables;  
Communication error [Cannot POST address [http://hostname:8080/\_xpack/sql?error\_trace](http://hostname:8080/_xpack/sql?error_trace) (Can't parse error from Elasticsearch [Unexpected character ('\<' (code 60)): expected a valid value (number, String, array, object, 'true', 'false' or 'null')] at [line 1 col 1]. Response:

403 Forbidden
# 403 Forbidden

* * *
nginx/1.10.3 (Ubuntu) )]

Thanks,  
Chandra

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 16, 2022, 7:59pm UTC](https://discuss.elastic.co/t/elasticsearch-on-aws-ec2/307565/4 "2022-07-16T19:59:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
