# Elasticsearch on EKS Fargate

**URL:** <https://discuss.elastic.co/t/elasticsearch-on-eks-fargate/356448>\
**Category:** Elasticsearch\
**Created:** [March 29, 2024, 9:11am UTC](https://discuss.elastic.co/t/elasticsearch-on-eks-fargate/356448 "2024-03-29T09:11:36Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![muhammadali1233ify](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/muhammadali1233ify/32/133107_2.png) [@muhammadali1233ify](https://discuss.elastic.co/u/muhammadali1233ify)\
**Post date:** [March 29, 2024, 9:11am UTC](https://discuss.elastic.co/t/elasticsearch-on-eks-fargate/356448/1 "2024-03-29T09:11:36Z")

</div>

Hi Community.

I have been trying to host / run elasticsearch on fargate but running into permission issues. the default init container definition looks osmething like this.

```auto
initContainers:
      - name: init-sysctl
        image: busybox
        imagePullPolicy: IfNotPresent
        securityContext:
          privileged: true
        command: ["sysctl", "-w", "vm.max_map_count=262144"]

```

but this throws an error on pod when you try to run this deployment.

 ![Screenshot 2024-03-29 at 2.04.45 PM](https://us1.discourse-cdn.com/elastic/original/3X/7/7/77f4a475df6905b63f166ff11e2e060f9ebf1040.png)

if we remove the init container all together from the deployment then elasticsearch throws the following error.

```auto
[2] bootstrap checks failed. You must address the points described in the following [2] lines before starting Elasticsearch. For more information see [https://www.elastic.co/guide/en/elasticsearch/reference/8.11/bootstrap-checks.html]
bootstrap check failure [1] of [2]: max number of threads [1024] for user [elastic] is too low, increase to at least [4096]; for more information see [https://www.elastic.co/guide/en/elasticsearch/reference/8.11/max-number-threads-check.html]
bootstrap check failure [2] of [2]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]; for more information see [https://www.elastic.co/guide/en/elasticsearch/reference/8.11/_maximum_map_count_check.html]

```

I have tried fixing this by attached the following configmap at path `/etc/security/limits.conf`, but that had no impact.

```auto
* hard nproc 100000
    * hard nproc 8192
    * hard rss 10000
    * soft nofile 8192
    * hard nofile 8192

```

If we have a working chart that's used for elastic deployment on EKS Fargate then do share that as well.

Any help on the above issue will be great.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 26, 2024, 9:12am UTC](https://discuss.elastic.co/t/elasticsearch-on-eks-fargate/356448/2 "2024-04-26T09:12:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
