# Elasticsearch refuses to run

**URL:** <https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945>\
**Category:** Elasticsearch\
**Created:** [September 18, 2018, 9:19am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945 "2018-09-18T09:19:05Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 18, 2018, 9:19am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/1 "2018-09-18T09:19:05Z")

</div>

I've installed the .tar.gz package on a Rhel7.5 instance on Amazon Web Services with a RAM of 1GB and volume of 10GB but when I run it with this command "./bin/elasticsearch" I get this error despite reducing the heap size to 512MBs:

`Exception in thread "main" java.nio.file.AccessDeniedException: /elasticsearch-6.3.1/config/jvm.options at sun.nio.fs.UnixException.translateToIOException(UnixException.java:84) at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102) at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107) at sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:214) at java.nio.file.Files.newByteChannel(Files.java:361) at java.nio.file.Files.newByteChannel(Files.java:407) at java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:384) at java.nio.file.Files.newInputStream(Files.java:152) at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:58)`  
What could the issue be?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 18, 2018, 9:28am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/2 "2018-09-18T09:28:44Z")

</div>

> [@adrwer](#):
>
> java.nio.file.AccessDeniedException: /elasticsearch-6.3.1/config/jvm.options

How did you install Elasticsearch?

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 18, 2018, 9:29am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/3 "2018-09-18T09:29:51Z")

</div>

I installed using the .tar.gz option

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 18, 2018, 9:41am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/4 "2018-09-18T09:41:17Z")

</div>

Right, but what did you do exactly?  
What commands, what user?

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 18, 2018, 9:43am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/5 "2018-09-18T09:43:43Z")

</div>

I installed using root and the commands were as follows:

`wget https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-6.4.0.tar.gz wget https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-6.4.0.tar.gz.sha512 shasum -a 512 -c elasticsearch-6.4.0.tar.gz.sha512 !(https://www.elastic.co/guide/en/elasticsearch/reference/current/images/icons/callouts/1.png) tar -xzf elasticsearch-6.4.0.tar.gz cd elasticsearch-6.4.0/ !(https://www.elastic.co/guide/en/elasticsearch/reference/current/images/icons/callouts/2.png)`

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 18, 2018, 9:44am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/6 "2018-09-18T09:44:50Z")

</div>

this is the link to the guide i followed...[https://www.elastic.co/guide/en/elasticsearch/reference/current/zip-targz.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/zip-targz.html)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 18, 2018, 9:45am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/7 "2018-09-18T09:45:30Z")

</div>

What user are you trying to run Elasticsearch as?

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 18, 2018, 9:47am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/8 "2018-09-18T09:47:27Z")

</div>

ec2-user currently coz i tried running the process using root but it keeps on being killed

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 18, 2018, 9:48am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/9 "2018-09-18T09:48:27Z")

</div>

You cannot run Elasticsearch as root, ever, there are checks to stop that.

> [@adrwer](#):
>
> ec2-user

Which would probably explain this;

> [@adrwer](#):
>
> java.nio.file. **AccessDeniedException** : /elasticsearch-6.3.1/config/jvm.options

Why not use the rpm?

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 18, 2018, 9:49am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/10 "2018-09-18T09:49:37Z")

</div>

Does that mean reinstalling elasticsearch with rpm?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 18, 2018, 9:50am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/11 "2018-09-18T09:50:47Z")

</div>

Yes, that creates the proper directory structures, users and service files.

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 18, 2018, 9:53am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/12 "2018-09-18T09:53:51Z")

</div>

can i uninstall the .tar.gz version?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 18, 2018, 9:54am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/13 "2018-09-18T09:54:49Z")

</div>

Just `rm -rf` the directory you extracted.

Also, ideally, you should setup the repo, not just download the RPM. That way you are setup to allow easy upgrades as well.

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 18, 2018, 9:56am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/14 "2018-09-18T09:56:56Z")

</div>

Okay, do you think this guide will help me?...[https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 18, 2018, 9:58am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/15 "2018-09-18T09:58:33Z")

</div>

Yep!

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 18, 2018, 10:01am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/16 "2018-09-18T10:01:24Z")

</div>

Thanks Mark you are awesome

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 18, 2018, 10:01am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/17 "2018-09-18T10:01:52Z")

</div>

Thanks for being sticking through to the end! 🙂

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 18, 2018, 10:03am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/18 "2018-09-18T10:03:01Z")

</div>

🙂

---

<div class="post-metadata">

**Author:** ![adrwer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrwer/32/35629_2.png) [@adrwer](https://discuss.elastic.co/u/adrwer)\
**Post date:** [September 19, 2018, 7:42am UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/19 "2018-09-19T07:42:21Z")

</div>

Blocked by another huddle....I installed Elasticsearch as adviced here:

> [@warkolm](#):
>
> Also, ideally, you should setup the repo, not just download the RPM. That way you are setup to allow easy upgrades as well.

but it sends this error when i try checking if it runs  
`curl: (7) Failed connect to localhost:9200; Connection refused`

i checked if the service was runnning and i found out that it wasn't so i started it then it sent me this response

```
    ● elasticsearch.service - Elasticsearch
       Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
       Active: active (running) since Wed 2018-09-19 07:21:43 UTC; 32s ago
         Docs: http://www.elastic.co
     Main PID: 5798 (java)
       CGroup: /system.slice/elasticsearch.service
               └─5798 /bin/java -Xms512m -Xmx512m -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+AlwaysPreTouch -Xss1m -Djava.awt.headl...

    Sep 19 07:21:43 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: Started Elasticsearch.
    Sep 19 07:21:43 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: Starting Elasticsearch...

```

but on trying to test the Elasticsearch node it still sent me this error  
`curl: (7) Failed connect to localhost:9200; Connection refused`  
and on checking the status of the service, this is what it said

```
● elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
   Active: failed (Result: signal) since Wed 2018-09-19 07:23:52 UTC; 9s ago
     Docs: http://www.elastic.co
  Process: 5798 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=killed, signal=KILL)
 Main PID: 5798 (code=killed, signal=KILL)

Sep 19 07:21:43 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: Started Elasticsearch.
Sep 19 07:21:43 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: Starting Elasticsearch...
Sep 19 07:23:52 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: elasticsearch.service: main process exited, code=killed, status=9/KILL
Sep 19 07:23:52 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: Unit elasticsearch.service entered failed state.
Sep 19 07:23:52 ip-172-31-7-139.us-east-2.compute.internal systemd[1]: elasticsearch.service failed.

```

Please help

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 19, 2018, 7:45pm UTC](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945/20 "2018-09-19T19:45:25Z")

</div>

Check `/var/log/elasticsearch` for something.

[Next page](https://discuss.elastic.co/t/elasticsearch-refuses-to-run/148945.md?page=2)
