# Elasticsearch running on Docker failing in taking snapshots and restore

**URL:** <https://discuss.elastic.co/t/elasticsearch-running-on-docker-failing-in-taking-snapshots-and-restore/225616>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [March 30, 2020, 6:17am UTC](https://discuss.elastic.co/t/elasticsearch-running-on-docker-failing-in-taking-snapshots-and-restore/225616 "2020-03-30T06:17:33Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![620528](https://avatars.discourse-cdn.com/v4/letter/6/13edae/32.png) [@620528](https://discuss.elastic.co/u/620528)\
**Post date:** [March 30, 2020, 6:17am UTC](https://discuss.elastic.co/t/elasticsearch-running-on-docker-failing-in-taking-snapshots-and-restore/225616/1 "2020-03-30T06:17:33Z")

</div>

Below is the logs taken from Curator while running snapshot. Can someone please help me on this ?

```auto

2020-03-30 02:02:52,095 WARNING elasticsearch log_request_fail:149 PUT http://localhost:9200/_snapshot/backup/indices-2020.03.30?wait_for_completion=false [status:500 request:0.551s]
2020-03-30 02:02:52,095 DEBUG elasticsearch log_request_fail:160 > {"ignore_unavailable":false,"include_global_state":true,"partial":false,"indices":"index-2019.04.30"}
2020-03-30 02:02:52,095 DEBUG elasticsearch log_request_fail:165 < {"error":{"root_cause":[{"type":"exception","reason":"failed to create blob container"}],"type":"exception","reason":"failed to create blob container","caused_by":{"type":"access_denied_exception","reason":"/mnt/esbackup/indices/8qdN1CiuQD-sMACmRWbIIA"}},"status":500}
2020-03-30 02:02:52,095 ERROR curator.cli run:213 Failed to complete action: snapshot. <class 'curator.exceptions.FailedExecution'>: Exception encountered. Rerun with loglevel DEBUG and/or check Elasticsearch logs for more information. Exception: TransportError(500, 'exception', 'failed to create blob container')

```

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [March 30, 2020, 6:19am UTC](https://discuss.elastic.co/t/elasticsearch-running-on-docker-failing-in-taking-snapshots-and-restore/225616/2 "2020-03-30T06:19:11Z")

</div>

What does the Elasticsearch logs contain?

---

<div class="post-metadata">

**Author:** ![620528](https://avatars.discourse-cdn.com/v4/letter/6/13edae/32.png) [@620528](https://discuss.elastic.co/u/620528)\
**Post date:** [March 30, 2020, 6:27am UTC](https://discuss.elastic.co/t/elasticsearch-running-on-docker-failing-in-taking-snapshots-and-restore/225616/3 "2020-03-30T06:27:34Z")

</div>

Thanks @Christian_Dahlqvist for the quick response.

It has the very same message saying its not able to access this path given on curator. Access denied only. I am using Elastic 5.6.16 on Docker. I will get you the elasticsearch logs in a while, however with the current info what do you think i am doing wrong here. Its happening only on PROD environment. In lower environment its working perfectly fine.

Its not only happening via Cerebro and also its happening via Cerebro API hit. Access denied exception.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [March 30, 2020, 6:40am UTC](https://discuss.elastic.co/t/elasticsearch-running-on-docker-failing-in-taking-snapshots-and-restore/225616/4 "2020-03-30T06:40:31Z")

</div>

I do not know as I have not seen the Elasticsearch logs, which likely will contain a lot more information. It could be that all nodes do not have access to the shared file system or that it has been mounted incorrectly.

---

<div class="post-metadata">

**Author:** ![620528](https://avatars.discourse-cdn.com/v4/letter/6/13edae/32.png) [@620528](https://discuss.elastic.co/u/620528)\
**Post date:** [March 30, 2020, 6:48am UTC](https://discuss.elastic.co/t/elasticsearch-running-on-docker-failing-in-taking-snapshots-and-restore/225616/5 "2020-03-30T06:48:28Z")

</div>

@Christian_Dahlqvist As it is a PROD environment, i couldn't get the logs at this moment. I will share the elasticsearch logs by this evening.

---

<div class="post-metadata">

**Author:** ![620528](https://avatars.discourse-cdn.com/v4/letter/6/13edae/32.png) [@620528](https://discuss.elastic.co/u/620528)\
**Post date:** [March 30, 2020, 2:15pm UTC](https://discuss.elastic.co/t/elasticsearch-running-on-docker-failing-in-taking-snapshots-and-restore/225616/6 "2020-03-30T14:15:55Z")

</div>

This is the elasticsearch logs we obtained on PROD servers. Can someone please help @Christian_Dahlqvist ?

```auto
[2020-03-30T12:01:06,781][WARN][r.suppressed] path: /_snapshot/analytics_backup/_verify, params: {repository=analytics_backup}
org.elasticsearch.transport.RemoteTransportException: [VFPV-A01ESM03][10.99.64.93:9300][cluster:admin/repository/verify]
Caused by: org.elasticsearch.ElasticsearchException: failed to create blob container
	at org.elasticsearch.common.blobstore.fs.FsBlobStore.blobContainer(FsBlobStore.java:70) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.repositories.blobstore.BlobStoreRepository.startVerification(BlobStoreRepository.java:720) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.repositories.RepositoriesService.verifyRepository(RepositoriesService.java:210) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.action.admin.cluster.repositories.verify.TransportVerifyRepositoryAction.masterOperation(TransportVerifyRepositoryAction.java:70) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.action.admin.cluster.repositories.verify.TransportVerifyRepositoryAction.masterOperation(TransportVerifyRepositoryAction.java:40) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.action.support.master.TransportMasterNodeAction.masterOperation(TransportMasterNodeAction.java:87) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.action.support.master.TransportMasterNodeAction$AsyncSingleAction$2.doRun(TransportMasterNodeAction.java:166) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:675) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) ~[elasticsearch-5.6.16.jar:5.6.16]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) ~[?:1.8.0_212]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) ~[?:1.8.0_212]
	at java.lang.Thread.run(Thread.java:748) [?:1.8.0_212]
Caused by: java.nio.file.AccessDeniedException: /mnt/bkup/elasticsearchbkup/analytics_backup/tests-Mgn1-6jxSJSaBdJIWeNOgg
	at sun.nio.fs.UnixException.translateToIOException(UnixException.java:84) ~[?:?]
	at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102) ~[?:?]
	at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107) ~[?:?]
	at sun.nio.fs.UnixFileSystemProvider.createDirectory(UnixFileSystemProvider.java:384) ~[?:?]
	at java.nio.file.Files.createDirectory(Files.java:674) ~[?:1.8.0_212]
	at java.nio.file.Files.createAndCheckIsDirectory(Files.java:781) ~[?:1.8.0_212]
	at java.nio.file.Files.createDirectories(Files.java:767) ~[?:1.8.0_212]
	at org.elasticsearch.common.blobstore.fs.FsBlobStore.buildAndCreate(FsBlobStore.java:86) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.common.blobstore.fs.FsBlobStore.blobContainer(FsBlobStore.java:68) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.repositories.blobstore.BlobStoreRepository.startVerification(BlobStoreRepository.java:720) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.repositories.RepositoriesService.verifyRepository(RepositoriesService.java:210) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.action.admin.cluster.repositories.verify.TransportVerifyRepositoryAction.masterOperation(TransportVerifyRepositoryAction.java:70) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.action.admin.cluster.repositories.verify.TransportVerifyRepositoryAction.masterOperation(TransportVerifyRepositoryAction.java:40) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.action.support.master.TransportMasterNodeAction.masterOperation(TransportMasterNodeAction.java:87) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.action.support.master.TransportMasterNodeAction$AsyncSingleAction$2.doRun(TransportMasterNodeAction.java:166) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:675) ~[elasticsearch-5.6.16.jar:5.6.16]
	at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) ~[elasticsearch-5.6.16.jar:5.6.16]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) ~[?:1.8.0_212]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) ~[?:1.8.0_212]
	at java.lang.Thread.run(Thread.java:748) ~[?:1.8.0_212]

```

---

<div class="post-metadata">

**Author:** ![620528](https://avatars.discourse-cdn.com/v4/letter/6/13edae/32.png) [@620528](https://discuss.elastic.co/u/620528)\
**Post date:** [March 31, 2020, 10:58am UTC](https://discuss.elastic.co/t/elasticsearch-running-on-docker-failing-in-taking-snapshots-and-restore/225616/7 "2020-03-31T10:58:11Z")

</div>

Can someone please help us on this issue ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 28, 2020, 10:58am UTC](https://discuss.elastic.co/t/elasticsearch-running-on-docker-failing-in-taking-snapshots-and-restore/225616/8 "2020-04-28T10:58:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
