# Elasticsearch S3 Backup Failing

**URL:** <https://discuss.elastic.co/t/elasticsearch-s3-backup-failing/204524>\
**Category:** Elasticsearch\
**Created:** [October 21, 2019, 4:35pm UTC](https://discuss.elastic.co/t/elasticsearch-s3-backup-failing/204524 "2019-10-21T16:35:00Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![akshaymaniyar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akshaymaniyar/32/45836_2.png) [@akshaymaniyar](https://discuss.elastic.co/u/akshaymaniyar)\
**Post date:** [October 21, 2019, 4:35pm UTC](https://discuss.elastic.co/t/elasticsearch-s3-backup-failing/204524/1 "2019-10-21T16:35:00Z")

</div>

Hi,

We run a backup of our data every 3 hours. We have recently started getting the below message because of which the backup fails sometimes. When we retry sometimes it succeeds, sometimes it fails with the same error.

\reason\\:\\[1363871--elasticsearch--2019-06-24--14-20-00--full:snapshot\_1571664901787/S2KnlgBKQWWmkOOO5ZB0nw] failed to create snapshot\\,\\caused\_by\\:\\type\\:\\i\_o\_exception\\,\\reason\\:\\Unable to upload object [indices/G2g4EI-WS4SGcQuaEMVwCA/meta-S2KnlgBKQWWmkOOO5ZB0nw.dat] using a single upload\\,\\caused\_by\\:\\type\\:\\sdk\_client\_exception\\,\\reason\\:\\sdk\_client\_exception: Unable to execute HTTP request: Read timed out\\,\\caused\_by\\:\\type\\:\\i\_o\_exception\\,\\reason\\:\\Read timed out\\,\\status\\:500[\18485.63 MB\, \15.29 pct\, \/usr/share/elasticsearch/jdk/bin/java -Xms16g -Xmx16g -XX:+U\, \8.90 MB\, \0.01 pct\

---

<div class="post-metadata">

**Author:** ![Armin\_Braun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/armin_braun/32/20092_2.png) [@Armin\_Braun](https://discuss.elastic.co/u/Armin_Braun)\
**Post date:** [October 21, 2019, 4:44pm UTC](https://discuss.elastic.co/t/elasticsearch-s3-backup-failing/204524/2 "2019-10-21T16:44:12Z")

</div>

Hi @akshaymaniyar

This is a known issue with S3 snapshots that we recently fixed in [https://github.com/elastic/elasticsearch/pull/46589](https://github.com/elastic/elasticsearch/pull/46589). Upcoming ES v7.5.0 should fix your issue.

---

<div class="post-metadata">

**Author:** ![akshaymaniyar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akshaymaniyar/32/45836_2.png) [@akshaymaniyar](https://discuss.elastic.co/u/akshaymaniyar)\
**Post date:** [October 21, 2019, 6:15pm UTC](https://discuss.elastic.co/t/elasticsearch-s3-backup-failing/204524/3 "2019-10-21T18:15:21Z")

</div>

Thanks for the quick revert. We'll upgrade as soon as it releases.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 18, 2019, 6:15pm UTC](https://discuss.elastic.co/t/elasticsearch-s3-backup-failing/204524/4 "2019-11-18T18:15:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
