# Elasticsearch Search Exception

**URL:** <https://discuss.elastic.co/t/elasticsearch-search-exception/150356>\
**Category:** Elasticsearch\
**Created:** [September 28, 2018, 2:08pm UTC](https://discuss.elastic.co/t/elasticsearch-search-exception/150356 "2018-09-28T14:08:31Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Silen\_logs](https://avatars.discourse-cdn.com/v4/letter/s/ed655f/32.png) [@Silen\_logs](https://discuss.elastic.co/u/Silen_logs)\
**Post date:** [September 28, 2018, 2:08pm UTC](https://discuss.elastic.co/t/elasticsearch-search-exception/150356/1 "2018-09-28T14:08:31Z")

</div>

Hi all,

I have a 3 node cluster in production in 5.6 version. I agreggate the data in daily indices and sometimes my cluster become unavailable and the exception that appears is "search\_phase\_exception".

Reading the cluster logs i can see the following error repeatedly :

\_`caused by: org.elasticsearch.common.util.concurrent.EsRejectedExecutionException: rejected execution of org.elasticsearch.transport.TransportService on EsThreadPoolExecutor[search, queue capacity = 1000, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor[Running, pool size = 16, active threads = 16, queued tasks = 64910, completed tasks = 67899727]]`

I think this is related with threadpool search queue capacity, and the solution is in general put another node to the cluster but i think that my configuration can be optimized.

May you help me to understand this exception ?

Regards.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 26, 2018, 2:08pm UTC](https://discuss.elastic.co/t/elasticsearch-search-exception/150356/2 "2018-10-26T14:08:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
