# Elasticsearch service failed to start on CentOS

**URL:** <https://discuss.elastic.co/t/elasticsearch-service-failed-to-start-on-centos/247034>\
**Category:** Elasticsearch\
**Created:** [September 1, 2020, 3:01am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-to-start-on-centos/247034 "2020-09-01T03:01:18Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![munwarrior](https://avatars.discourse-cdn.com/v4/letter/m/7c8e57/32.png) [@munwarrior](https://discuss.elastic.co/u/munwarrior)\
**Post date:** [September 1, 2020, 3:01am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-to-start-on-centos/247034/1 "2020-09-01T03:01:19Z")

</div>

Hi,

I've follow the steps in [https://casesup.com/category/knowledgebase/installation/how-to-install-elasticsearch-on-linux-server](https://casesup.com/category/knowledgebase/installation/how-to-install-elasticsearch-on-linux-server) to install elasticsearch in Centos 8.

but it stuck at step 3 when I tried to create service and start service, I run the service and find this error below.

> [root@elk-lab ~]# systemctl status elasticsearch.service  
> ● elasticsearch.service - Elasticsearch Service  
> Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: \>  
> Active: failed (Result: exit-code) since Tue 2020-09-01 10:47:13 +08; 11s ago  
> Process: 1965 ExecStart=/home/elksvcid/elasticsearch-7.5.1/bin/elasticsearch (code=exite\>  
> Main PID: 1965 (code=exited, status=203/EXEC)

Kindly help what should I do to settle the issue, thanks.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 1, 2020, 3:15am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-to-start-on-centos/247034/2 "2020-09-01T03:15:04Z")

</div>

Welcome to our community! 😃

Please check the Elasticsearch logs, there should be more there identifying the issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 29, 2020, 3:15am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-to-start-on-centos/247034/3 "2020-09-29T03:15:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
