# Elasticsearch.service: Failed with result 'exit-code'

**URL:** <https://discuss.elastic.co/t/elasticsearch-service-failed-with-result-exit-code/283123>\
**Category:** Elasticsearch\
**Created:** [September 2, 2021, 5:17am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-with-result-exit-code/283123 "2021-09-02T05:17:18Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![padamrai](https://avatars.discourse-cdn.com/v4/letter/p/3da27b/32.png) [@padamrai](https://discuss.elastic.co/u/padamrai)\
**Post date:** [September 2, 2021, 5:17am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-with-result-exit-code/283123/1 "2021-09-02T05:17:18Z")

</div>

My Elasticsearch is not starting, I don't know why I am getting below error.

```auto
root@i3insight2:~# systemctl status elasticsearch.service
â elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2021-09-01 19:27:39 PKT; 14h ago
     Docs: http://www.elastic.co
  Process: 26386 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid (code=exited, status=1/FAILURE)
 Main PID: 26386 (code=exited, status=1/FAILURE)

Sep 01 19:27:39 i3insight2 elasticsearch[26386]: at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)
Sep 01 19:27:39 i3insight2 elasticsearch[26386]: at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:116)
Sep 01 19:27:39 i3insight2 elasticsearch[26386]: at java.base/sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:219)
Sep 01 19:27:39 i3insight2 elasticsearch[26386]: at java.base/java.nio.file.Files.newByteChannel(Files.java:373)
Sep 01 19:27:39 i3insight2 elasticsearch[26386]: at java.base/java.nio.file.Files.newByteChannel(Files.java:424)
Sep 01 19:27:39 i3insight2 elasticsearch[26386]: at java.base/java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:420)
Sep 01 19:27:39 i3insight2 elasticsearch[26386]: at java.base/java.nio.file.Files.newInputStream(Files.java:158)
Sep 01 19:27:39 i3insight2 elasticsearch[26386]: at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:61)
Sep 01 19:27:39 i3insight2 systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
Sep 01 19:27:39 i3insight2 systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

```

I want to do my project in production mode. It is working perfectly underdevelopment of the project after production mode this is not working. I want my project to read data continuously without running manually. But is not working now.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 2, 2021, 5:27am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-with-result-exit-code/283123/2 "2021-09-02T05:27:12Z")

</div>

Please don't post pictures of text or code. They are difficult to read, impossible to search and replicate (if it's code), and some people may not be even able to see them 🙂

---

<div class="post-metadata">

**Author:** ![padamrai](https://avatars.discourse-cdn.com/v4/letter/p/3da27b/32.png) [@padamrai](https://discuss.elastic.co/u/padamrai)\
**Post date:** [September 2, 2021, 5:32am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-with-result-exit-code/283123/3 "2021-09-02T05:32:52Z")

</div>

Dear I edited the post please do help me how to resolve this issue.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 2, 2021, 5:33am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-with-result-exit-code/283123/4 "2021-09-02T05:33:39Z")

</div>

You will need to check `/var/log/elasticsearch` for the full log of what is happening there.

---

<div class="post-metadata">

**Author:** ![padamrai](https://avatars.discourse-cdn.com/v4/letter/p/3da27b/32.png) [@padamrai](https://discuss.elastic.co/u/padamrai)\
**Post date:** [September 2, 2021, 5:43am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-with-result-exit-code/283123/5 "2021-09-02T05:43:22Z")

</div>

This is my log file.

```auto
root@i3insight2:/var/log/elasticsearch# tail -f elasticsearch.log
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-7.2.0.jar:7.2.0]
        at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.2.0.jar:7.2.0]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.2.0.jar:7.2.0]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.2.0.jar:7.2.0]
Caused by: java.lang.RuntimeException: can not run elasticsearch as root
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:105) ~[elasticsearch-7.2.0.jar:7.2.0]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:172) ~[elasticsearch-7.2.0.jar:7.2.0]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:349) ~[elasticsearch-7.2.0.jar:7.2.0]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.2.0.jar:7.2.0]

```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 2, 2021, 5:44am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-with-result-exit-code/283123/6 "2021-09-02T05:44:51Z")

</div>

> [@padamrai](#):
>
> ```auto
> Caused by: java.lang.RuntimeException: can not run elasticsearch as root
> 
> ```

That'd be why.  
How did you install Elasticsearch?

---

<div class="post-metadata">

**Author:** ![padamrai](https://avatars.discourse-cdn.com/v4/letter/p/3da27b/32.png) [@padamrai](https://discuss.elastic.co/u/padamrai)\
**Post date:** [September 2, 2021, 5:49am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-with-result-exit-code/283123/7 "2021-09-02T05:49:03Z")

</div>

This is installed on the server so I don't know about this much, I am just using it last 2 months, It is working fine but since yesterday It is not working. May be a permissions issue from the admin side.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 2, 2021, 5:51am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-with-result-exit-code/283123/8 "2021-09-02T05:51:26Z")

</div>

That's not likely, the service file that is included in DEB/RPM installs ensures that Elasticsearch runs as the correct user.

This sounds like it is a custom install.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 30, 2021, 5:51am UTC](https://discuss.elastic.co/t/elasticsearch-service-failed-with-result-exit-code/283123/9 "2021-09-30T05:51:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
