# Elasticsearch Service Fails to create Node Environment (5.5.6)

**URL:** https://discuss.elastic.co/t/elasticsearch-service-fails-to-create-node-environment-5-5-6/146355
**Category:** Elasticsearch
**Created:** [August 28, 2018, 1:33pm UTC](https://discuss.elastic.co/t/elasticsearch-service-fails-to-create-node-environment-5-5-6/146355 "2018-08-28T13:33:53Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![tbugbee](https://avatars.discourse-cdn.com/v4/letter/t/4bbf92/32.png) [@tbugbee](https://discuss.elastic.co/u/tbugbee)
#### Post date: [August 28, 2018, 1:33pm UTC](https://discuss.elastic.co/t/elasticsearch-service-fails-to-create-node-environment-5-5-6/146355/1 "2018-08-28T13:33:53Z")

</div>

Hello,

I'm running **Elasticsearch 5.5.2** on **Windows Server 2012 R2**. The service has been working for months with no change to the machine or the service (config, bin, etc.) as far as I know. Here are the log messages generated when I attempt to start the service. It stops immediately after starting.

```
[2018-08-28T09:11:35,464][INFO][o.e.e.NodeEnvironment] [AADCWEB609D] using [1] data paths, mounts [[DATA (E:)]], net usable_space [99.3gb], net total_space [99.9gb], spins? [unknown], types [NTFS]
[2018-08-28T09:11:35,480][INFO][o.e.e.NodeEnvironment] [AADCWEB609D] heap size [1.9gb], compressed ordinary object pointers [true]
[2018-08-28T09:11:35,980][ERROR][o.e.b.Bootstrap] Exception
java.lang.IllegalStateException: Failed to create node environment
	at org.elasticsearch.node.Node.<init>(Node.java:267) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.node.Node.<init>(Node.java:244) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:232) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:232) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:351) [elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) [elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) [elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67) [elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) [elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.cli.Command.main(Command.java:88) [elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) [elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) [elasticsearch-5.5.2.jar:5.5.2]
Caused by: java.io.IOException: failed to write in data directory [E:\Elasticsearch\data\nodes\0\indices\hhRngq1_QE-91vOmuIEYvw\0\_state] write permission is required
	at org.elasticsearch.env.NodeEnvironment.tryWriteTempFile(NodeEnvironment.java:1076) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.env.NodeEnvironment.assertCanWrite(NodeEnvironment.java:1059) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:278) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.node.Node.<init>(Node.java:264) ~[elasticsearch-5.5.2.jar:5.5.2]
	... 11 more
Caused by: java.nio.file.FileAlreadyExistsException: E:\Elasticsearch\data\nodes\0\indices\hhRngq1_QE-91vOmuIEYvw\0\_state\.es_temp_file
	at sun.nio.fs.WindowsException.translateToIOException(WindowsException.java:81) ~[?:?]
	at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:97) ~[?:?]
	at sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:102) ~[?:?]
	at sun.nio.fs.WindowsFileSystemProvider.newByteChannel(WindowsFileSystemProvider.java:230) ~[?:?]
	at java.nio.file.Files.newByteChannel(Files.java:361) ~[?:1.8.0_161]
	at java.nio.file.Files.createFile(Files.java:632) ~[?:1.8.0_161]
	at org.elasticsearch.env.NodeEnvironment.tryWriteTempFile(NodeEnvironment.java:1073) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.env.NodeEnvironment.assertCanWrite(NodeEnvironment.java:1059) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:278) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.node.Node.<init>(Node.java:264) ~[elasticsearch-5.5.2.jar:5.5.2]
	... 11 more
[2018-08-28T09:11:36,230][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [AADCWEB609D] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: Failed to create node environment
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:127) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.cli.Command.main(Command.java:88) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) ~[elasticsearch-5.5.2.jar:5.5.2]
Caused by: java.lang.IllegalStateException: Failed to create node environment
	at org.elasticsearch.node.Node.<init>(Node.java:267) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.node.Node.<init>(Node.java:244) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:232) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:232) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:351) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) ~[elasticsearch-5.5.2.jar:5.5.2]
	... 6 more
Caused by: java.io.IOException: failed to write in data directory [E:\Elasticsearch\data\nodes\0\indices\hhRngq1_QE-91vOmuIEYvw\0\_state] write permission is required
	at org.elasticsearch.env.NodeEnvironment.tryWriteTempFile(NodeEnvironment.java:1076) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.env.NodeEnvironment.assertCanWrite(NodeEnvironment.java:1059) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:278) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.node.Node.<init>(Node.java:264) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.node.Node.<init>(Node.java:244) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:232) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:232) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:351) ~[elasticsearch-5.5.2.jar:5.5.2]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) ~[elasticsearch-5.5.2.jar:5.5.2]
	... 6 more

```

Any help or suggestions is greatly appreciated. Thank you,

Tyler

---

<div class="post-metadata">

### Author: ![tbugbee](https://avatars.discourse-cdn.com/v4/letter/t/4bbf92/32.png) [@tbugbee](https://discuss.elastic.co/u/tbugbee)
#### Post date: [August 28, 2018, 1:38pm UTC](https://discuss.elastic.co/t/elasticsearch-service-fails-to-create-node-environment-5-5-6/146355/2 "2018-08-28T13:38:52Z")

</div>

The service is set to log on as the local system account, which has full permissions to E:\Elasticsearch.

---

<div class="post-metadata">

### Author: ![tbugbee](https://avatars.discourse-cdn.com/v4/letter/t/4bbf92/32.png) [@tbugbee](https://discuss.elastic.co/u/tbugbee)
#### Post date: [September 6, 2018, 8:07pm UTC](https://discuss.elastic.co/t/elasticsearch-service-fails-to-create-node-environment-5-5-6/146355/3 "2018-09-06T20:07:21Z")

</div>

bump

---

<div class="post-metadata">

### Author: ![tbugbee](https://avatars.discourse-cdn.com/v4/letter/t/4bbf92/32.png) [@tbugbee](https://discuss.elastic.co/u/tbugbee)
#### Post date: [September 26, 2018, 3:07pm UTC](https://discuss.elastic.co/t/elasticsearch-service-fails-to-create-node-environment-5-5-6/146355/4 "2018-09-26T15:07:58Z")

</div>

I figured it out!

Take a look at this line:  
`Caused by: java.nio.file.FileAlreadyExistsException: E:\Elasticsearch\data\nodes\0\indices\hhRngq1_QE-91vOmuIEYvw\0\_state\.es_temp_file`

I'm not sure what generates this file or causes it to be persistent, but after deleting .es\_temp\_file, everything began working normally. Maybe it wasn't destroyed automatically like it's supposed to?

In any event, I am no longer experiencing issues and the file is not staying persistent.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 24, 2018, 3:08pm UTC](https://discuss.elastic.co/t/elasticsearch-service-fails-to-create-node-environment-5-5-6/146355/5 "2018-10-24T15:08:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
