# Elasticsearch Service Fails to Load - KeyRing Errors

**URL:** <https://discuss.elastic.co/t/elasticsearch-service-fails-to-load-keyring-errors/142055>\
**Category:** Elasticsearch\
**Created:** [July 29, 2018, 5:16am UTC](https://discuss.elastic.co/t/elasticsearch-service-fails-to-load-keyring-errors/142055 "2018-07-29T05:16:59Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ahaw021](https://avatars.discourse-cdn.com/v4/letter/a/d78d45/32.png) [@ahaw021](https://discuss.elastic.co/u/ahaw021)\
**Post date:** [July 29, 2018, 5:16am UTC](https://discuss.elastic.co/t/elasticsearch-service-fails-to-load-keyring-errors/142055/1 "2018-07-29T05:16:59Z")

</div>

Hi All

Haven't had much luck with this. When starting Elasticsearch using Systemd i get the following errors:

**Tail of Systemd Logs:**

Jul 29 04:50:22 vps systemd[1]: Started Elasticsearch.  
Jul 29 04:50:22 vps systemd[578]: elasticsearch.service: Failed to change ownership of session keyring: Permission denied  
Jul 29 04:50:22 vps systemd[578]: elasticsearch.service: Failed to set up kernel keyring: Permission denied  
Jul 29 04:50:22 vps systemd[578]: elasticsearch.service: Failed at step KEYRING spawning /usr/share/elasticsearch/bin/elasticsearch: Permission denied  
Jul 29 04:50:22 vps systemd[1]: elasticsearch.service: Main process exited, code=exited, status=237/KEYRING  
Jul 29 04:50:22 vps systemd[1]: elasticsearch.service: Failed with result 'exit-code'.  
Jul 29 05:03:52 vps systemd[1]: Started Elasticsearch.  
Jul 29 05:03:52 vps systemd[1]: elasticsearch.service: Main process exited, code=exited, status=237/KEYRING  
Jul 29 05:03:52 vps systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

**Linux Version:**

PRETTY\_NAME="Debian GNU/Linux 9 (stretch)"  
NAME="Debian GNU/Linux"  
VERSION\_ID="9"  
VERSION="9 (stretch)"  
ID=debian

**Open-JDK Version:**

openjdk version "1.8.0\_151"  
OpenJDK Runtime Environment (build 1.8.0\_151-8u151-b12-1~deb9u1-b12)  
OpenJDK 64-Bit Server VM (build 25.151-b12, mixed mode)

Hopefully someone can point me in the right direction

Andrei

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 26, 2018, 5:17am UTC](https://discuss.elastic.co/t/elasticsearch-service-fails-to-load-keyring-errors/142055/2 "2018-08-26T05:17:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
