# ElasticSearch Service Failure status=78/n/a

**URL:** <https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461>\
**Category:** Elasticsearch\
**Created:** [April 25, 2018, 10:45am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461 "2018-04-25T10:45:23Z")\
**Posts on this page:** 19\
**Page:** 1

<div class="post-metadata">

**Author:** ![thompsonlau](https://avatars.discourse-cdn.com/v4/letter/t/e9a140/32.png) [@thompsonlau](https://discuss.elastic.co/u/thompsonlau)\
**Post date:** [April 25, 2018, 10:45am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/1 "2018-04-25T10:45:23Z")

</div>

I have installed ElasticSearch v6.2.4 on CentOS 7.0

I have done all necessary configurations. When I run it, I got the following messages in system.

Apr 25 18:24:18 QVELKSRH01 systemd[1]: elasticsearch.service: main process exited, code=exited, status=78/n/a  
Apr 25 18:24:18 QVELKSRH01 systemd[1]: Unit elasticsearch.service entered failed state.  
Apr 25 18:24:18 QVELKSRH01 systemd[1]: elasticsearch.service failed.

How can I solve the problem? Thanks.

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [April 25, 2018, 10:57am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/2 "2018-04-25T10:57:59Z")

</div>

You have installed but have you configured Elasticsearch? What is in your elasticsearch.yml

---

<div class="post-metadata">

**Author:** ![thompsonlau](https://avatars.discourse-cdn.com/v4/letter/t/e9a140/32.png) [@thompsonlau](https://discuss.elastic.co/u/thompsonlau)\
**Post date:** [April 25, 2018, 11:05am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/3 "2018-04-25T11:05:44Z")

</div>

I have configured elasticsearch.

The content of elasticsearch.yml is as below,

```
# ======================== Elasticsearch Configuration =========================
#
# NOTE: Elasticsearch comes with reasonable defaults for most settings.
# Before you set out to tweak and tune the configuration, make sure you
# understand what are you trying to accomplish and the consequences.
#
# The primary way of configuring a node is via this file. This template lists
# the most important settings you may want to configure for a production cluster .
#
# Please consult the documentation for further information on configuration opti ons:
# https://www.elastic.co/guide/en/elasticsearch/reference/index.html
#
# ---------------------------------- Cluster -----------------------------------
#
# Use a descriptive name for your cluster:
#
#cluster.name: Elastic Search
#
# ------------------------------------ Node ------------------------------------
#
# Use a descriptive name for the node
#
node.name: QVELKSRH01
#
# Add custom attributes to the node:
#
#node.attr.rack: r1
#
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comm a):
#
path.data: /var/lib/elasticsearch
#
# Path to log files:
#
path.logs: /var/log/elasticsearch
#
# ----------------------------------- Memory -----------------------------------
#
# Lock the memory on startup:
#
#bootstrap.memory_lock: true
bootstrp.system_call_filter: false
#
# Make sure that the heap size is set to about half the memory available
# on the system and that the owner of the process is allowed to use this
# limit.
#
# Elasticsearch performs poorly when the system is swapping the memory.
#
# ---------------------------------- Network -----------------------------------
#
# Set the bind address to a specific IP (IPv4 or IPv6):
#
network.host: 10.51.20.23
#
# Set a custom port for HTTP:
#
http.port: 9200
#
# For more information, consult the network module documentation.
#
# --------------------------------- Discovery ----------------------------------
#
# Pass an initial list of hosts to perform discovery when new node is started:
# The default list of hosts is ["127.0.0.1", "[::1]"]
#
#discovery.zen.ping.unicast.hosts: [10.51.20.23:9300,""]
#
# Prevent the "split brain" by configuring the majority of nodes (total number o f master-eligible nodes / 2 + 1):
#
#discovery.zen.minimum_master_nodes = 1:
#
# For more information, consult the zen discovery module documentation.
#
# ---------------------------------- Gateway -----------------------------------
#
# Block initial recovery after a full cluster restart until N nodes are started:
#
#gateway.recover_after_nodes: 3
#
# For more information, consult the gateway module documentation.
#
# ---------------------------------- Various -----------------------------------
#
# Require explicit names when deleting indices:
#
#action.destructive_requires_name: true
```

---

<div class="post-metadata">

**Author:** ![thompsonlau](https://avatars.discourse-cdn.com/v4/letter/t/e9a140/32.png) [@thompsonlau](https://discuss.elastic.co/u/thompsonlau)\
**Post date:** [April 26, 2018, 4:37pm UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/4 "2018-04-26T16:37:19Z")

</div>

What's wrong in the configuration?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 26, 2018, 4:51pm UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/5 "2018-04-26T16:51:54Z")

</div>

`bootstrp` ?

---

<div class="post-metadata">

**Author:** ![thompsonlau](https://avatars.discourse-cdn.com/v4/letter/t/e9a140/32.png) [@thompsonlau](https://discuss.elastic.co/u/thompsonlau)\
**Post date:** [April 27, 2018, 3:51am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/6 "2018-04-27T03:51:34Z")

</div>

I have corrected it but it keeps starting and the connection (port 9200) is refused. I don't know how to solve.

From systems service log, It is still starting stage for long tim

```auto
Apr 27 11:31:35 QVELKSRH01 systemd[1]: Stopping Elasticsearch.
Apr 27 11:31:35 QVELKSRH01 systemd[1]: Started Elasticsearch.e
Apr 27 11:31:35 QVELKSRH01 systemd[1]: Starting Elasticsearch.

```

From the elasticsearch.log,

```auto
[2018-04-27T11:31:35,292][INFO][o.e.n.Node] [QVELKSRH01] stopping ...
[2018-04-27T11:31:35,331][INFO][o.e.n.Node] [QVELKSRH01] stopped
[2018-04-27T11:31:35,332][INFO][o.e.n.Node] [QVELKSRH01] closing ...
[2018-04-27T11:31:35,345][INFO][o.e.n.Node] [QVELKSRH01] closed
[2018-04-27T11:31:37,713][INFO][o.e.n.Node] [QVELKSRH01] initializing ...
[2018-04-27T11:31:37,787][INFO][o.e.e.NodeEnvironment] [QVELKSRH01] using [1] data paths, mounts [[/ (rootfs)]], net usable_space [48.7gb], net total_space [49.9gb], types [rootfs]
[2018-04-27T11:31:37,787][INFO][o.e.e.NodeEnvironment] [QVELKSRH01] heap size [1.9gb], compressed ordinary object pointers [true]
[2018-04-27T11:31:37,788][INFO][o.e.n.Node] [QVELKSRH01] node name [QVELKSRH01], node ID [FndpeyYfQ6Oo_U-F8aQusg]
[2018-04-27T11:31:37,788][INFO][o.e.n.Node] [QVELKSRH01] version[6.2.4], pid[12014], build[ccec39f/2018-04-12T20:37:28.497551Z], OS[Linux/3.10.0-693.el7.x86_64/amd64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0_171/25.171-b11]
[2018-04-27T11:31:37,788][INFO][o.e.n.Node] [QVELKSRH01] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Djava.io.tmpdir=/tmp/elasticsearch.EvFo8Q0n, -XX:+HeapDumpOnOutOfMemoryError, -XX:HeapDumpPath=/var/lib/elasticsearch, -XX:+PrintGCDetails, -XX:+PrintGCDateStamps, -XX:+PrintTenuringDistribution, -XX:+PrintGCApplicationStoppedTime, -Xloggc:/var/log/elasticsearch/gc.log, -XX:+UseGCLogFileRotation, -XX:NumberOfGCLogFiles=32, -XX:GCLogFileSize=64m, -Des.path.home=/usr/share/elasticsearch, -Des.path.conf=/etc/elasticsearch]
[2018-04-27T11:31:38,504][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [aggs-matrix-stats]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [analysis-common]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [ingest-common]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [lang-expression]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [lang-mustache]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [lang-painless]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [mapper-extras]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [parent-join]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [percolator]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [rank-eval]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [reindex]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [repository-url]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [transport-netty4]
[2018-04-27T11:31:38,505][INFO][o.e.p.PluginsService] [QVELKSRH01] loaded module [tribe]
[2018-04-27T11:31:38,506][INFO][o.e.p.PluginsService] [QVELKSRH01] no plugins loaded
[2018-04-27T11:31:40,781][INFO][o.e.d.DiscoveryModule] [QVELKSRH01] using discovery type [zen]
[2018-04-27T11:31:41,194][INFO][o.e.n.Node] [QVELKSRH01] initialized
[2018-04-27T11:31:41,194][INFO][o.e.n.Node] [QVELKSRH01] starting ...
[2018-04-27T11:31:41,391][INFO][o.e.t.TransportService] [QVELKSRH01] publish_address {10.51.20.23:9300}, bound_addresses {10.51.20.23:9300}
[2018-04-27T11:31:41,409][INFO][o.e.b.BootstrapChecks] [QVELKSRH01] bound or publishing to a non-loopback address, enforcing bootstrap checks
[2018-04-27T11:31:44,492][INFO][o.e.c.s.MasterService] [QVELKSRH01] zen-disco-elected-as-master ([0] nodes joined), reason: new_master {QVELKSRH01}{FndpeyYfQ6Oo_U-F8aQusg}{9gzDrupuR5SiVRSJ7we5MA}{10.51.20.23}{10.51.20.23:9300}
[2018-04-27T11:31:44,501][INFO][o.e.c.s.ClusterApplierService] [QVELKSRH01] new_master {QVELKSRH01}{FndpeyYfQ6Oo_U-F8aQusg}{9gzDrupuR5SiVRSJ7we5MA}{10.51.20.23}{10.51.20.23:9300}, reason: apply cluster state (from master [master {QVELKSRH01}{FndpeyYfQ6Oo_U-F8aQusg}{9gzDrupuR5SiVRSJ7we5MA}{10.51.20.23}{10.51.20.23:9300} committed version [1] source [zen-disco-elected-as-master ([0] nodes joined)]])
[2018-04-27T11:31:44,524][INFO][o.e.h.n.Netty4HttpServerTransport] [QVELKSRH01] publish_address {10.51.20.23:9200}, bound_addresses {10.51.20.23:9200}
[2018-04-27T11:31:44,525][INFO][o.e.n.Node] [QVELKSRH01] started
[2018-04-27T11:31:44,537][INFO][o.e.g.GatewayService] [QVELKSRH01] recovered [0] indices into cluster_state

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 27, 2018, 4:04am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/7 "2018-04-27T04:04:24Z")

</div>

Run that from the machine where elasticsearch has been started:

```auto
curl 10.51.20.23:9200

```

---

<div class="post-metadata">

**Author:** ![thompsonlau](https://avatars.discourse-cdn.com/v4/letter/t/e9a140/32.png) [@thompsonlau](https://discuss.elastic.co/u/thompsonlau)\
**Post date:** [April 27, 2018, 4:08am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/8 "2018-04-27T04:08:51Z")

</div>

It shows some output with attributes.

I just wonder why I can't access through web browser

After this, what steps should I follow then? I'm a bit getting lost.

Thanks.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 27, 2018, 4:28am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/9 "2018-04-27T04:28:04Z")

</div>

So everything is working well on elasticsearch side as the logs suggest.

May be look if you have a proxy defined in your browser, a firewall somewhere...  
And if it does not work, share what you are exactly doing in the browser. Which URL?

---

<div class="post-metadata">

**Author:** ![thompsonlau](https://avatars.discourse-cdn.com/v4/letter/t/e9a140/32.png) [@thompsonlau](https://discuss.elastic.co/u/thompsonlau)\
**Post date:** [April 27, 2018, 5:05am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/10 "2018-04-27T05:05:14Z")

</div>

I try to access it via [http://10.51.20.23:9200](http://10.51.20.23:9200) in the same network bypassing proxy and firewall.

Nothing is displayed.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 27, 2018, 5:19am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/11 "2018-04-27T05:19:50Z")

</div>

I can't tell. If elasticsearch is working with:

```auto
curl 10.51.20.23:9200

```

Then you have a problem on your end. Double check that you can access this machine from your laptop by like doing a telnet or curl **from your machine** on port 9200.

---

<div class="post-metadata">

**Author:** ![thompsonlau](https://avatars.discourse-cdn.com/v4/letter/t/e9a140/32.png) [@thompsonlau](https://discuss.elastic.co/u/thompsonlau)\
**Post date:** [April 27, 2018, 6:58am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/12 "2018-04-27T06:58:29Z")

</div>

I can ping it but unable to telnet it via port 9200.

Any setting also needs to be changed?

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [April 27, 2018, 7:18am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/13 "2018-04-27T07:18:32Z")

</div>

@thompsonlau as @dadoonet has kindly pointed out, are you able to `curl 10.51.20.23:9200` ?

---

<div class="post-metadata">

**Author:** ![thompsonlau](https://avatars.discourse-cdn.com/v4/letter/t/e9a140/32.png) [@thompsonlau](https://discuss.elastic.co/u/thompsonlau)\
**Post date:** [April 27, 2018, 7:20am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/14 "2018-04-27T07:20:59Z")

</div>

Found the problem. The CentOS firewall block it.

I now can access the page via web browser. Then what part of procedures should I move on to configure elasticsearch?

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [April 27, 2018, 7:25am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/15 "2018-04-27T07:25:36Z")

</div>

from here go forth with [https://www.elastic.co/guide/en/elasticsearch/reference/current/\_exploring\_your\_cluster.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/_exploring_your_cluster.html)

---

<div class="post-metadata">

**Author:** ![thompsonlau](https://avatars.discourse-cdn.com/v4/letter/t/e9a140/32.png) [@thompsonlau](https://discuss.elastic.co/u/thompsonlau)\
**Post date:** [April 27, 2018, 7:29am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/16 "2018-04-27T07:29:37Z")

</div>

OK thanks. Actually will ElasticSearch goes with GUI? At which step I can access UI?

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [April 27, 2018, 8:04am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/17 "2018-04-27T08:04:44Z")

</div>

Ensure Kibana is installed, started, listening on port 5601: [https://www.elastic.co/guide/en/kibana/current/getting-started.html](https://www.elastic.co/guide/en/kibana/current/getting-started.html)

Then and depending on your setup visit `http://10.51.20.23:5601`

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 27, 2018, 8:37am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/18 "2018-04-27T08:37:03Z")

</div>

> [@thompsonlau](#):
>
> Found the problem. The CentOS firewall block it.

Isn't what I said?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 25, 2018, 8:37am UTC](https://discuss.elastic.co/t/elasticsearch-service-failure-status-78-n-a/129461/19 "2018-05-25T08:37:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
