# Elasticsearch service getting aborted

**URL:** <https://discuss.elastic.co/t/elasticsearch-service-getting-aborted/221857>\
**Category:** Elasticsearch\
**Created:** [March 3, 2020, 10:45am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-aborted/221857 "2020-03-03T10:45:08Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ihjaz](https://avatars.discourse-cdn.com/v4/letter/i/8baadc/32.png) [@Ihjaz](https://discuss.elastic.co/u/Ihjaz)\
**Post date:** [March 3, 2020, 10:45am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-aborted/221857/1 "2020-03-03T10:45:08Z")

</div>

Hi,

I'm running Elasticsearch 6.2.2 on Rhel 7.6 and Java openjdk 1.8.0\_242.

When the Elasticsearch is started, it keeps getting aborted with the following error:

```
Mar 03 16:07:15 barnda044 systemd[1]: Started Elasticsearch.
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: #
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: # A fatal error has been detected by the Java Runtime Environment:
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: #
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: # SIGSEGV (0xb) at pc=0x00007fedbcc29b85, pid=29823, tid=0x00007fedeaadb700
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: #
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: # JRE version: OpenJDK Runtime Environment (8.0_242-b08) (build 1.8.0_242-b08)
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: # Java VM: OpenJDK 64-Bit Server VM (25.242-b08 mixed mode linux-amd64 compressed oops)
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: # Problematic frame:
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: # C [jna9139010698262288310.tmp+0x12b85] ffi_prep_closure_loc+0x15
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: #
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: #
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: # An error report file with more information is saved as:
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: # /tmp/hs_err_pid29823.log
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: #
Mar 03 16:07:17 barnda044 elasticsearch-wrapper[29823]: # If you would like to submit a bug report, please visit:
Mar 03 16:07:17 barnda044 systemd[1]: elasticsearch.service: main process exited, code=killed, status=6/ABRT
Mar 03 16:07:17 barnda044 systemd[1]: Unit elasticsearch.service entered failed state.
Mar 03 16:07:17 barnda044 systemd[1]: elasticsearch.service failed.

```

Any idea how I can fix this?

---

<div class="post-metadata">

**Author:** ![HenningAndersen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/henningandersen/32/48188_2.png) [@HenningAndersen](https://discuss.elastic.co/u/HenningAndersen)\
**Post date:** [March 3, 2020, 11:03am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-aborted/221857/2 "2020-03-03T11:03:39Z")

</div>

Hi @Ihjaz,

the file: `/tmp/hs_err_pid29823.log` should contain more details and would be worthwhile looking into.

There is a previous issue that resembles this though for an older ES version:

> <https://github.com/elastic/elasticsearch/issues/18272>
>
> Elasticsearch version 2.2
> JVM version: 1.7.0\_75
> OS version: CentOS release 6.7
> Description of the problem including expected versus actual behavior:
> Starting elasticsearch fails to start...

---

<div class="post-metadata">

**Author:** ![Ihjaz](https://avatars.discourse-cdn.com/v4/letter/i/8baadc/32.png) [@Ihjaz](https://discuss.elastic.co/u/Ihjaz)\
**Post date:** [March 3, 2020, 1:31pm UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-aborted/221857/3 "2020-03-03T13:31:42Z")

</div>

Thanks @HenningAndersen.

Changing the jna tmp dir to /var/lib/elasticsearch as mentioned in the thread you shared fixed the issue.

-Djna.tmpdir=/var/lib/elasticsearch/tmp

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 31, 2020, 1:31pm UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-aborted/221857/4 "2020-03-31T13:31:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
