# Elasticsearch service getting failed on Ubuntu 20.4

**URL:** <https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677>\
**Category:** Elasticsearch\
**Created:** [October 28, 2022, 11:44am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677 "2022-10-28T11:44:21Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![BJawaid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjawaid/32/112648_2.png) [@BJawaid](https://discuss.elastic.co/u/BJawaid)\
**Post date:** [October 28, 2022, 11:44am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/1 "2022-10-28T11:44:22Z")

</div>

Hi, I have installed elasticsearch 7.1.0 on Ubuntu 20.4 with java-11-openjdk-amd64. Since I am not a developer hence I expect respect for this post.

Elasticsearch service is getting started successfully whenever I run;

sudo -i service elasticsearch start

and after 3 seconds when I check the status here is the output;

\</\>  
root@server:~# sudo -i service elasticsearch status  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Fri 2022-10-28 16:24:31 PKT; 28s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 6851 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)  
Main PID: 6851 (code=exited, status=1/FAILURE)

Oct 28 16:24:28 server.rni.com.pk systemd[1]: Started Elasticsearch.  
Oct 28 16:24:31 server.rni.com.pk systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE  
Oct 28 16:24:31 server.rni.com.pk systemd[1]: elasticsearch.service: Failed with result 'exit-code'.  
\</\>

I checked for Elastic Search Logs and found below details but unable to find any help with regards to the same;

\</\>

[2022-10-28T15:53:55,440][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [server.xyz.com.pk] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: ElasticsearchException[java.io.IOException: failed to read /var/lib/elasticsearch/nodes/0/\_state/node-14.st]; nested: IOException[failed to read /var/lib/elasticsearch/nodes/0/\_state/node-14.st]; nested: XContentParseException[[-1:36] [node\_meta\_data] unknown field [node\_version], parser not found];  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:163) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-7.1.0.jar:7.1.0]  
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.1.0.jar:7.1.0]  
Caused by: org.elasticsearch.ElasticsearchException: java.io.IOException: failed to read /var/lib/elasticsearch/nodes/0/\_state/node-14.st  
at org.elasticsearch.ExceptionsHelper.maybeThrowRuntimeAndSuppress(ExceptionsHelper.java:165) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.gateway.MetaDataStateFormat.loadGeneration(MetaDataStateFormat.java:414) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.gateway.MetaDataStateFormat.loadLatestStateWithGeneration(MetaDataStateFormat.java:433) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.gateway.MetaDataStateFormat.loadLatestState(MetaDataStateFormat.java:454) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.env.NodeEnvironment.loadOrCreateNodeMetaData(NodeEnvironment.java:406) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:302) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.node.Node.(Node.java:272) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.node.Node.(Node.java:252) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:211) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:211) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:325) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.1.0.jar:7.1.0]  
... 6 more  
Caused by: java.io.IOException: failed to read /var/lib/elasticsearch/nodes/0/\_state/node-14.st  
at org.elasticsearch.gateway.MetaDataStateFormat.loadGeneration(MetaDataStateFormat.java:408) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.gateway.MetaDataStateFormat.loadLatestStateWithGeneration(MetaDataStateFormat.java:433) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.gateway.MetaDataStateFormat.loadLatestState(MetaDataStateFormat.java:454) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.env.NodeEnvironment.loadOrCreateNodeMetaData(NodeEnvironment.java:406) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:302) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.node.Node.(Node.java:272) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.node.Node.(Node.java:252) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:211) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:211) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:325) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.1.0.jar:7.1.0]  
... 6 more  
Caused by: org.elasticsearch.common.xcontent.XContentParseException: [-1:36] [node\_meta\_data] unknown field [node\_version], parser not found  
at org.elasticsearch.common.xcontent.ObjectParser.getParser(ObjectParser.java:369) ~[elasticsearch-x-content-7.1.0.jar:7.1.0]  
at org.elasticsearch.common.xcontent.ObjectParser.parse(ObjectParser.java:158) ~[elasticsearch-x-content-7.1.0.jar:7.1.0]  
at org.elasticsearch.common.xcontent.ObjectParser.apply(ObjectParser.java:182) ~[elasticsearch-x-content-7.1.0.jar:7.1.0]  
at org.elasticsearch.env.NodeMetaData$1.fromXContent(NodeMetaData.java:110) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.env.NodeMetaData$1.fromXContent(NodeMetaData.java:94) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.gateway.MetaDataStateFormat.read(MetaDataStateFormat.java:302) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.gateway.MetaDataStateFormat.loadGeneration(MetaDataStateFormat.java:404) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.gateway.MetaDataStateFormat.loadLatestStateWithGeneration(MetaDataStateFormat.java:433) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.gateway.MetaDataStateFormat.loadLatestState(MetaDataStateFormat.java:454) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.env.NodeEnvironment.loadOrCreateNodeMetaData(NodeEnvironment.java:406) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:302) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.node.Node.(Node.java:272) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.node.Node.(Node.java:252) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:211) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:211) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:325) ~[elasticsearch-7.1.0.jar:7.1.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.1.0.jar:7.1.0]  
... 6 more  
\</\>

I checked my other Centos Servers and found that Elasticsearch is running smoothly for more than 2 months but I am unable to have this consistency on this machine. Any precious advice for this will be very helpful.

Thanks.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 28, 2022, 11:44am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/2 "2022-10-28T11:44:22Z")

</div>

elasticsearch 7.1 is [EOL](https://www.elastic.co/support/eol) and no longer supported. Please upgrade ASAP.

(This is an automated response from your friendly Elastic bot. Please report this post if you have any suggestions or concerns :elasticheart: )

---

<div class="post-metadata">

**Author:** ![BJawaid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjawaid/32/112648_2.png) [@BJawaid](https://discuss.elastic.co/u/BJawaid)\
**Post date:** [October 28, 2022, 12:29pm UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/3 "2022-10-28T12:29:03Z")

</div>

when I am trying to upgrade Elasticsearch the service is not starting at all.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 31, 2022, 1:35am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/4 "2022-10-31T01:35:36Z")

</div>

Welcome to our community! 😃

Are you trying to install this as a new instance?

---

<div class="post-metadata">

**Author:** ![BJawaid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjawaid/32/112648_2.png) [@BJawaid](https://discuss.elastic.co/u/BJawaid)\
**Post date:** [October 31, 2022, 5:50am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/5 "2022-10-31T05:50:12Z")

</div>

yes, we have already installed this as a new instance.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 31, 2022, 5:51am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/6 "2022-10-31T05:51:01Z")

</div>

Is there a reason you are using an EOL version?

---

<div class="post-metadata">

**Author:** ![BJawaid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjawaid/32/112648_2.png) [@BJawaid](https://discuss.elastic.co/u/BJawaid)\
**Post date:** [October 31, 2022, 5:52am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/7 "2022-10-31T05:52:50Z")

</div>

well its the developer's choice.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 31, 2022, 5:57am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/8 "2022-10-31T05:57:17Z")

</div>

You should remind them that Elasticsearch 7.1 was released in early 2019 and has been EOL for quite a while. If you or they run into continuing issues, you are likely going to struggle to get anyone to assist you without upgrading to a more current version.

However I would start by removing Elasticsearch, deleting `/var/lib/elasticsearch` and then try resintalling.

---

<div class="post-metadata">

**Author:** ![BJawaid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjawaid/32/112648_2.png) [@BJawaid](https://discuss.elastic.co/u/BJawaid)\
**Post date:** [October 31, 2022, 6:01am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/10 "2022-10-31T06:01:15Z")

</div>

We have already deleted and reinstalled Elasticsearch number of times

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 31, 2022, 6:14am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/11 "2022-10-31T06:14:05Z")

</div>

Then something else is happening if it's constantly causing these IO errors, have you checked the hardware?

---

<div class="post-metadata">

**Author:** ![BJawaid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjawaid/32/112648_2.png) [@BJawaid](https://discuss.elastic.co/u/BJawaid)\
**Post date:** [October 31, 2022, 6:15am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/12 "2022-10-31T06:15:39Z")

</div>

Its actually a cloud virtual machine and we have reinstalled the OS 3-4 times already.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 31, 2022, 6:17am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/13 "2022-10-31T06:17:21Z")

</div>

What sort of storage is it?

---

<div class="post-metadata">

**Author:** ![BJawaid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjawaid/32/112648_2.png) [@BJawaid](https://discuss.elastic.co/u/BJawaid)\
**Post date:** [October 31, 2022, 6:19am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/14 "2022-10-31T06:19:59Z")

</div>

SSD Storage

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [October 31, 2022, 6:23am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/15 "2022-10-31T06:23:15Z")

</div>

If it is a cloud VM it is probably not local SSDs. Can you provide more details?

You also mentioned having some CentOS servers running just fine. Are they using the same hardware?

---

<div class="post-metadata">

**Author:** ![BJawaid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjawaid/32/112648_2.png) [@BJawaid](https://discuss.elastic.co/u/BJawaid)\
**Post date:** [October 31, 2022, 6:24am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/16 "2022-10-31T06:24:50Z")

</div>

Those CentOS servers are physical servers.

---

<div class="post-metadata">

**Author:** ![BJawaid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjawaid/32/112648_2.png) [@BJawaid](https://discuss.elastic.co/u/BJawaid)\
**Post date:** [October 31, 2022, 6:25am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/17 "2022-10-31T06:25:15Z")

</div>

But I haven't heard anywhere that CloudVM can't run Elasticsearch

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [October 31, 2022, 6:34am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/18 "2022-10-31T06:34:15Z")

</div>

You can run Elasticsearch in the cloud. Most people do. Not every cloud instance might however be suitable, which is why I am asking for details.

I have seen users having problems trying to install and run Elasticsearch on cloud VMs with limits or restrictions in place, which may not always be obvious.

---

<div class="post-metadata">

**Author:** ![BJawaid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjawaid/32/112648_2.png) [@BJawaid](https://discuss.elastic.co/u/BJawaid)\
**Post date:** [October 31, 2022, 6:39am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/19 "2022-10-31T06:39:31Z")

</div>

any process to have that checked out ?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [October 31, 2022, 6:57am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/20 "2022-10-31T06:57:49Z")

</div>

How is the storage mounted? As it is a cloud VM I assume it is networked storage. What type of networked storage is used?

> [@BJawaid](#):
>
> any process to have that checked out ?

No, not that I am aware of. It generally just work for most major cloud providers.

---

<div class="post-metadata">

**Author:** ![BJawaid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bjawaid/32/112648_2.png) [@BJawaid](https://discuss.elastic.co/u/BJawaid)\
**Post date:** [October 31, 2022, 7:00am UTC](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677/21 "2022-10-31T07:00:26Z")

</div>

No idea about that because we are only using a number of VM instances from them and none of them are having any issues with any services but here in this particular scenario we are getting stuck.

[Next page](https://discuss.elastic.co/t/elasticsearch-service-getting-failed-on-ubuntu-20-4/317677.md?page=2)
