# Elasticsearch.service has failed (code=exited, status=143)

**URL:** <https://discuss.elastic.co/t/elasticsearch-service-has-failed-code-exited-status-143/283072>\
**Category:** Elasticsearch\
**Created:** [September 1, 2021, 3:58pm UTC](https://discuss.elastic.co/t/elasticsearch-service-has-failed-code-exited-status-143/283072 "2021-09-01T15:58:28Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![larzu](https://avatars.discourse-cdn.com/v4/letter/l/ba8739/32.png) [@larzu](https://discuss.elastic.co/u/larzu)\
**Post date:** [September 1, 2021, 3:58pm UTC](https://discuss.elastic.co/t/elasticsearch-service-has-failed-code-exited-status-143/283072/1 "2021-09-01T15:58:29Z")

</div>

I'm a "bit" lost with this Elasticsearch installation (for Magento). I was following the installation for Centos [Install Elasticsearch with RPM | Elasticsearch Guide [7.14] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html)

Unfortunately Elasticsearch is not starting. All advices/tips are welcome!

Thanks in advance.

* * *

```auto
systemctl start elasticsearch.service

Sep 01 06:58:49 instance-2 systemd[1]: Starting Elasticsearch...
-- Subject: Unit elasticsearch.service has begun start-up
-- Defined-By: systemd
-- Support: https://access.redhat.com/support
--
-- Unit elasticsearch.service has begun starting up.
Sep 01 06:58:52 instance-2 sshd[3466]: Invalid user user from x.x.x.x port 64078
Sep 01 06:58:52 instance-2 sshd[3466]: Connection closed by invalid user user x.x.x.x port 64078 [preauth]
Sep 01 07:05:10 instance-2 sssd[sssd][735]: Child [2924] ('implicit_files':'%BE_implicit_files') was terminated by own WATCHDOG. Consult corresponding logs to figure out the reason.
Sep 01 07:05:42 instance-2 sssd[sssd][735]: Child [2956] ('nss':'nss') was terminated by own WATCHDOG. Consult corresponding logs to figure out the reason.
Sep 01 07:12:01 instance-2 GCEGuestAgent[1197]: 2021-09-01T07:09:12.2899Z GCEGuestAgent Error main.go:178: Error watching metadata: Get /computeMetadata/v1//?recursive=true&alt=json&wait_for_change=true&timeout_sec=60&last_etag=6c6fdc67ab1e1388: net/http: request canceled while waiting for con>
Sep 01 07:13:44 instance-2 NetworkManager[799]: <info> [1630480422.6843] dhcp4 (eth0): state changed extended -> extended, address=x.x.x.x
Sep 01 07:14:45 instance-2 CROND[3545]: (root) CMD (run-parts /etc/cron.hourly)
Sep 01 07:14:48 instance-2 systemd[1]: elasticsearch.service: start operation timed out. Terminating.
Sep 01 07:16:17 instance-2 dbus-daemon[737]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.8' (uid=0 pid=799 comm="/usr/sbin/NetworkManager --no-daemon " label="system_u:system_r:NetworkManager_t:s0")
Sep 01 07:16:18 instance-2 systemd[1]: Starting Network Manager Script Dispatcher Service...
-- Subject: Unit NetworkManager-dispatcher.service has begun start-up
-- Defined-By: systemd
-- Support: https://access.redhat.com/support
--
-- Unit NetworkManager-dispatcher.service has begun starting up.
Sep 01 07:16:18 instance-2 sshd[3537]: Invalid user user from x.x.x.x port 28449
Sep 01 07:16:18 instance-2 systemd[1]: elasticsearch.service: Failed with result 'timeout'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support: https://access.redhat.com/support
--
-- The unit elasticsearch.service has entered the 'failed' state with result 'timeout'.
Sep 01 07:16:18 instance-2 systemd[1]: Failed to start Elasticsearch.
-- Subject: Unit elasticsearch.service has failed
-- Defined-By: systemd
-- Support: https://access.redhat.com/support
--
-- Unit elasticsearch.service has failed.
--
-- The result is failed.

```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 1, 2021, 10:17pm UTC](https://discuss.elastic.co/t/elasticsearch-service-has-failed-code-exited-status-143/283072/2 "2021-09-01T22:17:09Z")

</div>

Welcome to our community! 😃

Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

It'd be really helpful if you could post your (formatted) log from `/var/log/elasticsearch`.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 29, 2021, 10:17pm UTC](https://discuss.elastic.co/t/elasticsearch-service-has-failed-code-exited-status-143/283072/3 "2021-09-29T22:17:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
