# Elasticsearch.service: main process exited, code=exited, status=1/FAILURE

**URL:** https://discuss.elastic.co/t/elasticsearch-service-main-process-exited-code-exited-status-1-failure/237215
**Category:** Elasticsearch
**Created:** [June 16, 2020, 4:54am UTC](https://discuss.elastic.co/t/elasticsearch-service-main-process-exited-code-exited-status-1-failure/237215 "2020-06-16T04:54:31Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![bhargav7](https://avatars.discourse-cdn.com/v4/letter/b/f08c70/32.png) [@bhargav7](https://discuss.elastic.co/u/bhargav7)
#### Post date: [June 16, 2020, 4:54am UTC](https://discuss.elastic.co/t/elasticsearch-service-main-process-exited-code-exited-status-1-failure/237215/1 "2020-06-16T04:54:31Z")

</div>

Kindly help me to relove the issuse, update ELK from 7.5.2 to 7.7.7 after updating facing below error.  
root@hydelkapp /]# rpm -Uvh --force elasticsearch-7.7.1-x86\_64.rpm

Preparing... ################################# [100%]

Updating / installing...

1:elasticsearch-0:7.7.1-1 ################################# [100%]

could not find java in JAVA\_HOME at /usr/java/jre1.8.0\_241-amd64/bin/java

chown: cannot access ‘/etc/elasticsearch/elasticsearch.keystore’: No such file or directory

chmod: cannot access ‘/etc/elasticsearch/elasticsearch.keystore’: No such file or directory

md5sum: /etc/elasticsearch/elasticsearch.keystore: No such file or directory

warning: %posttrans(elasticsearch-0:7.7.1-1.x86\_64) scriptlet failed, exit status 1

[root@hydelkapp /]# sudo service elasticsearch start

Starting elasticsearch (via systemctl): Warning: elasticsearch.service changed on disk. Run 'systemctl daemon-reload' to reload units.

Job for elasticsearch.service failed because the control process exited with error code. See "systemctl status elasticsearch.service" and "journalctl -xe" for details.

```
                                                       [FAILED]

```

[root@hydelkapp /]# systemctl daemon-reload

[root@hydelkapp /]# sudo service elasticsearch start

Starting elasticsearch (via systemctl): Job for elasticsearch.service failed because the control process exited with error code. See "systemctl status elasticsearch.service" and "journalctl -xe" for details.

```
                                                       [FAILED]

```

[root@hydelkapp /]# systemctl status elasticsearch.service

● elasticsearch.service - Elasticsearch

Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)

Active: failed (Result: exit-code) since Tue 2020-06-16 08:54:42 IST; 9s ago

```
 Docs: http://www.elastic.co

```

Process: 36720 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)

Main PID: 36720 (code=exited, status=1/FAILURE)

Jun 16 08:54:42 hydelkapp elasticsearch[36720]: at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)

Jun 16 08:54:42 hydelkapp elasticsearch[36720]: at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:116)

Jun 16 08:54:42 hydelkapp elasticsearch[36720]: at java.base/sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:219)

Jun 16 08:54:42 hydelkapp elasticsearch[36720]: at java.base/java.nio.file.spi.FileSystemProvider.newOutputStream(FileSystemProvider.java:478)

Jun 16 08:54:42 hydelkapp elasticsearch[36720]: at java.base/java.nio.file.Files.newOutputStream(Files.java:224)

Jun 16 08:54:42 hydelkapp elasticsearch[36720]: at org.apache.lucene.store.FSDirectory$FSIndexOutput.(FSDirectory.java:410)

Jun 16 08:54:42 hydelkapp systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE

Jun 16 08:54:42 hydelkapp systemd[1]: Failed to start Elasticsearch.

Jun 16 08:54:42 hydelkapp systemd[1]: Unit elasticsearch.service entered failed state.

Jun 16 08:54:42 hydelkapp systemd[1]: elasticsearch.service failed.

[root@hydelkapp /]#

[root@hydelkapp /]#

[root@hydelkapp /]#

[r

[root@hydelkapp /]# journalctl -xe

Jun 16 09:00:02 hydelkapp postfix/sendmail[37414]: fatal: parameter inet\_interfaces: no local interface found for ::1

Jun 16 09:00:03 hydelkapp CROND[37404]: (root) MAIL (mailed 2019 bytes of output but got status 0x004b

```
                                    )

```

Jun 16 09:00:03 hydelkapp systemd[1]: Removed slice User Slice of root.

-- Subject: Unit user-0.slice has finished shutting down

-- Defined-By: systemd

-- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

-- Unit user-0.slice has finished shutting down.

Jun 16 09:01:01 hydelkapp systemd[1]: Created slice User Slice of root.

-- Subject: Unit user-0.slice has finished start-up

-- Defined-By: systemd

-- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

-- Unit user-0.slice has finished starting up.

-- The start-up result is done.

Jun 16 09:01:01 hydelkapp systemd[1]: Started Session 255496 of user root.

-- Subject: Unit session-255496.scope has finished start-up

-- Defined-By: systemd

-- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

-- Unit session-255496.scope has finished starting up.

-- The start-up result is done.

Jun 16 09:01:01 hydelkapp CROND[37483]: (root) CMD (run-parts /etc/cron.hourly)

Jun 16 09:01:01 hydelkapp systemd[1]: Started Session 255497 of user root.

-- Subject: Unit session-255497.scope has finished start-up

-- Defined-By: systemd

-- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

-- Unit session-255497.scope has finished starting up.

-- The start-up result is done.

Jun 16 09:01:01 hydelkapp run-parts(/etc/cron.hourly)[37486]: starting 0anacron

Jun 16 09:01:01 hydelkapp CROND[37489]: (root) CMD (/usr/lib64/sa/sa1 1 1)

Jun 16 09:01:01 hydelkapp run-parts(/etc/cron.hourly)[37494]: finished 0anacron

Jun 16 09:01:01 hydelkapp systemd[1]: Removed slice User Slice of root.

-- Subject: Unit user-0.slice has finished shutting down

-- Defined-By: systemd

-- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

-- Unit user-0.slice has finished shutting down.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 14, 2020, 4:54am UTC](https://discuss.elastic.co/t/elasticsearch-service-main-process-exited-code-exited-status-1-failure/237215/2 "2020-07-14T04:54:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
