# Elasticsearch.service: Main process exited, code=killed, status=9/KILL

**URL:** https://discuss.elastic.co/t/elasticsearch-service-main-process-exited-code-killed-status-9-kill/337796
**Category:** Elasticsearch
**Created:** [July 6, 2023, 12:38pm UTC](https://discuss.elastic.co/t/elasticsearch-service-main-process-exited-code-killed-status-9-kill/337796 "2023-07-06T12:38:45Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![bbkunbi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bbkunbi/32/107767_2.png) [@bbkunbi](https://discuss.elastic.co/u/bbkunbi)
#### Post date: [July 6, 2023, 12:38pm UTC](https://discuss.elastic.co/t/elasticsearch-service-main-process-exited-code-killed-status-9-kill/337796/1 "2023-07-06T12:38:45Z")

</div>

Errror: elasticsearch.service: Main process exited, code=killed, status=9/KILL  
ul 06 17:32:05 linux systemd[1]: elasticsearch.service: Main process exited, code=killed, status=9/KILL  
Jul 06 17:32:05 linux systemd[1]: elasticsearch.service: Failed with result 'signal'.  
Jul 06 17:32:05 linux systemd[1]: Failed to start Elasticsearch.

Kibana is showing: {"statusCode":503,"error":"Service Unavailable","message":"License is not available."}

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [July 6, 2023, 1:10pm UTC](https://discuss.elastic.co/t/elasticsearch-service-main-process-exited-code-killed-status-9-kill/337796/2 "2023-07-06T13:10:06Z")

</div>

> [@bbkunbi](#):
>
> Errror: elasticsearch.service: Main process exited, code=killed, status=9/KILL  
> ul 06 17:32:05 linux systemd[1]: elasticsearch.service: Main process exited, code=killed, status=9/KILL  
> Jul 06 17:32:05 linux systemd[1]: elasticsearch.service: Failed with result 'signal'.  
> Jul 06 17:32:05 linux systemd[1]: Failed to start Elasticsearch.

Your elasticsearch is not starting, there is something wrong and you need to check on the system logs, `/var/log/messages` or `/var/log/syslog`.

> [@bbkunbi](#):
>
> Kibana is showing: {"statusCode":503,"error":"Service Unavailable","message":"License is not available."}

This is expected, your Elasticsearch is not running, so Kibana can not talk to it.

---

<div class="post-metadata">

### Author: ![bbkunbi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bbkunbi/32/107767_2.png) [@bbkunbi](https://discuss.elastic.co/u/bbkunbi)
#### Post date: [July 7, 2023, 3:49am UTC](https://discuss.elastic.co/t/elasticsearch-service-main-process-exited-code-killed-status-9-kill/337796/4 "2023-07-07T03:49:27Z")

</div>

`/var/log/syslog` ,, Output of this after starting Elasticsearch

```auto
Jul 7 09:13:58 linux kernel: [326976.921317] Out of memory: Killed process 440665 (java) total-vm:5665488kB, anon-rss:4021776kB, file-rss:0kB, shmem-rss:0kB, UID:130 pgtables:8128kB oom_score_adj:0
Jul 7 09:13:51 linux rtkit-daemon[1777]: Supervising 0 threads of 0 processes of 0 users.
Jul 7 09:14:16 linux /usr/lib/gdm3/gdm-x-session[2841]: (EE) client bug: timer event6 debounce: scheduled expiry is in the past (-2648ms), your system is too slow
Jul 7 09:14:20 linux /usr/lib/gdm3/gdm-x-session[2841]: (EE) client bug: timer event6 debounce: scheduled expiry is in the past (-4558ms), your system is too slow
Jul 7 09:14:20 linux /usr/lib/gdm3/gdm-x-session[2841]: (EE) client bug: timer event6 debounce short: scheduled expiry is in the past (-4571ms), your system is too slow
Jul 7 09:14:22 linux systemd[1]: elasticsearch.service: Main process exited, code=killed, status=9/KILL
Jul 7 09:14:22 linux filebeat[1377]: 2023-07-07T09:14:03.373+0530#011ERROR#011[publisher_pipeline_output]#011pipeline/output.go:154#011Failed to connect to backoff(async(tcp://localhost:5044)): dial tcp 127.0.0.1:5044: connect: connection refused
Jul 7 09:14:24 linux filebeat[1377]: 2023-07-07T09:14:04.028+0530#011INFO#011[publisher]#011pipeline/retry.go:219#011retryer: send unwait signal to consumer
Jul 7 09:14:24 linux filebeat[1377]: 2023-07-07T09:14:04.028+0530#011INFO#011[publisher]#011pipeline/retry.go:223#011 done
Jul 7 09:14:24 linux filebeat[1377]: 2023-07-07T09:14:04.029+0530#011INFO#011[publisher_pipeline_output]#011pipeline/output.go:145#011Attempting to reconnect to backoff(async(tcp://localhost:5044)) with 7124 reconnect attempt(s)
Jul 7 09:14:24 linux filebeat[1377]: 2023-07-07T09:14:06.292+0530#011INFO#011[monitoring]#011log/log.go:184#011Non-zero metrics in the last 30s#011{"monitoring": {"metrics": {"beat":{"cgroup":{"cpuacct":{"total":{"ns":597907710}},"memory":{"mem":{"usage":{"bytes":-376832}}}},"cpu":{"system":{"ticks":241790,"time":{"ms":205}},"total":{"ticks":1056900,"time":{"ms":592},"value":1056900},"user":{"ticks":815110,"time":{"ms":387}}},"handles":{"limit":{"hard":524288,"soft":1024},"open":16},"info":{"ephemeral_id":"a8df84c1-c7a9-4daa-8252-45c8d7dc09bf","uptime":{"ms":326848236},"version":"7.17.6"},"memstats":{"gc_next":62268696,"memory_alloc":31339368,"memory_total":10957639864,"rss":61636608},"runtime":{"goroutines":74}},"filebeat":{"harvester":{"open_files":5,"running":4}},"libbeat":{"config":{"module":{"running":1}},"output":{"events":{"active":0}},"pipeline":{"clients":2,"events":{"active":4118,"retry":2048}}},"registrar":{"states":{"current":4}},"system":{"load":{"1":13.96,"15":4.42,"5":8.63,"norm":{"1":1.1633,"15":0.3683,"5":0.7192}}}}}}
Jul 7 09:14:24 linux systemd[1]: elasticsearch.service: Failed with result 'signal'.
Jul 7 09:14:24 linux CRON[440887]: (bhaveshk) CMD (/home/bhaveshk/Desktop/warning_temp_v1.py >> /home/bhaveshk/Desktop/high_temp_log1.txt 2>errors2.txt)
Jul 7 09:14:24 linux systemd[1]: Failed to start Elasticsearch.

```

---

<div class="post-metadata">

### Author: ![PodarcisMuralis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/podarcismuralis/32/122606_2.png) [@PodarcisMuralis](https://discuss.elastic.co/u/PodarcisMuralis)
#### Post date: [July 7, 2023, 9:23pm UTC](https://discuss.elastic.co/t/elasticsearch-service-main-process-exited-code-killed-status-9-kill/337796/5 "2023-07-07T21:23:04Z")

</div>

I would check the elasticsearch.yml if there is enough resources (CPU, memory etc.) allocated for elasticsearch. Your logs say that you have memory / performance issues.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 4, 2023, 9:23pm UTC](https://discuss.elastic.co/t/elasticsearch-service-main-process-exited-code-killed-status-9-kill/337796/6 "2023-08-04T21:23:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
