# Elasticsearch service not strated

**URL:** <https://discuss.elastic.co/t/elasticsearch-service-not-strated/364699>\
**Category:** Elasticsearch\
**Created:** [August 9, 2024, 4:02pm UTC](https://discuss.elastic.co/t/elasticsearch-service-not-strated/364699 "2024-08-09T16:02:08Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![SAMY-ELK](https://avatars.discourse-cdn.com/v4/letter/s/e9c0ed/32.png) [@SAMY-ELK](https://discuss.elastic.co/u/SAMY-ELK)\
**Post date:** [August 9, 2024, 4:02pm UTC](https://discuss.elastic.co/t/elasticsearch-service-not-strated/364699/1 "2024-08-09T16:02:08Z")

</div>

hello,

i cannot start service elasticsearch after unpatch/uninstall readonlyrest Plugin.  
log Error :

```auto
Aug 09 10:26:57 SRV027 systemd-entrypoint[660337]: Error: Could not find or load main class org.elasticsearch.common.settings.KeyStoreCli
Aug 09 10:26:57 SRV027 systemd-entrypoint[660337]: Caused by: java.lang.NoClassDefFoundError: org/elasticsearch/cli/LoggingAwareMultiCommand
Aug 09 10:26:59 SRV027 systemd-entrypoint[660269]: [0.000s][warning][gc] -Xloggc is deprecated. Will use -Xlog:gc:/var/log/elasticsearch/es-SRV027/gc.log instead.
Aug 09 10:26:59 SRV027 systemd-entrypoint[660269]: [0.001s][warning][gc] -XX:+PrintGCDetails is deprecated. Will use -Xlog:gc* instead.
Aug 09 10:27:00 SRV027 systemd-entrypoint[660269]: Error: Could not find or load main class org.elasticsearch.bootstrap.Elasticsearch
Aug 09 10:27:00 SRV027 systemd-entrypoint[660269]: Caused by: java.lang.ClassNotFoundException: org.elasticsearch.bootstrap.Elasticsearch

```

Thanks in advance for help.  
SAMY

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [August 11, 2024, 5:54pm UTC](https://discuss.elastic.co/t/elasticsearch-service-not-strated/364699/2 "2024-08-11T17:54:27Z")

</div>

Which version of Elasticsearch are you using?

What does your configuration look like?

> [@SAMY-ELK](#):
>
> i cannot start service elasticsearch after unpatch/uninstall readonlyrest Plugin.

Readonlyrest is not supported here so if the error is related to this or an unsuccssful installation/uninstallation you may need to reach out to that community.
