# Elasticsearch - Shard issue

**URL:** <https://discuss.elastic.co/t/elasticsearch-shard-issue/22269>\
**Category:** Elasticsearch\
**Created:** [February 19, 2015, 3:22pm UTC](https://discuss.elastic.co/t/elasticsearch-shard-issue/22269 "2015-02-19T15:22:23Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![lhorsky](https://avatars.discourse-cdn.com/v4/letter/l/c2a13f/32.png) [@lhorsky](https://discuss.elastic.co/u/lhorsky)\
**Post date:** [February 19, 2015, 3:22pm UTC](https://discuss.elastic.co/t/elasticsearch-shard-issue/22269/1 "2015-02-19T15:22:23Z")

</div>

I am a newbie to Elasticsearch, so please be patient as I am troubleshooting  
a system that was not built by me. I have a single server running redis,  
elasticsearch, and logstash. Everything was running great on the system  
until it just started failing. When I look at Kibana, I see 'No index found'  
error message. When I try to look at the node status, it gives me  
"error":"IndexMissingException[[nodename] missing]","status":404

Where do I begin to troubleshoot this issue? When I look at the  
elasticsearch log I see:

org.elasticsearch.indices.InvalidTypeNameException: mapping type name is  
empty

followed by:  
[Failed to start shard, message  
[IndexShardGatewayRecoveryException[[nodename-2015.01.17][4] failed to  
recover shard]; nested: IllegalArgumentException[No type mapped for [0]]

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:31am UTC](https://discuss.elastic.co/t/elasticsearch-shard-issue/22269/2 "2017-07-06T00:31:31Z")

</div>


