# Elasticsearch shutdown after some times

**URL:** https://discuss.elastic.co/t/elasticsearch-shutdown-after-some-times/93912
**Category:** Elasticsearch
**Created:** [July 20, 2017, 10:41am UTC](https://discuss.elastic.co/t/elasticsearch-shutdown-after-some-times/93912 "2017-07-20T10:41:34Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![arafath](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/arafath/32/12784_2.png) [@arafath](https://discuss.elastic.co/u/arafath)
#### Post date: [July 20, 2017, 10:41am UTC](https://discuss.elastic.co/t/elasticsearch-shutdown-after-some-times/93912/1 "2017-07-20T10:41:34Z")

</div>

We have Elasticsearch installed and configured on **Digitalocean**. and ES getting shut down after some times.  
ES log :  
_sudo journalctl --unit elasticsearch --since "2017-07-20"_

> Jul 20 06:19:11 ubuntu-2gb-sgp1-01 systemd[1]: Starting Elasticsearch...  
> Jul 20 06:19:11 ubuntu-2gb-sgp1-01 systemd[1]: Started Elasticsearch.  
> Jul 20 06:19:13 ubuntu-2gb-sgp1-01 elasticsearch[11523]: [2017-07-20T06:19:13,388][WARN][o.e.c.l.LogConfigurator] igJul 20 08:32:50 ubuntu-2gb-sgp1-01 systemd[1]: elasticsearch.service: Main process exited, code=killed, status=9/KILL  
> Jul 20 08:32:50 ubuntu-2gb-sgp1-01 systemd[1]: elasticsearch.service: Unit entered failed state.  
> Jul 20 08:32:50 ubuntu-2gb-sgp1-01 systemd[1]: elasticsearch.service: Failed with result 'signal'.  
> Jul 20 08:36:32 ubuntu-2gb-sgp1-01 systemd[1]: Starting Elasticsearch...  
> Jul 20 08:36:32 ubuntu-2gb-sgp1-01 systemd[1]: Started Elasticsearch.  
> Jul 20 08:36:35 ubuntu-2gb-sgp1-01 elasticsearch[13428]: [2017-07-20T08:36:35,361][WARN][o.e.c.l.LogConfigurator] igJul 20 09:20:57 ubuntu-2gb-sgp1-01 systemd[1]: elasticsearch.service: Main process exited, code=killed, status=9/KILL  
> Jul 20 09:20:57 ubuntu-2gb-sgp1-01 systemd[1]: elasticsearch.service: Unit entered failed state.  
> Jul 20 09:20:57 ubuntu-2gb-sgp1-01 systemd[1]: elasticsearch.service: Failed with result 'signal'.  
> Jul 20 10:16:30 ubuntu-2gb-sgp1-01 systemd[1]: Starting Elasticsearch...  
> Jul 20 10:16:30 ubuntu-2gb-sgp1-01 systemd[1]: Started Elasticsearch.  
> Jul 20 10:16:33 ubuntu-2gb-sgp1-01 elasticsearch[14343]: [2017-07-20T10:16:33,093][WARN][o.e.c.l.LogConfigurator] iglines 89-117/117 (END)

Server Details:  
UBUNTU 16.04  
20GB SSD  
2GB RAM

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [July 28, 2017, 8:35am UTC](https://discuss.elastic.co/t/elasticsearch-shutdown-after-some-times/93912/2 "2017-07-28T08:35:32Z")

</div>

```auto
Jul 20 08:36:35 ubuntu-2gb-sgp1-01 elasticsearch[13428]: [2017-07-20T08:36:35,361][WARN][o.e.c.l.LogConfigurator] igJul 20 09:20:57 ubuntu-2gb-sgp1-01 systemd[1]: elasticsearch.service: Main process exited, code=killed, status=9/KILL

```

Seems to indicate that "something" is killing your process. May be you have something like an OOM Killer?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 25, 2017, 8:35am UTC](https://discuss.elastic.co/t/elasticsearch-shutdown-after-some-times/93912/3 "2017-08-25T08:35:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
