# Elasticsearch Snapshot

**URL:** <https://discuss.elastic.co/t/elasticsearch-snapshot/133630>\
**Category:** Elasticsearch\
**Created:** [May 29, 2018, 7:05am UTC](https://discuss.elastic.co/t/elasticsearch-snapshot/133630 "2018-05-29T07:05:56Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mozuffer](https://avatars.discourse-cdn.com/v4/letter/m/c57346/32.png) [@Mozuffer](https://discuss.elastic.co/u/Mozuffer)\
**Post date:** [May 29, 2018, 7:05am UTC](https://discuss.elastic.co/t/elasticsearch-snapshot/133630/1 "2018-05-29T07:05:56Z")

</div>

Hi Guys, I'm using elasticsearch Version "1.4.5" and "lucene\_version" : "4.10.4" on elasticsearch cluster consist of 4 nodes. I want to take anapshot from this cluster, I have configured NFS server and made it available to all nodes, but when I take snapshot I'm recieving the following error and snpashot not completed successfully.  
Note: the cluster status is green, sometimes I'm getting shard not found from kibana dashboard. any ideas to get rid of this error and make complete successfull snapshot  
[2018-05-24 12:47:02,680][WARN][snapshots] [MAS-GSDB02-DR] [[logstash-2017.01.17][3]] [smartpass\_es\_repo:prod\_masdar\_logstash-2017.01.17\_2018-05-24] failed to create snapshot  
org.elasticsearch.index.snapshots.IndexShardSnapshotFailedException: [logstash-2017.01.17][3] Failed to perform snapshot (index files)  
at org.elasticsearch.index.snapshots.blobstore.BlobStoreIndexShardRepository$SnapshotContext.snapshot(BlobStoreIndexShardRepository.java:503)  
at org.elasticsearch.index.snapshots.blobstore.BlobStoreIndexShardRepository.snapshot(BlobStoreIndexShardRepository.java:139)  
at org.elasticsearch.index.snapshots.IndexShardSnapshotAndRestoreService.snapshot(IndexShardSnapshotAndRestoreService.java:86)  
at org.elasticsearch.snapshots.SnapshotsService$5.run(SnapshotsService.java:817)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)  
at java.lang.Thread.run(Unknown Source)  
Caused by: java.io.FileNotFoundException: /elasticsearch\_snapshot/indices/logstash-2017.01.17/3/\_\_0 (No such file or directory)  
at java.io.FileOutputStream.open0(Native Method)  
at java.io.FileOutputStream.open(Unknown Source)  
at java.io.FileOutputStream.(Unknown Source)  
at java.io.FileOutputStream.(Unknown Source)  
at org.elasticsearch.common.blobstore.fs.FsBlobContainer.createOutput(FsBlobContainer.java:85)  
at org.elasticsearch.index.snapshots.blobstore.BlobStoreIndexShardRepository$SnapshotContext.snapshotFile(BlobStoreIndexShardRepository.java:555)  
at org.elasticsearch.index.snapshots.blobstore.BlobStoreIndexShardRepository$SnapshotContext.snapshot(BlobStoreIndexShardRepository.java:501)  
... 6 more

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [May 29, 2018, 7:21am UTC](https://discuss.elastic.co/t/elasticsearch-snapshot/133630/2 "2018-05-29T07:21:01Z")

</div>

I doubt you will get help as this version is a way tooooooo old. At the very least you should use the latest 1.7 version available which "might" fix the problem.

But definitely you should upgrade to 6.2...

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [May 29, 2018, 7:32am UTC](https://discuss.elastic.co/t/elasticsearch-snapshot/133630/3 "2018-05-29T07:32:55Z")

</div>

Given the index names that are reported, it looks like you might potentially have a large number of indices/shards, which might slow down or cause problems with snapshot creation.

---

<div class="post-metadata">

**Author:** ![Mozuffer](https://avatars.discourse-cdn.com/v4/letter/m/c57346/32.png) [@Mozuffer](https://discuss.elastic.co/u/Mozuffer)\
**Post date:** [May 29, 2018, 8:40am UTC](https://discuss.elastic.co/t/elasticsearch-snapshot/133630/4 "2018-05-29T08:40:29Z")

</div>

but how some shards are missing while the cluster is green ?

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [May 29, 2018, 1:29pm UTC](https://discuss.elastic.co/t/elasticsearch-snapshot/133630/5 "2018-05-29T13:29:35Z")

</div>

I don’t know, and it does not help that you are using such an old version.

---

<div class="post-metadata">

**Author:** ![Mozuffer](https://avatars.discourse-cdn.com/v4/letter/m/c57346/32.png) [@Mozuffer](https://discuss.elastic.co/u/Mozuffer)\
**Post date:** [May 31, 2018, 6:45am UTC](https://discuss.elastic.co/t/elasticsearch-snapshot/133630/6 "2018-05-31T06:45:57Z")

</div>

Any Ideas to get rid of this error?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 28, 2018, 6:46am UTC](https://discuss.elastic.co/t/elasticsearch-snapshot/133630/7 "2018-06-28T06:46:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
