# Elasticsearch start

**URL:** https://discuss.elastic.co/t/elasticsearch-start/76594
**Category:** Elasticsearch
**Created:** [February 27, 2017, 9:19am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594 "2017-02-27T09:19:04Z")
**Posts on this page:** 15
**Page:** 1

<div class="post-metadata">

### Author: ![Tigryss](https://avatars.discourse-cdn.com/v4/letter/t/c0e974/32.png) [@Tigryss](https://discuss.elastic.co/u/Tigryss)
#### Post date: [February 27, 2017, 9:19am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/1 "2017-02-27T09:19:04Z")

</div>

Hi I'm current on upgrade my elk from 2.3.4 to 5.1.2 and I have a troble with ES start.

I tried start it as daemon (init file) start as root but run as function USER, and i tried also as the user and no daemon, just a java call, but I get the same error msg. Can someone help me please?

```
[root@hostname]# daemon --user=username --pidfile=/var/run/elasticsearch.pid '/usr/lib/jvm/jre/bin/java -Duser.name=username -Djava.awt.headless=true -XX:+HeapDumpOnOutOfMemoryError 
-XX:+DisableExplicitGC -Dfile.encoding=UTF-8 -Djna.nosys=true -Djava.awt.headless=true -Des.path.home=/opt/elasticsearch -Des.path.logs=/opt/elasticsearch/logs -Des.path.data=/opt/elasticsearch
-Des.path.work=/opt/elasticsearch/tmp -cp /opt/elasticsearch/lib/elasticsearch-5.1.2.jar:/opt/elasticsearch/lib/* org.elasticsearch.bootstrap.Elasticsearch start \"\$@\" <&- & >/dev/null 2>&1'

[root@hostname]# 2017-02-24 07:50:52,424 main ERROR Could not register mbeans java.security.AccessControlException: access denied ("javax.management.MBeanTrustPermission" "register")
        at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)
        at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrustPermission(DefaultMBeanServerInterceptor.java:1848)
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:322)
        at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.java:522)
        at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)
        at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:167)
        at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:140)
        at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:541)
        at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:258)
        at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:206)
        at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:220)
        at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:197)
        at org.elasticsearch.common.logging.LogConfigurator.configureStatusLogger(LogConfigurator.java:125)
        at org.elasticsearch.common.logging.LogConfigurator.configureWithoutConfig(LogConfigurator.java:67)
        at org.elasticsearch.cli.Command.main(Command.java:85)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)

starts elasticsearch

Option Description
------ -----------
-E <KeyValuePair> Configure a setting
-V, --version Prints elasticsearch version information and exits
-d, --daemonize Starts Elasticsearch in the background
-h, --help show help
-p, --pidfile <Path> Creates a pid file in the specified path on start
-q, --quiet Turns off standard ouput/error streams logging in console
-s, --silent show minimal output
-v, --verbose show verbose output
ERROR: Positional arguments not allowed, found [start, "$@"]
```

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [February 27, 2017, 10:11am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/2 "2017-02-27T10:11:27Z")

</div>

Hey,

can you start `/opt/elasticsearch/bin/elasticsearch` as the user you want to run at, just to test if that works?

This looks as if you got two error messages in there... I am confused about that...

--Alex

---

<div class="post-metadata">

### Author: ![Tigryss](https://avatars.discourse-cdn.com/v4/letter/t/c0e974/32.png) [@Tigryss](https://discuss.elastic.co/u/Tigryss)
#### Post date: [February 27, 2017, 10:29am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/3 "2017-02-27T10:29:31Z")

</div>

> [@spinscale](#):
>
> /opt/elasticsearch/bin/elasticsearch

Same issue

```
-bash-4.1$ /opt/elasticsearch/bin/elasticsearch start
2017-02-27 11:28:01,748 main ERROR Could not register mbeans java.security.AccessControlException: access denied ("javax.management.MBeanTrustPermission" "register")
        at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)
        at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrustPermission(DefaultMBeanServerInterceptor.java:1848)
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:322)
        at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.java:522)
        at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)
        at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:167)
        at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:140)
        at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:541)
        at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:258)
        at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:206)
        at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:220)
        at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:197)
        at org.elasticsearch.common.logging.LogConfigurator.configureStatusLogger(LogConfigurator.java:125)
        at org.elasticsearch.common.logging.LogConfigurator.configureWithoutConfig(LogConfigurator.java:67)
        at org.elasticsearch.cli.Command.main(Command.java:85)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)

starts elasticsearch

Option Description
------ -----------
-E <KeyValuePair> Configure a setting
-V, --version Prints elasticsearch version information and exits
-d, --daemonize Starts Elasticsearch in the background
-h, --help show help
-p, --pidfile <Path> Creates a pid file in the specified path on start
-q, --quiet Turns off standard ouput/error streams logging in console
-s, --silent show minimal output
-v, --verbose show verbose output
ERROR: Positional arguments not allowed, found [start]

```

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [February 27, 2017, 10:47am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/4 "2017-02-27T10:47:19Z")

</div>

Hey,

is this a stock Elasticsearch 5.1.2 distribution? You just took the zip file and unzipped it? Did you do anything special when installing elasticsearch?

One more thing: Can you try to install a java JDK instead of an JRE (at least the path you showed in your in the first post, seems to indicate it is a jre).

--Alex

---

<div class="post-metadata">

### Author: ![Tigryss](https://avatars.discourse-cdn.com/v4/letter/t/c0e974/32.png) [@Tigryss](https://discuss.elastic.co/u/Tigryss)
#### Post date: [February 27, 2017, 10:58am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/5 "2017-02-27T10:58:01Z")

</div>

Hi Alex,

I took the zip and removed a .bat .dll (files which not linux relavant) and put in the /opt I customized the jvm.option elasticsearch.yml and go

this is my java pkg  
java-1.8.0-openjdk-headless  
java-1.8.0-openjdk

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [February 27, 2017, 2:47pm UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/6 "2017-02-27T14:47:02Z")

</div>

Hey,

why did you run `bin/elasticsearch start` - can you run without the `start`?

--Alex

---

<div class="post-metadata">

### Author: ![Tigryss](https://avatars.discourse-cdn.com/v4/letter/t/c0e974/32.png) [@Tigryss](https://discuss.elastic.co/u/Tigryss)
#### Post date: [February 28, 2017, 4:55am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/7 "2017-02-28T04:55:43Z")

</div>

Hi Alex,

now without start

```
-bash-4.1$ /opt/elasticsearch/bin/elasticsearch
2017-02-28 05:50:48,189 main ERROR Could not register mbeans java.security.AccessControlException: access denied ("javax.management.MBeanTrustPermission" "register")
        at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)
        at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrustPermission(DefaultMBeanServerInterceptor.java:1848)
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:322)
        at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.java:522)
        at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)
        at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:167)
        at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:140)
        at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:541)
        at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:258)
        at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:206)
        at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:220)
        at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:197)
        at org.elasticsearch.common.logging.LogConfigurator.configureStatusLogger(LogConfigurator.java:125)
        at org.elasticsearch.common.logging.LogConfigurator.configureWithoutConfig(LogConfigurator.java:67)
        at org.elasticsearch.cli.Command.main(Command.java:85)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)

2017-02-28 05:50:48,885 main ERROR Could not register mbeans java.security.AccessControlException: access denied ("javax.management.MBeanTrustPermission" "register")
        at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)
        at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrustPermission(DefaultMBeanServerInterceptor.java:1848)
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:322)
        at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.java:522)
        at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)
        at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:167)
        at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:140)
        at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:541)
        at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:258)
        at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:116)
        at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:83)
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:272)
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121)
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112)
        at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54)
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)
        at org.elasticsearch.cli.Command.main(Command.java:88)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)

2017-02-28 05:50:50,750 Thread-4 ERROR Unable to unregister MBeans java.security.AccessControlException: access denied ("javax.management.MBeanServerPermission" "createMBeanServer")
        at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)
        at java.security.AccessController.checkPermission(AccessController.java:884)
        at java.lang.SecurityManager.checkPermission(SecurityManager.java:549)
        at java.lang.management.ManagementFactory.getPlatformMBeanServer(ManagementFactory.java:465)
        at org.apache.logging.log4j.core.jmx.Server.unregisterLoggerContext(Server.java:246)
        at org.apache.logging.log4j.core.LoggerContext.stop(LoggerContext.java:317)
        at org.apache.logging.log4j.core.AbstractLifeCycle.stop(AbstractLifeCycle.java:127)
        at org.apache.logging.log4j.core.config.Configurator.shutdown(Configurator.java:344)
        at org.elasticsearch.bootstrap.Bootstrap$5.run(Bootstrap.java:192)
```

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [February 28, 2017, 7:25am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/8 "2017-02-28T07:25:06Z")

</div>

Hey,

you might want to check

- [https://github.com/elastic/elasticsearch/issues/21932](https://github.com/elastic/elasticsearch/issues/21932)
- [https://github.com/elastic/elasticsearch/issues/22228](https://github.com/elastic/elasticsearch/issues/22228)
- [Elasticsearch 5.1.1 cannot run as root user](https://discuss.elastic.co/t/elasticsearch-5-1-1-cannot-run-as-root-user/70304/8)

--Alex

---

<div class="post-metadata">

### Author: ![Tigryss](https://avatars.discourse-cdn.com/v4/letter/t/c0e974/32.png) [@Tigryss](https://discuss.elastic.co/u/Tigryss)
#### Post date: [February 28, 2017, 7:45am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/9 "2017-02-28T07:45:23Z")

</div>

Hi Alex,

read the topics

```
-bash-4.1$ chown user:group -R /opt/elasticsearch

jmx was already inactiv
-bash-4.1$ grep jmx *
jvm.options:#-Dlog4j2.disable.jmx=true
logging.yml: #com.amazonaws.jmx.SdkMBeanRegistrySupport: ERROR

start with path parameter
-bash-4.1$ /opt/elasticsearch/bin/elasticsearch -Epath.conf=/opt/elasticsearch/config/

```

same Error

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [February 28, 2017, 7:47am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/10 "2017-02-28T07:47:24Z")

</div>

hey

can you put the **full** start up log into a gist/pastebin?

--Alex

---

<div class="post-metadata">

### Author: ![Tigryss](https://avatars.discourse-cdn.com/v4/letter/t/c0e974/32.png) [@Tigryss](https://discuss.elastic.co/u/Tigryss)
#### Post date: [February 28, 2017, 7:56am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/11 "2017-02-28T07:56:51Z")

</div>

Hi Alex

sure

[https://paste.ofcode.org/jwbXgT6vZyH52hzVKuf8k](https://paste.ofcode.org/jwbXgT6vZyH52hzVKuf8k)

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [February 28, 2017, 8:10am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/12 "2017-02-28T08:10:08Z")

</div>

Hey,

first, the JXM line is **commented out**. It is not applied. This means, you very likely have modified the file?

second, the error why Elasticsearch does not start is not about the JXM error. You omitted the other issue in this post, which states that you cannot configure the number of shards and number of replicas in your elasticsearch configuration. When I asked if you took the standard distribution I was also assuming you did not have your own configuration files. Apparently the whole config directory is very custom, so we just misunderstood each other there.

--Alex

---

<div class="post-metadata">

### Author: ![Tigryss](https://avatars.discourse-cdn.com/v4/letter/t/c0e974/32.png) [@Tigryss](https://discuss.elastic.co/u/Tigryss)
#### Post date: [February 28, 2017, 8:20am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/13 "2017-02-28T08:20:27Z")

</div>

Hi Alex

i can say that the config is the standard config from 2.3.4, and I try to modify so that is working with our deployment process and with 5.x. My problem is only the permission denied because the other errors are "only" WARN-s and I know how can I change the configuration.  
Sould I increase the loglevel?

Mit Freundlichen Grüßen  
Krisz

---

<div class="post-metadata">

### Author: ![Tigryss](https://avatars.discourse-cdn.com/v4/letter/t/c0e974/32.png) [@Tigryss](https://discuss.elastic.co/u/Tigryss)
#### Post date: [March 1, 2017, 6:21am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/14 "2017-03-01T06:21:23Z")

</div>

Hi Alex,

i changed the config now and the ES starting I but the errors still there..

```
-bash-4.1$ /opt/elasticsearch/bin/elasticsearch &
[1] 9219
-bash-4.1$ 2017-03-01 07:13:05,661 main ERROR Could not register mbeans java.security.AccessControlException: access denied ("javax.management.MBeanTrustPermission" "register")
        at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)
        at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrustPermission(DefaultMBeanServerInterceptor.java:1848)
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:322)
        at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.java:522)
        at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)
        at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:167)
        at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:140)
        at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:541)
        at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:258)
        at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:206)
        at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:220)
        at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:197)
        at org.elasticsearch.common.logging.LogConfigurator.configureStatusLogger(LogConfigurator.java:125)
        at org.elasticsearch.common.logging.LogConfigurator.configureWithoutConfig(LogConfigurator.java:67)
        at org.elasticsearch.cli.Command.main(Command.java:85)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)

2017-03-01 07:13:05,924 main ERROR Could not register mbeans java.security.AccessControlException: access denied ("javax.management.MBeanTrustPermission" "register")
        at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)
        at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrustPermission(DefaultMBeanServerInterceptor.java:1848)
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:322)
        at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.java:522)
        at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)
        at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:167)
        at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:140)
        at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:541)
        at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:258)
        at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:116)
        at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:83)
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:272)
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121)
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112)
        at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54)
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)
        at org.elasticsearch.cli.Command.main(Command.java:88)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)

[2017-03-01T07:13:05,927][WARN][o.e.c.l.LogConfigurator] ignoring unsupported logging configuration file [/opt/elasticsearch/config/logging.yml], logging is configured via [/opt/elasticsearch/config/log4j2.properties]
[2017-03-01T07:13:05,969][WARN][o.e.b.JNANatives] unable to install syscall filter:
java.lang.UnsupportedOperationException: seccomp unavailable: CONFIG_SECCOMP not compiled into kernel, CONFIG_SECCOMP and CONFIG_SECCOMP_FILTER are needed
        at org.elasticsearch.bootstrap.Seccomp.linuxImpl(Seccomp.java:361) ~[elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.bootstrap.Seccomp.init(Seccomp.java:630) ~[elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.bootstrap.JNANatives.trySeccomp(JNANatives.java:215) [elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.bootstrap.Natives.trySeccomp(Natives.java:99) [elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:105) [elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:176) [elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:306) [elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) [elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) [elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) [elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) [elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.cli.Command.main(Command.java:88) [elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89) [elasticsearch-5.1.2.jar:5.1.2]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82) [elasticsearch-5.1.2.jar:5.1.2]
```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 29, 2017, 6:22am UTC](https://discuss.elastic.co/t/elasticsearch-start/76594/15 "2017-03-29T06:22:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
