# Elasticsearch starts and stops automatically if i change network host

**URL:** <https://discuss.elastic.co/t/elasticsearch-starts-and-stops-automatically-if-i-change-network-host/198025>\
**Category:** Elasticsearch\
**Created:** [September 4, 2019, 9:59am UTC](https://discuss.elastic.co/t/elasticsearch-starts-and-stops-automatically-if-i-change-network-host/198025 "2019-09-04T09:59:33Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![katara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/katara/32/60143_2.png) [@katara](https://discuss.elastic.co/u/katara)\
**Post date:** [September 4, 2019, 9:59am UTC](https://discuss.elastic.co/t/elasticsearch-starts-and-stops-automatically-if-i-change-network-host/198025/1 "2019-09-04T09:59:33Z")

</div>

In my elasticsearch yml (version 7.1.0), when i change my network host to the IP or simply 0.0.0.0,  
once i restart the service, the service runs for a few seconds and stops automatically.  
Please help me with this.

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [September 4, 2019, 10:16am UTC](https://discuss.elastic.co/t/elasticsearch-starts-and-stops-automatically-if-i-change-network-host/198025/2 "2019-09-04T10:16:22Z")

</div>

Elasticsearch will log the reason why it is shutting down, so you should look at its logs to find this out. If you need help understanding the logs, please share them here.

---

<div class="post-metadata">

**Author:** ![katara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/katara/32/60143_2.png) [@katara](https://discuss.elastic.co/u/katara)\
**Post date:** [September 4, 2019, 11:17am UTC](https://discuss.elastic.co/t/elasticsearch-starts-and-stops-automatically-if-i-change-network-host/198025/3 "2019-09-04T11:17:50Z")

</div>

@DavidTurner,  
Please find the error that I found in my Logs below.

```
[2019-09-04T02:55:06,871][ERROR][o.e.b.Bootstrap] [SOLARWIND-SRV] Exception
org.elasticsearch.ElasticsearchException: Failed to create native process factories for Machine Learning
	at org.elasticsearch.xpack.ml.MachineLearning.createComponents(MachineLearning.java:433) ~[?:?]
	at org.elasticsearch.node.Node.lambda$new$9(Node.java:440) ~[elasticsearch-7.1.0.jar:7.1.0]
	at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:267) ~[?:1.8.0_221]
	at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1382) ~[?:1.8.0_221]
	at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:482) ~[?:1.8.0_221]
	at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:472) ~[?:1.8.0_221]
	at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:708) ~[?:1.8.0_221]
	at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:1.8.0_221]
	at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:499) ~[?:1.8.0_221]
	at org.elasticsearch.node.Node.<init>(Node.java:443) ~[elasticsearch-7.1.0.jar:7.1.0]
	at org.elasticsearch.node.Node.<init>(Node.java:252) ~[elasticsearch-7.1.0.jar:7.1.0]
	at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:211) ~[elasticsearch-7.1.0.jar:7.1.0]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:211) ~[elasticsearch-7.1.0.jar:7.1.0]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:325) [elasticsearch-7.1.0.jar:7.1.0]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) [elasticsearch-7.1.0.jar:7.1.0]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:150) [elasticsearch-7.1.0.jar:7.1.0]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-7.1.0.jar:7.1.0]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-7.1.0.jar:7.1.0]
	at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-7.1.0.jar:7.1.0]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) [elasticsearch-7.1.0.jar:7.1.0]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-7.1.0.jar:7.1.0]
Caused by: java.io.FileNotFoundException: \\.\pipe\controller_log_19556 (The system cannot find the file specified)
	at java.io.FileInputStream.open0(Native Method) ~[?:1.8.0_221]
	at java.io.FileInputStream.open(FileInputStream.java:195) ~[?:1.8.0_221]
	at java.io.FileInputStream.<init>(FileInputStream.java:138) ~[?:1.8.0_221]
	at java.io.FileInputStream.<init>(FileInputStream.java:93) ~[?:1.8.0_221]
	at org.elasticsearch.xpack.ml.utils.NamedPipeHelper$PrivilegedInputPipeOpener.run(NamedPipeHelper.java:288) ~[?:?]
	at org.elasticsearch.xpack.ml.utils.NamedPipeHelper$PrivilegedInputPipeOpener.run(NamedPipeHelper.java:277) ~[?:?]
	at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_221]
	at org.elasticsearch.xpack.ml.utils.NamedPipeHelper.openNamedPipeInputStream(NamedPipeHelper.java:130) ~[?:?]
	at org.elasticsearch.xpack.ml.utils.NamedPipeHelper.openNamedPipeInputStream(NamedPipeHelper.java:97) ~[?:?]
	at org.elasticsearch.xpack.ml.process.ProcessPipes.connectStreams(ProcessPipes.java:131) ~[?:?]
	at org.elasticsearch.xpack.ml.process.NativeController.<init>(NativeController.java:61) ~[?:?]
	at org.elasticsearch.xpack.ml.process.NativeControllerHolder.getNativeController(NativeControllerHolder.java:40) ~[?:?]
	at org.elasticsearch.xpack.ml.MachineLearning.createComponents(MachineLearning.java:418) ~[?:?]
	... 20 more
```

---

<div class="post-metadata">

**Author:** ![katara](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/katara/32/60143_2.png) [@katara](https://discuss.elastic.co/u/katara)\
**Post date:** [September 9, 2019, 6:29am UTC](https://discuss.elastic.co/t/elasticsearch-starts-and-stops-automatically-if-i-change-network-host/198025/4 "2019-09-09T06:29:17Z")

</div>

@DavidTurner, Please help me through this issue.

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [September 9, 2019, 6:38am UTC](https://discuss.elastic.co/t/elasticsearch-starts-and-stops-automatically-if-i-change-network-host/198025/5 "2019-09-09T06:38:06Z")

</div>

This looks like the same error message as in this post, which contains a solution:

> [@Elasticsearch 7.0.1 throws error in ML in bootstrap ( Windows 2012 Server)](https://discuss.elastic.co/t/elasticsearch-7-0-1-throws-error-in-ml-in-bootstrap-windows-2012-server/181667/1):
>
> I have installed ES 7.0.1 on Windows 2012 Server. And i get following error in the logs when trying to start the ES Service. If i disable the "ml pack" via configuration it works, but i want to use ml pack. [2019-05-17T17:15:27,975][INFO][o.e.p.PluginsService] [telemetry1] loaded module [x-pack-watcher] [2019-05-17T17:15:27,975][INFO][o.e.p.PluginsService] [telemetry1] no plugins loaded [2019-05-17T17:16:27,099][ERROR][o.e.b.Bootstrap] [telemetry1] Exception org.elasti…

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 7, 2019, 6:38am UTC](https://discuss.elastic.co/t/elasticsearch-starts-and-stops-automatically-if-i-change-network-host/198025/6 "2019-10-07T06:38:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
