# Elasticsearch Status Active Failed

**URL:** <https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143>\
**Category:** Elasticsearch\
**Created:** [September 11, 2017, 11:37pm UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143 "2017-09-11T23:37:11Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![yrizal](https://avatars.discourse-cdn.com/v4/letter/y/b2d939/32.png) [@yrizal](https://discuss.elastic.co/u/yrizal)\
**Post date:** [September 11, 2017, 11:37pm UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/1 "2017-09-11T23:37:11Z")

</div>

**Hello,**  
**OS = centos7, install in vm**  
**java version**

==========================================================================

openjdk version "1.8.0\_102"  
OpenJDK Runtime Environment (build 1.8.0\_102-b14)  
OpenJDK 64-Bit Server VM (build 25.102-b14, mixed mode)

==========================================================================

**the first time when install elasticsearch is successful, and its status running (curl -X GET '[http://localhost:9200](http://localhost:9200)'). I follow the [https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html) (Installing from the RPM repository)**

==========================================================================

● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: active (running) since Mon 2017-09-11 18:02:52 EDT; 11min ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 1119 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 1130 (java)  
CGroup: /system.slice/elasticsearch.service  
└─1130 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInit...

Sep 11 18:02:52 192.168.1.9 systemd[1]: Starting Elasticsearch...  
Sep 11 18:02:52 192.168.1.9 systemd[1]: Started Elasticsearch.

[root@192 cenelk]# curl -X GET '[http://localhost:9200](http://localhost:9200)' {  
"name" : "bCTNIfd",  
"cluster\_name" : "elasticsearch",  
"cluster\_uuid" : "eeS1QsUmQC69-vMZ8ZFftQ",  
"version" : {  
"number" : "5.6.0",  
"build\_hash" : "781a835",  
"build\_date" : "2017-09-07T03:09:58.087Z",  
"build\_snapshot" : false,  
"lucene\_version" : "6.6.0"  
},  
"tagline" : "You Know, for Search"  
}

==============================================================================

**keep install kibana also successful and running status, after install logstash and logstash status running, but elasticsearch status failed, is there any problem. can u help me??**

==============================================================================  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Mon 2017-09-11 19:16:20 EDT; 11min ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 6121 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
Process: 6117 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 6121 (code=exited, status=1/FAILURE)

Sep 11 19:16:18 192.168.1.9 systemd[1]: Started Elasticsearch.  
Sep 11 19:16:19 192.168.1.9 elasticsearch[6121]: OpenJDK 64-Bit Server VM warning: INFO: os::com...12)  
Sep 11 19:16:19 192.168.1.9 elasticsearch[6121]: #  
Sep 11 19:16:19 192.168.1.9 elasticsearch[6121]: # There is insufficient memory for the Java Run...ue.  
Sep 11 19:16:19 192.168.1.9 elasticsearch[6121]: # Native memory allocation (mmap) failed to map...ry.  
Sep 11 19:16:19 192.168.1.9 elasticsearch[6121]: # An error report file with more information is...as:  
Sep 11 19:16:19 192.168.1.9 elasticsearch[6121]: # /tmp/hs\_err\_pid6121.log  
Sep 11 19:16:20 192.168.1.9 systemd[1]: elasticsearch.service: main process exited, code=exited...LURE  
Sep 11 19:16:20 192.168.1.9 systemd[1]: Unit elasticsearch.service entered failed state.  
Sep 11 19:16:20 192.168.1.9 systemd[1]: elasticsearch.service failed.  
Hint: Some lines were ellipsized, use -l to show in full.

======================================================================

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 12, 2017, 12:41am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/2 "2017-09-12T00:41:29Z")

</div>

> [@yrizal](#):
>
> There is insufficient memory for the Java Run

That's probably why.  
How much memory does your host have, how much did you give Elasticsearch?

---

<div class="post-metadata">

**Author:** ![yrizal](https://avatars.discourse-cdn.com/v4/letter/y/b2d939/32.png) [@yrizal](https://discuss.elastic.co/u/yrizal)\
**Post date:** [September 12, 2017, 1:46am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/3 "2017-09-12T01:46:14Z")

</div>

Maybe his memory is unlimited.  
and i have 1 vm again but still its status active failed

● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: signal) since Mon 2017-09-11 14:36:42 WIB; 18h ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 8869 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR} (code=killed, signal=KILL)  
Process: 8865 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 8869 (code=killed, signal=KILL)

Sep 11 14:24:40 localhost.localdomain systemd[1]: Starting Elasticsearch...  
Sep 11 14:24:40 localhost.localdomain systemd[1]: Started Elasticsearch.  
Sep 11 14:36:42 localhost.localdomain systemd[1]: elasticsearch.service: main process exited, code=killed, status=9/KILL  
Sep 11 14:36:42 localhost.localdomain systemd[1]: Unit elasticsearch.service entered failed state.  
Sep 11 14:36:42 localhost.localdomain systemd[1]: elasticsearch.service failed.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 12, 2017, 1:50am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/4 "2017-09-12T01:50:53Z")

</div>

Look at the actual Elasticsearch logs, they should tell you more.

---

<div class="post-metadata">

**Author:** ![yrizal](https://avatars.discourse-cdn.com/v4/letter/y/b2d939/32.png) [@yrizal](https://discuss.elastic.co/u/yrizal)\
**Post date:** [September 12, 2017, 6:10am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/5 "2017-09-12T06:10:44Z")

</div>

is this the log, /etc/var/log/elasticsearch/elasticsearch.log

[2017-09-11T09:33:52,646][WARN][o.e.m.j.JvmGcMonitorService] [qs5K1Ku] [gc][young][335528][2079] duration [20.3s], collections [1]/[3.7s], total [20.3s$  
[2017-09-11T09:35:45,970][WARN][o.e.m.j.JvmGcMonitorService] [qs5K1Ku] [gc][335528] overhead, spent [20.3s] collecting in the last [3.7s]  
[2017-09-11T14:26:54,605][INFO][o.e.n.Node] [] initializing ...  
[2017-09-11T14:26:56,242][INFO][o.e.e.NodeEnvironment] [qs5K1Ku] using [1] data paths, mounts [[/ (rootfs)]], net usable\_space [16.6gb], net total\_$  
[2017-09-11T14:26:56,242][INFO][o.e.e.NodeEnvironment] [qs5K1Ku] heap size [1.9gb], compressed ordinary object pointers [true]  
[2017-09-11T14:26:56,393][INFO][o.e.n.Node] node name [qs5K1Ku] derived from node ID [qs5K1Ku0S8ic\_FQOuqI-YQ]; set [[node.name](http://node.name)] to overri$  
[2017-09-11T14:26:56,393][INFO][o.e.n.Node] version[5.5.2], pid[8869], build[b2f0c09/2017-08-14T12:33:14.154Z], OS[Linux/3.10.0-514.el7.$  
[2017-09-11T14:26:56,393][INFO][o.e.n.Node] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=7$  
[2017-09-11T14:27:07,974][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [aggs-matrix-stats]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [ingest-common]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [lang-expression]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [lang-groovy]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [lang-mustache]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [lang-painless]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [parent-join]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [percolator]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [reindex]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [transport-netty3]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [transport-netty4]  
[2017-09-11T14:27:07,976][INFO][o.e.p.PluginsService] [qs5K1Ku] no plugins loaded  
[2017-09-11T14:27:23,757][INFO][o.e.d.DiscoveryModule] [qs5K1Ku] using discovery type [zen]  
[2017-09-11T14:27:30,731][INFO][o.e.n.Node] initialized  
[2017-09-11T14:27:30,735][INFO][o.e.n.Node] [qs5K1Ku] starting ...  
[2017-09-11T14:27:32,324][INFO][o.e.t.TransportService] [qs5K1Ku] publish\_address {127.0.0.1:9300}, bound\_addresses {[::1]:9300}, {127.0.0.1:9300}  
[2017-09-11T14:27:36,515][INFO][o.e.c.s.ClusterService] [qs5K1Ku] new\_master {qs5K1Ku}{qs5K1Ku0S8ic\_FQOuqI-YQ}{nlD3EGMVT--2SVoSx5bEDA}{127.0.0.1}{12$  
[2017-09-11T14:27:37,961][INFO][o.e.h.n.Netty4HttpServerTransport] [qs5K1Ku] publish\_address {127.0.0.1:9200}, bound\_addresses {[::1]:9200}, {127.0.0.1$  
[2017-09-11T14:27:37,961][INFO][o.e.n.Node] [qs5K1Ku] started  
[2017-09-11T14:27:40,351][INFO][o.e.g.GatewayService] [qs5K1Ku] recovered [1] indices into cluster\_state  
[2017-09-11T14:27:42,347][INFO][o.e.m.j.JvmGcMonitorService] [qs5K1Ku] [gc][11] overhead, spent [628ms] collecting in the last [1.5s]  
[2017-09-11T14:27:43,485][INFO][o.e.c.r.a.AllocationService] [qs5K1Ku] Cluster health status changed from [RED] to [YELLOW] (reason: [shards started [[$

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 12, 2017, 6:13am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/6 "2017-09-12T06:13:14Z")

</div>

Yes, but there's nothing that that suggests Elasticsearch is stopping.

---

<div class="post-metadata">

**Author:** ![yrizal](https://avatars.discourse-cdn.com/v4/letter/y/b2d939/32.png) [@yrizal](https://discuss.elastic.co/u/yrizal)\
**Post date:** [September 12, 2017, 6:17am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/7 "2017-09-12T06:17:32Z")

</div>

is this the log /var/log/elasticsearch/elasaticsearch.log

2017-09-11T09:33:52,646][WARN][o.e.m.j.JvmGcMonitorService] [qs5K1Ku] [gc][young][335528][2079] duration [20.3s], collections [1]/[3.7s], total [20.3s]/[1.8m], memor memory [128.2mb]-\>[128.2mb]/[1.9gb], all\_pools {[young] [66.5mb]-\>[66.5mb]/[66.5mb]}{[survivor] [104kb]-\>[104kb]/[8.3mb]}{[old] [61.5mb]-\>[61.5mb]/[1.9gb]}  
[2017-09-11T09:35:45,970][WARN][o.e.m.j.JvmGcMonitorService] [qs5K1Ku] [gc][335528] overhead, spent [20.3s] collecting in the last [3.7s]  
[2017-09-11T14:26:54,605][INFO][o.e.n.Node] [] initializing ...  
[2017-09-11T14:26:56,242][INFO][o.e.e.NodeEnvironment] [qs5K1Ku] using [1] data paths, mounts [[/ (rootfs)]], net usable\_space [16.6gb], net total\_space [21.9gb],spins? [unknown], types [rootfs]

[2017-09-11T14:26:56,242][INFO][o.e.e.NodeEnvironment] [qs5K1Ku] heap size [1.9gb], compressed ordinary object pointers [true]  
[2017-09-11T14:26:56,393][INFO][o.e.n.Node] node name [qs5K1Ku] derived from node ID [qs5K1Ku0S8ic\_FQOuqI-YQ]; set [[node.name](http://node.name)] to override  
[2017-09-11T14:26:56,393][INFO][o.e.n.Node] version[5.5.2], pid[8869], build[b2f0c09/2017-08-14T12:33:14.154Z], OS[Linux/3.10.0-514.el7.x86\_64/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/1.8.0\_102/25.102-b14]  
[2017-09-11T14:26:56,393][INFO][o.e.n.Node] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSI$  
[2017-09-11T14:27:07,974][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [aggs-matrix-stats]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [ingest-common]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [lang-expression]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [lang-groovy]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [lang-mustache]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [lang-painless]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [parent-join]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [percolator]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [reindex]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [transport-netty3]  
[2017-09-11T14:27:07,975][INFO][o.e.p.PluginsService] [qs5K1Ku] loaded module [transport-netty4]  
[2017-09-11T14:27:07,976][INFO][o.e.p.PluginsService] [qs5K1Ku] no plugins loaded  
[2017-09-11T14:27:23,757][INFO][o.e.d.DiscoveryModule] [qs5K1Ku] using discovery type [zen]  
[2017-09-11T14:27:30,731][INFO][o.e.n.Node] initialized  
[2017-09-11T14:27:30,735][INFO][o.e.n.Node] [qs5K1Ku] starting ...  
[2017-09-11T14:27:32,324][INFO][o.e.t.TransportService] [qs5K1Ku] publish\_address {127.0.0.1:9300}, bound\_addresses {[::1]:9300}, {127.0.0.1:9300}  
[2017-09-11T14:27:36,515][INFO][o.e.c.s.ClusterService] [qs5K1Ku] new\_master {qs5K1Ku}{qs5K1Ku0S8ic\_FQOuqI-YQ}{nlD3EGMVT--2SVoSx5bEDA}{127.0.0.1}{127.0.0.1:9300}, reason: zen-disco-elected-as-master ([0] nodes joined)  
[2017-09-11T14:27:37,961][INFO][o.e.h.n.Netty4HttpServerTransport] [qs5K1Ku] publish\_address {127.0.0.1:9200}, bound\_addresses {[::1]:9200}, {127.0.0.1:9200}  
[2017-09-11T14:27:37,961][INFO][o.e.n.Node] [qs5K1Ku] started  
[2017-09-11T14:27:40,351][INFO][o.e.g.GatewayService] [qs5K1Ku] recovered [1] indices into cluster\_state  
[2017-09-11T14:27:42,347][INFO][o.e.m.j.JvmGcMonitorService] [qs5K1Ku] [gc][11] overhead, spent [628ms] collecting in the last [1.5s]  
[2017-09-11T14:27:43,485][INFO][o.e.c.r.a.AllocationService] [qs5K1Ku] Cluster health status changed from [RED] to [YELLOW] (reason: [shards started [[.kibana][0]] ...]).

---

<div class="post-metadata">

**Author:** ![yrizal](https://avatars.discourse-cdn.com/v4/letter/y/b2d939/32.png) [@yrizal](https://discuss.elastic.co/u/yrizal)\
**Post date:** [September 12, 2017, 6:19am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/8 "2017-09-12T06:19:27Z")

</div>

so, why elasticsearch status active failed??? is there anything to install

---

<div class="post-metadata">

**Author:** ![poojagupta](https://avatars.discourse-cdn.com/v4/letter/p/5daacb/32.png) [@poojagupta](https://discuss.elastic.co/u/poojagupta)\
**Post date:** [September 12, 2017, 6:22am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/9 "2017-09-12T06:22:15Z")

</div>

HI @yrizal

Sep 11 19:16:19 192.168.1.9 elasticsearch[6121]: # There is insufficient memory for the Java Run...ue.  
Sep 11 19:16:19 192.168.1.9 elasticsearch[6121]: # Native memory allocation (mmap) failed to map...ry.

Looking at this issue it seems space problem which you have given to Elasticsearch. If your VM size is not enough to work properly with elasticsearch you can customize the ES size via editing heap size in "jvm.options" file of elasticsearch.

Also for second logs which you have provide there is no full logs. Can you please provide full logs file of elasticsearch for better understanding the issue.  
Also, Make sure you installed fresh elasticsearch on new VM.  
have you created new VM or cloned previous VM? Because sometimes previous data is kept in elasticsearch folder due to this user is unable to start the service.

---

<div class="post-metadata">

**Author:** ![yrizal](https://avatars.discourse-cdn.com/v4/letter/y/b2d939/32.png) [@yrizal](https://discuss.elastic.co/u/yrizal)\
**Post date:** [September 12, 2017, 6:39am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/10 "2017-09-12T06:39:39Z")

</div>

ok I will try, but how many minimum requirements for elasticsearch

and i have 1 vm again, the first time after i install elasticsearch can work, but after install logstash, elasticsearch status active failed, with this problem,

Sep 11 14:24:40 localhost.localdomain systemd[1]: Starting Elasticsearch...  
Sep 11 14:24:40 localhost.localdomain systemd[1]: Started Elasticsearch.  
Sep 11 14:36:42 localhost.localdomain systemd[1]: elasticsearch.service: main process exited, code=killed, status=9/KILL  
Sep 11 14:36:42 localhost.localdomain systemd[1]: Unit elasticsearch.service entered failed state.  
Sep 11 14:36:42 localhost.localdomain systemd[1]: elasticsearch.service failed.

i will try re-install

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 12, 2017, 6:43am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/11 "2017-09-12T06:43:49Z")

</div>

What size is the VM? RAM, disk, CPU etc.

---

<div class="post-metadata">

**Author:** ![yrizal](https://avatars.discourse-cdn.com/v4/letter/y/b2d939/32.png) [@yrizal](https://discuss.elastic.co/u/yrizal)\
**Post date:** [September 12, 2017, 6:54am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/12 "2017-09-12T06:54:51Z")

</div>

VMware eSXi  
CPU HPproliant DL380 Gen9  
RAM 8GB  
Disk 1 TB

i used 1 vm for Elasticsearch with specification :  
Disk 30GB Thin Provisioning  
RAM 2GB

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 12, 2017, 6:55am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/13 "2017-09-12T06:55:47Z")

</div>

The default heap for Elasticsearch is 2GB, you will need to change that.

---

<div class="post-metadata">

**Author:** ![poojagupta](https://avatars.discourse-cdn.com/v4/letter/p/5daacb/32.png) [@poojagupta](https://discuss.elastic.co/u/poojagupta)\
**Post date:** [September 12, 2017, 6:59am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/14 "2017-09-12T06:59:45Z")

</div>

Make sure delete all previous data folder before installing Elasticearch.  
As you said that after installing Logstash , fail to start elasticsearch. for this better way to read the logs for logstash and elasticserach both.  
And also make sure compatible version you are installing for both.  
for checking version compatibility yiu can follow the below link:  
[https://www.elastic.co/support/matrix#show\_compatibilityhttps://www.elastic.co/support/matrix#show\_compatibility](https://www.elastic.co/support/matrix#show_compatibilityhttps://www.elastic.co/support/matrix#show_compatibility)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 10, 2017, 6:59am UTC](https://discuss.elastic.co/t/elasticsearch-status-active-failed/100143/15 "2017-10-10T06:59:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
