# Elasticsearch throwing an “OutOfMemoryError\[unable to create new native thread\]” error

**URL:** <https://discuss.elastic.co/t/elasticsearch-throwing-an-outofmemoryerror-unable-to-create-new-native-thread-error/21924>\
**Category:** Elasticsearch\
**Created:** [January 30, 2015, 4:43pm UTC](https://discuss.elastic.co/t/elasticsearch-throwing-an-outofmemoryerror-unable-to-create-new-native-thread-error/21924 "2015-01-30T16:43:08Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![bstascavage1](https://avatars.discourse-cdn.com/v4/letter/b/ea5d25/32.png) [@bstascavage1](https://discuss.elastic.co/u/bstascavage1)\
**Post date:** [January 30, 2015, 4:43pm UTC](https://discuss.elastic.co/t/elasticsearch-throwing-an-outofmemoryerror-unable-to-create-new-native-thread-error/21924/1 "2015-01-30T16:43:08Z")

</div>

We just did a rolling restart of our server, but now every few hours our  
cluster stops responding to API calls. Instead, when we make a call, I get  
a response like this:

curl -XGET '[http://localhost:9200/\_cluster/health?pretty](http://localhost:9200/_cluster/health?pretty)'  
{  
"error" : "OutOfMemoryError[unable to create new native thread]",  
"status" : 500  
}

I noticed that we can still index data fine, it seems, but cannot search or  
call any API functions. This seems to happen every few hours, and the most  
recent time it happened, there was no logs in any of the node's log files.

Our cluster is 8 nodes over 5 servers (3 servers run 2 elasticsearch  
processes, 2 run 1), running RHEL6u5. We are running Elasticsearch 1.3.4.

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c3e19365-d993-4f38-9857-a0a709546165%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c3e19365-d993-4f38-9857-a0a709546165%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:35am UTC](https://discuss.elastic.co/t/elasticsearch-throwing-an-outofmemoryerror-unable-to-create-new-native-thread-error/21924/2 "2017-07-06T00:35:37Z")

</div>


