# Elasticsearch::Transport Cannot get new connection from pool

**URL:** https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363
**Category:** Elasticsearch
**Created:** [November 11, 2015, 11:34pm UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363 "2015-11-11T23:34:21Z")
**Posts on this page:** 12
**Page:** 1

<div class="post-metadata">

### Author: ![elain](https://avatars.discourse-cdn.com/v4/letter/e/a5b964/32.png) [@elain](https://discuss.elastic.co/u/elain)
#### Post date: [November 11, 2015, 11:34pm UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363/1 "2015-11-11T23:34:21Z")

</div>

Hello everyone  
I now deployed in the AWS EC2 td-agent, used to collect logs send to elasticsearch, found every about 6 hours, the log can not be normal collection, the newspaper is as follows:  
#################################################  
2015-11-11 18:06:37 +0800 [warn]: temporarily failed to flush the buffer. next\_retry=2015-11-11 18:06:38 +0800 error\_class="Elasticsearch::Transport::Transport::Error" error="Cannot get new connection from pool." plugin\_id="object:124678c"  
2015-11-11 18:06:37 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/elasticsearch-transport-1.0.7/lib/elasticsearch/transport/transport/base.rb:179:in `perform_request' 2015-11-11 18:06:37 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/elasticsearch-transport-1.0.7/lib/elasticsearch/transport/transport/http/faraday.rb:20:in`perform\_request'  
2015-11-11 18:06:37 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/elasticsearch-transport-1.0.7/lib/elasticsearch/transport/client.rb:115:in `perform_request' 2015-11-11 18:06:37 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/elasticsearch-api-1.0.7/lib/elasticsearch/api/actions/bulk.rb:80:in`bulk'  
2015-11-11 18:06:37 +0800 [warn]: /home/work/app/td-agent/etc/plugin/out\_elasticsearch.rb:168:in `send' 2015-11-11 18:06:37 +0800 [warn]: /home/work/app/td-agent/etc/plugin/out_elasticsearch.rb:161:in`write'  
2015-11-11 18:06:37 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/fluentd-0.12.12/lib/fluent/buffer.rb:325:in `write_chunk' 2015-11-11 18:06:37 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/fluentd-0.12.12/lib/fluent/buffer.rb:304:in`pop'  
2015-11-11 18:06:37 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/fluentd-0.12.12/lib/fluent/output.rb:321:in `try_flush' 2015-11-11 18:06:37 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/fluentd-0.12.12/lib/fluent/output.rb:140:in`run'  
2015-11-11 18:06:38 +0800 [warn]: temporarily failed to flush the buffer. next\_retry=2015-11-11 18:06:40 +0800 error\_class="Elasticsearch::Transport::Transport::Error" error="Cannot get new connection from pool." plugin\_id="object:124678c"  
2015-11-11 18:06:38 +0800 [warn]: suppressed same stacktrace  
2015-11-11 18:06:40 +0800 [warn]: temporarily failed to flush the buffer. next\_retry=2015-11-11 18:06:44 +0800 error\_class="Elasticsearch::Transport::Transport::Error" error="Cannot get new connection from pool." plugin\_id="object:124678c"  
2015-11-11 18:06:40 +0800 [warn]: suppressed same stacktrace  
2015-11-11 18:06:44 +0800 [warn]: temporarily failed to flush the buffer. next\_retry=2015-11-11 18:06:52 +0800 error\_class="Elasticsearch::Transport::Transport::Error" error="Cannot get new connection from pool." plugin\_id="object:124678c"  
2015-11-11 18:06:44 +0800 [warn]: suppressed same stacktrace  
2015-11-11 18:06:52 +0800 [warn]: temporarily failed to flush the buffer. next\_retry=2015-11-11 18:07:06 +0800 error\_class="Elasticsearch::Transport::Transport::Error" error="Cannot get new connection from pool." plugin\_id="object:124678c"  
2015-11-11 18:06:52 +0800 [warn]: suppressed same stacktrace  
2015-11-11 18:07:06 +0800 [warn]: temporarily failed to flush the buffer. next\_retry=2015-11-11 18:07:37 +0800 error\_class="Elasticsearch::Transport::Transport::Error" error="Cannot get new connection from pool." plugin\_id="object:124678c"  
#################################################

My configuration is as follows:  
#################################################  
type elasticsearch  
host 10.0.0.52  
port 9200  
path /  
logstash\_format true  
utc\_index false  
flush\_interval 3s  
include\_tag\_key true  
tag\_key tag  
buffer\_type memory  
buffer\_chunk\_limit 256m  
buffer\_queue\_limit 128  
disable\_retry\_limit false  
retry\_limit 17  
retry\_wait 1s  
num\_threads 5  
#################################################

Help me see what is the cause?

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [November 12, 2015, 2:02am UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363/2 "2015-11-12T02:02:09Z")

</div>

What do the logs for one of the nodes show?

---

<div class="post-metadata">

### Author: ![elain](https://avatars.discourse-cdn.com/v4/letter/e/a5b964/32.png) [@elain](https://discuss.elastic.co/u/elain)
#### Post date: [November 12, 2015, 3:24am UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363/4 "2015-11-12T03:24:44Z")

</div>

This is an error in the daily newspaper, no special error log when the fault occurs.

[2015-11-12 03:48:45,399][DEBUG][action.bulk] [10.64.1.218] [ngx\_log\_i18n\_order-2015.11.12][1] failed to execute bulk item (index) index {[ngx\_log\_i18n\_order-2  
015.11.12][fluentd][AVD4F97T9BcHxEWJ1zx5], source[{"client\_ip":"2a02:120b:2c28:9b00:b901:9bc1:23c0:e5b1","domain":"[m.buy.xx.com](http://m.buy.xx.com)","method":"GET","url":"/in/misc/getstarstock/  
?hd\_id=miband&\_=1447271320698&jsonpcallback=jsonp1","http\_code":"200","http\_length":"972","referer":"[http://mobile.xx.com/in/miband/","ua":"Mozilla/5.0](http://mobile.xx.com/in/miband/%22,%22ua%22:%22Mozilla/5.0) (Linux; Android 5.0.2  
; LG-D802 Build/LRX22G) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.76 Mobile Safari/537.36","proxy\_ip":"10.64.10.244","request\_time":"0.036","response\_time":"0.  
036","custom\_status":"0","userid":"","logid":"682324803920","ua\_name":"Chrome","ua\_category":"smartphone","ua\_os":"Android","ua\_version":"46.0.2490.76","ua\_vendor":"Google",  
"hostname":"sgpaws-b2corder-web12.mias","hostip":"10.64.11.167","tag":"ngx\_log\_kafka","@timestamp":"2015-11-12T03:48:44+08:00"}]}  
MapperParsingException[failed to parse [client\_ip]]; nested: IllegalArgumentException[failed to parse ip [2a02:120b:2c28:9b00:b901:9bc1:23c0:e5b1], not a valid ipv4 address  
(4 dots)];  
at org.elasticsearch.index.mapper.FieldMapper.parse(FieldMapper.java:339)  
at org.elasticsearch.index.mapper.DocumentParser.parseObjectOrField(DocumentParser.java:314)  
at org.elasticsearch.index.mapper.DocumentParser.parseValue(DocumentParser.java:441)  
at org.elasticsearch.index.mapper.DocumentParser.parseObject(DocumentParser.java:267)  
at org.elasticsearch.index.mapper.DocumentParser.innerParseDocument(DocumentParser.java:128)  
at org.elasticsearch.index.mapper.DocumentParser.parseDocument(DocumentParser.java:79)  
at org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:318)  
at org.elasticsearch.index.shard.IndexShard.prepareCreate(IndexShard.java:503)  
at org.elasticsearch.index.shard.IndexShard.prepareCreate(IndexShard.java:494)  
at org.elasticsearch.action.support.replication.TransportReplicationAction.prepareIndexOperationOnPrimary(TransportReplicationAction.java:1052)  
at org.elasticsearch.action.support.replication.TransportReplicationAction.executeIndexRequestOnPrimary(TransportReplicationAction.java:1060)  
at org.elasticsearch.action.bulk.TransportShardBulkAction.shardIndexOperation(TransportShardBulkAction.java:338)  
at org.elasticsearch.action.bulk.TransportShardBulkAction.shardOperationOnPrimary(TransportShardBulkAction.java:131)  
at org.elasticsearch.action.support.replication.TransportReplicationAction$PrimaryPhase.performOnPrimary(TransportReplicationAction.java:579)  
at org.elasticsearch.action.support.replication.TransportReplicationAction$PrimaryPhase$1.doRun(TransportReplicationAction.java:452)  
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: java.lang.IllegalArgumentException: failed to parse ip [2a02:120b:2c28:9b00:b901:9bc1:23c0:e5b1], not a valid ipv4 address (4 dots)  
at org.elasticsearch.index.mapper.ip.IpFieldMapper.ipToLong(IpFieldMapper.java:82)  
at org.elasticsearch.index.mapper.ip.IpFieldMapper.innerParseCreateField(IpFieldMapper.java:271)  
at org.elasticsearch.index.mapper.core.NumberFieldMapper.parseCreateField(NumberFieldMapper.java:213)  
at org.elasticsearch.index.mapper.FieldMapper.parse(FieldMapper.java:331)  
... 18 more

---

<div class="post-metadata">

### Author: ![elain](https://avatars.discourse-cdn.com/v4/letter/e/a5b964/32.png) [@elain](https://discuss.elastic.co/u/elain)
#### Post date: [November 12, 2015, 3:25am UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363/5 "2015-11-12T03:25:46Z")

</div>

[2015-11-12 11:14:25,544][DEBUG][action.bulk] [10.64.1.218] [ngx\_log\_i18n\_order-2015.11.12][1] failed to execute bulk item (index) index {[ngx\_log\_i18n\_order-2  
015.11.12][fluentd][AVD5r-SY9BcHxEWJ3MOs], source[{"client\_ip":"unknown","domain":"[buy.xx.com](http://buy.xx.com)","method":"GET","url":"/hk/event/selectPacket/goodsId/4154500008","http\_code":"  
200","http\_length":"44370","referer":"-","ua":"Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36","proxy\_ip":"10.64.10.23  
0","request\_time":"0.008","response\_time":"0.008","custom\_status":"0","userid":"165830530","logid":"953064857145","ua\_name":"Chrome","ua\_category":"pc","ua\_os":"Windows XP",  
"ua\_version":"46.0.2490.80","ua\_vendor":"Google","hostname":"sgpaws-b2c-order-web04.mias","hostip":"10.64.11.163","tag":"ngx\_log\_kafka","@timestamp":"2015-11-12T11:14  
:24+08:00"}]}  
MapperParsingException[failed to parse [client\_ip]]; nested: IllegalArgumentException[failed to parse ip [unknown], not a valid ip address];  
at org.elasticsearch.index.mapper.FieldMapper.parse(FieldMapper.java:339)  
at org.elasticsearch.index.mapper.DocumentParser.parseObjectOrField(DocumentParser.java:314)  
at org.elasticsearch.index.mapper.DocumentParser.parseValue(DocumentParser.java:441)  
at org.elasticsearch.index.mapper.DocumentParser.parseObject(DocumentParser.java:267)  
at org.elasticsearch.index.mapper.DocumentParser.innerParseDocument(DocumentParser.java:128)  
at org.elasticsearch.index.mapper.DocumentParser.parseDocument(DocumentParser.java:79)  
at org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:318)  
at org.elasticsearch.index.shard.IndexShard.prepareCreate(IndexShard.java:503)  
at org.elasticsearch.index.shard.IndexShard.prepareCreate(IndexShard.java:494)  
at org.elasticsearch.action.support.replication.TransportReplicationAction.prepareIndexOperationOnPrimary(TransportReplicationAction.java:1052)  
at org.elasticsearch.action.support.replication.TransportReplicationAction.executeIndexRequestOnPrimary(TransportReplicationAction.java:1060)  
at org.elasticsearch.action.bulk.TransportShardBulkAction.shardIndexOperation(TransportShardBulkAction.java:338)  
at org.elasticsearch.action.bulk.TransportShardBulkAction.shardOperationOnPrimary(TransportShardBulkAction.java:131)  
at org.elasticsearch.action.support.replication.TransportReplicationAction$PrimaryPhase.performOnPrimary(TransportReplicationAction.java:579)  
at org.elasticsearch.action.support.replication.TransportReplicationAction$PrimaryPhase$1.doRun(TransportReplicationAction.java:452)  
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: java.lang.IllegalArgumentException: failed to parse ip [unknown], not a valid ip address  
at org.elasticsearch.index.mapper.ip.IpFieldMapper.ipToLong(IpFieldMapper.java:78)  
at org.elasticsearch.index.mapper.ip.IpFieldMapper.innerParseCreateField(IpFieldMapper.java:271)  
at org.elasticsearch.index.mapper.core.NumberFieldMapper.parseCreateField(NumberFieldMapper.java:213)  
at org.elasticsearch.index.mapper.FieldMapper.parse(FieldMapper.java:331)  
... 18 more

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [November 12, 2015, 3:39am UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363/6 "2015-11-12T03:39:03Z")

</div>

Ip type does not support IPV6.

---

<div class="post-metadata">

### Author: ![elain](https://avatars.discourse-cdn.com/v4/letter/e/a5b964/32.png) [@elain](https://discuss.elastic.co/u/elain)
#### Post date: [November 12, 2015, 9:27am UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363/7 "2015-11-12T09:27:11Z")

</div>

Thank you, I know this meaning, because IPv6 does not support the newspaper is wrong, you can lead me to start to say that the error? Data cannot be written to ES

It is impossible because the IPv6 does not support, and so that the client can not write data to the ES cluster, right?

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [November 12, 2015, 9:49am UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363/8 "2015-11-12T09:49:19Z")

</div>

Sorry. I just answered to what the DEBUG log means here. It means that in your mapping you defined a field as `ip` but `ip` supports only IPV4: [https://www.elastic.co/guide/en/elasticsearch/reference/current/ip.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/ip.html)

I have no idea about the error messages you have on the client. (I even don't know what kind of client you are using)

---

<div class="post-metadata">

### Author: ![elain](https://avatars.discourse-cdn.com/v4/letter/e/a5b964/32.png) [@elain](https://discuss.elastic.co/u/elain)
#### Post date: [November 12, 2015, 11:31pm UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363/9 "2015-11-12T23:31:05Z")

</div>

MY elasticsearch version 2.0.0

my client is fluentd(td-agent)

error log:  
2015-11-09 01:59:02 +0800 [info]: following tail of /home/work/logs/nginx/sgp.shopapi.b2c.srv.log  
2015-11-09 01:59:02 +0800 [info]: detected rotation of /home/work/logs/nginx/sgp.shopapi.notify.b2c.srv.log; waiting 5 seconds  
2015-11-09 01:59:02 +0800 [info]: following tail of /home/work/logs/nginx/sgp.shopapi.notify.b2c.srv.log  
2015-11-09 02:00:04 +0800 [warn]: temporarily failed to flush the buffer. next\_retry=2015-11-09 02:00:05 +0800 error\_class="Elasticsearch::Transport::Transport::Error" error="Cannot get new connection from pool." plugin\_id="object:150df38"  
2015-11-09 02:00:04 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/elasticsearch-transport-1.0.7/lib/elasticsearch/transport/transport/base.rb:179:in `perform_request' 2015-11-09 02:00:04 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/elasticsearch-transport-1.0.7/lib/elasticsearch/transport/transport/http/faraday.rb:20:in`perform\_request'  
2015-11-09 02:00:04 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/elasticsearch-transport-1.0.7/lib/elasticsearch/transport/client.rb:115:in `perform_request' 2015-11-09 02:00:04 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/elasticsearch-api-1.0.7/lib/elasticsearch/api/actions/bulk.rb:80:in`bulk'  
2015-11-09 02:00:04 +0800 [warn]: /home/work/app/td-agent/etc/plugin/out\_elasticsearch.rb:168:in `send' 2015-11-09 02:00:04 +0800 [warn]: /home/work/app/td-agent/etc/plugin/out_elasticsearch.rb:161:in`write'  
2015-11-09 02:00:04 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/fluentd-0.12.12/lib/fluent/buffer.rb:325:in `write_chunk' 2015-11-09 02:00:04 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/fluentd-0.12.12/lib/fluent/buffer.rb:304:in`pop'  
2015-11-09 02:00:04 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/fluentd-0.12.12/lib/fluent/output.rb:321:in `try_flush' 2015-11-09 02:00:04 +0800 [warn]: /home/work/app/td-agent/embedded/lib/ruby/gems/2.1.0/gems/fluentd-0.12.12/lib/fluent/output.rb:140:in`run'  
2015-11-09 02:00:05 +0800 [warn]: temporarily failed to flush the buffer. next\_retry=2015-11-09 02:00:07 +0800 error\_class="Elasticsearch::Transport::Transport::Error" error="Cannot get new connection from pool." plugin\_id="object:150df38"  
2015-11-09 02:00:05 +0800 [warn]: suppressed same stacktrace  
2015-11-09 02:00:07 +0800 [warn]: temporarily failed to flush the buffer. next\_retry=2015-11-09 02:00:11 +0800 error\_class="Elasticsearch::Transport::Transport::Error" error="Cannot get new connection from pool." plugin\_id="object:150df38"  
2015-11-09 02:00:07 +0800 [warn]: suppressed same stacktrace  
2015-11-09 02:00:11 +0800 [warn]: temporarily failed to flush the buffer. next\_retry=2015-11-09 02:00:19 +0800 error\_class="Elasticsearch::Transport::Transport::Error" error="Cannot get new connection from pool." plugin\_id="object:150df38"  
2015-11-09 02:00:11 +0800 [warn]: suppressed same stacktrace  
2015-11-09 02:00:19 +0800 [warn]: temporarily failed to flush the buffer. next\_retry=2015-11-09 02:00:36 +0800 error\_class="Elasticsearch::Transport::Transport::Error" error="Cannot get new connection from pool." plugin\_id="object:150df38"  
2015-11-09 02:00:19 +0800 [warn]: suppressed same stacktrace  
2015-11-09 02:00:36 +0800 [warn]: temporarily failed to flush the buffer. next\_retry=2015-11-09 02:01:11 +0800 error\_class="Elasticsearch::Transport::Transport::Error" error="Cannot get new connection from pool." plugin\_id="object:150df38"  
2015-11-09 02:00:36 +0800 [warn]: suppressed same stacktrace

---

<div class="post-metadata">

### Author: ![repeatedly](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/repeatedly/32/6329_2.png) [@repeatedly](https://discuss.elastic.co/u/repeatedly)
#### Post date: [December 2, 2015, 4:03pm UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363/10 "2015-12-02T16:03:58Z")

</div>

When "Cannot get new connection from pool" error happen with elasticsearch-ruby?  
fluent-plugin-elasticsearch code is here: [https://github.com/uken/fluent-plugin-elasticsearch/blob/e44f323c99f3a5aca29b569023b846c1111f87da/lib/fluent/plugin/out\_elasticsearch.rb#L52](https://github.com/uken/fluent-plugin-elasticsearch/blob/e44f323c99f3a5aca29b569023b846c1111f87da/lib/fluent/plugin/out_elasticsearch.rb#L52)

Is this code wrong?  
I want to know this error is fluent-plugin-elasticsearch problem or not.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [December 2, 2015, 8:40pm UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363/11 "2015-12-02T20:40:00Z")

</div>

Please start your own thread.

---

<div class="post-metadata">

### Author: ![repeatedly](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/repeatedly/32/6329_2.png) [@repeatedly](https://discuss.elastic.co/u/repeatedly)
#### Post date: [December 3, 2015, 7:50am UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363/12 "2015-12-03T07:50:41Z")

</div>

Okay. I just opened new topic: [Elasitcsearch-ruby raises "Cannot get new connection from pool" error](https://discuss.elastic.co/t/elasitcsearch-ruby-raises-cannot-get-new-connection-from-pool-error/36252)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 11:33pm UTC](https://discuss.elastic.co/t/elasticsearch-transport-cannot-get-new-connection-from-pool/34363/13 "2017-07-05T23:33:58Z")

</div>


